Apport's recommendation of Ask Ubuntu is misdirecting bug traffic

Bug #991602 reported by Jorge Castro on 2012-04-30
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xdiagnose (Ubuntu)
Wishlist
Unassigned
Oneiric
Undecided
Unassigned
Precise
Wishlist
Unassigned
Quantal
Wishlist
Unassigned

Bug Description

[Impact]
The X and compiz apport hooks direct users to Ask Ubuntu for technical support before filing a bug report. However, this results in many users going to AskUbuntu for problems that the AskUbuntu gang feel unable to help with.

[Development Fix]
No changes required for development. The Ubuntu-X team provides support for users of the development release.

[Stable Fix]
* Point user to all technical support options, not just Ask Ubuntu specifically.
* Reword recommendation to explain why technical support should be used first.
* Add a 'referred-by-support' tag so triagers can give those bugs priority attention.
* Provide an option to just file the bug, for cases where the user knows they don't need technical support.

[Test Case]
1. ubuntu-bug xorg
2. Follow dialog through to the technical support page
3. Pick "Please point me to where I can get technical support."

Broken Behavior: Dialog pops up pointing user to http://askubuntu.com.
Fixed Behavior: Dialog pops up pointing user to http://www.ubuntu.com/support.

[Regression Potential]
As this is a change to the xorg apport hook, technical problems to look for include irregularities in bug reporting against compiz, unity, or any xorg package. Testing that filing a bug and going past the aforementioned dialogs should be sufficient to prove the change works without regression.

Non-technical problems to watch for are if users with X problems are more likely or less likely to get the help they need with this change in place. For example, by pointing them to a generic support page rather than a specific help site, will they simply give up, or will they drill down and find the help they need? (From my review, only the AskUbuntu link resulted in actually relevant and effective advice, but even so was still fairly hit or miss. If this holds true in general, then this change may be merely raising the bar to getting help, rather than actually addressing the problem.)

[Original Report]
"Ask Ubuntu is the best place to get free technical support"

While this is sort of true it's vague. Bug reports and crashers are offtopic for a Q+A site, so they are usually closed pretty fast and the user is sent to launchpad so that their bug can be properly handled, so Apport probably shouldn't send people there at all.

Perhaps just linking to http://www.ubuntu.com/support/community is best.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Martin Pitt (pitti) on 2012-05-02
affects: apport → launchpad-integration (Ubuntu)
Changed in launchpad-integration (Ubuntu):
status: New → Confirmed
Changed in launchpad-integration (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

not sure where it's coming from but it seems "not apport, not launchpad-integration" ... having steps to trigger that dialog would help

affects: launchpad-integration (Ubuntu) → ubuntu
affects: ubuntu → xdiagnose (Ubuntu)
Jorge Castro (jorge) wrote :

Bryce (or whoever is also working on X),

This is becoming troublesome because AU is starting to get a bunch of bug reports instead of questions and it's starting to affect the quality of the site and it's becoming more burdensome to continually police these up.

When we instruct people to instead post their bug report to launchpad they tell us launchpad sent them there, so it's stuck in a vicious loop right now. If we could reword this text (is an SRU out of the question?) so we're not blanket telling people to just go to askubuntu it would really help out. Thanks!

Sebastien Bacher (seb128) wrote :

the exact message seems to be:

" else:
            ui.information("http://askubuntu.com is the best place to get free help with technical issues.\n\n"
                           "See http://www.ubuntu.com/support for paid support and other free options.")
            report['UnreportableReason'] = 'Please work this issue through technical support channels first.'"

it's from source_xorg.py apport's hook

Bryce Harrington (bryce) on 2012-06-15
description: updated
Changed in xdiagnose (Ubuntu Quantal):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Changed in xdiagnose (Ubuntu Precise):
status: New → Won't Fix
Bryce Harrington (bryce) on 2012-06-15
description: updated
description: updated

Hello Jorge, or anyone else affected,

Accepted xdiagnose into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Bryce Harrington (bryce) on 2012-06-19
Changed in xdiagnose (Ubuntu Quantal):
status: Triaged → Fix Committed
Changed in xdiagnose (Ubuntu Precise):
status: Won't Fix → Fix Committed
importance: Undecided → Wishlist
hexafraction (rarkenin) on 2012-06-20
summary: - Apport's recommendation of Ask Ubuntu is vague
+ Apport's recommendation of Ask Ubuntu is misdirecting bug traffic
Bryce Harrington (bryce) wrote :

xdiagnose (2.5.1) precise-proposed; urgency=low

  * xdiagnose.udev: Disable GPU apport hook from being triggered by udev.
    This should only be enabled during the development period. Apport is
    disabled after release, but it appears the hook still gets triggered
    under certain circumstances.
    (LP: #1009971, #997470)
  * apport/source_xorg.py: Link to all technical support options, not just
    to Ask Ubuntu. Reword recommendation to explain why technical support
    should be used first. Add a 'referred-by-support' tag so we can give
    those bugs priority attention. Provide an option to just file the bug.
    (LP: #991602)

 -- Bryce Harrington <email address hidden> Fri, 15 Jun 2012 11:39:10 -0700

Bryce Harrington (bryce) wrote :

#1009971 / #997470 was validated several days ago and is pretty critical for us to get out, but this SRU is blocked due to no one having validated this one (#991602). I'm actually surprised there's been no comment at all one way or the other.

If no one can validate this fix ASAP, I'll split out the validated fix to its own SRU and get that one in at least.

I can confirm that the version in proposed resolves this issue. Screenshot from proposed version with link to www.ubuntu.com/support and not AskUbuntu attached.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.5.1

---------------
xdiagnose (2.5.1) precise-proposed; urgency=low

  * xdiagnose.udev: Disable GPU apport hook from being triggered by udev.
    This should only be enabled during the development period. Apport is
    disabled after release, but it appears the hook still gets triggered
    under certain circumstances.
    (LP: #1009971, #997470)
  * apport/source_xorg.py: Link to all technical support options, not just
    to Ask Ubuntu. Reword recommendation to explain why technical support
    should be used first. Add a 'referred-by-support' tag so we can give
    those bugs priority attention. Provide an option to just file the bug.
    (LP: #991602)
 -- Bryce Harrington <email address hidden> Fri, 15 Jun 2012 11:39:10 -0700

Changed in xdiagnose (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.9

---------------
xdiagnose (2.9) quantal; urgency=low

  * xdiagnose.udev: Make the GPU apport hook trigger on RESET=1 rather
    than ERROR=1, as an attempt to prevent capturing bug reports on false
    gpu lockups.
    (LP: #983640)
  * apport/source_xorg.py:
    - Link to all technical support options, not just to Ask Ubuntu.
      Reword recommendation to explain why technical support should be used
      first. Add a 'referred-by-support' tag so we can give those bugs
      priority attention. Provide an option to just file the bug.
      (LP: #991602)
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
  * xdiagnose.desktop.in: Move xdiagnose to System/Settings menu. Provide
    a GenericName. Set the gettext domain.
  * debian/control: Add runtime dependency on librsvg2, required for
    displaying SVG icons.
    (LP: #969603)
  *
 -- Bryce Harrington <email address hidden> Tue, 19 Jun 2012 14:26:04 -0700

Changed in xdiagnose (Ubuntu Quantal):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Hello Jorge, or anyone else affected,

Accepted xdiagnose into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xdiagnose/1.6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xdiagnose (Ubuntu Oneiric):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Ishaan Dalal (izx) on 2012-08-10
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 1.6.1

---------------
xdiagnose (1.6.1) oneiric-proposed; urgency=low

  * apport/source_xorg.py:
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
    - Link to all technical support options, not just to Ask Ubuntu.
      (LP: #991602)
 -- Bryce Harrington <email address hidden> Wed, 27 Jun 2012 10:47:58 -0700

Changed in xdiagnose (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers