xdiagnose crashed with GError in constructor(): Couldn't recognize the image file format for file '/usr/share/xdiagnose/icons/microscope.svg'

Bug #969603 reported by Bernd Kramer on 2012-03-30
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xdiagnose (Ubuntu)
Medium
Unassigned

Bug Description

n/a

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xdiagnose 2.3
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CompositorRunning: kwin
Date: Fri Mar 30 23:03:23 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: kubuntu
DkmsStatus: nvidia-current, 295.33, 3.2.0-20-generic, x86_64: installed
ExecutablePath: /usr/bin/xdiagnose
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228.1)
InterpreterPath: /usr/bin/python2.7
MachineType: BIOSTAR Group N61PB-M2S
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/xdiagnose
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=aa0fa0b3-7121-4bf6-b8d7-1d00f131c39f ro quiet splash vt.handoff=7
PythonArgs: ['/usr/bin/xdiagnose']
SourcePackage: xdiagnose
Title: xdiagnose crashed with GError in constructor(): Couldn't recognize the image file format for file '/usr/share/xdiagnose/icons/microscope.svg'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 05/06/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: N61PB-M2S
dmi.board.vendor: BIOSTAR Group
dmi.chassis.type: 3
dmi.chassis.vendor: BIOSTAR Group
dmi.chassis.version: N61PB-M2S
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd05/06/2009:svnBIOSTARGroup:pnN61PB-M2S:pvr:rvnBIOSTARGroup:rnN61PB-M2S:rvr:cvnBIOSTARGroup:ct3:cvrN61PB-M2S:
dmi.product.name: N61PB-M2S
dmi.sys.vendor: BIOSTAR Group
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Bernd Kramer (l6o0) wrote :
tags: removed: need-duplicate-check
Bryce Harrington (bryce) on 2012-04-04
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdiagnose (Ubuntu):
status: New → Confirmed
Changed in xdiagnose (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) on 2012-06-19
Changed in xdiagnose (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.9

---------------
xdiagnose (2.9) quantal; urgency=low

  * xdiagnose.udev: Make the GPU apport hook trigger on RESET=1 rather
    than ERROR=1, as an attempt to prevent capturing bug reports on false
    gpu lockups.
    (LP: #983640)
  * apport/source_xorg.py:
    - Link to all technical support options, not just to Ask Ubuntu.
      Reword recommendation to explain why technical support should be used
      first. Add a 'referred-by-support' tag so we can give those bugs
      priority attention. Provide an option to just file the bug.
      (LP: #991602)
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
  * xdiagnose.desktop.in: Move xdiagnose to System/Settings menu. Provide
    a GenericName. Set the gettext domain.
  * debian/control: Add runtime dependency on librsvg2, required for
    displaying SVG icons.
    (LP: #969603)
  *
 -- Bryce Harrington <email address hidden> Tue, 19 Jun 2012 14:26:04 -0700

Changed in xdiagnose (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.