apport hook tags too many bugs regression-update

Bug #1018510 reported by Brian Murray on 2012-06-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdiagnose (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
High
Unassigned

Bug Description

The stable release update team has subscribed to bug reports that are tagged either regression-proposed or regression-update and has noticed that quite a few bugs are tagged regression-update which should not be.

The question in xdiagnose that leads to tagging bugs regression-update is a bit ambiguous:

"The problem began right after system software update"

This could mean either installing a package from -updates or happened after upgrading from one release to another. Due to the quantity of false positives the best thing seems to be just to remove the question.

This should be SRU'ed for both Oneiric and Precise.

TEST CASE:
1) run ubuntu-bug xorg
2) At the first dialog box you will see a radio button labelled:
   'Continue. The problem began right after system software update.'

In the proposed version of the package this question should not appear.

REGRESSION POTENTIAL:
This question just affects the tags being added to the bug and no regression in functionality of the apport hook is possible.

Bryce Harrington (bryce) on 2012-06-27
Changed in xdiagnose (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → High
Bryce Harrington (bryce) wrote :

Fixed by just dropping the question.

This removes the feature for indicating possible regressions, so if that's useful to anyone it'll need to be identified some other way.

Bryce Harrington (bryce) on 2012-06-27
Changed in xdiagnose (Ubuntu Oneiric):
status: New → Fix Committed
description: updated

Hello Brian, or anyone else affected,

Accepted xdiagnose into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xdiagnose/2.5.2 in a few hours and then in the -proposed repository.

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.9

---------------
xdiagnose (2.9) quantal; urgency=low

  * xdiagnose.udev: Make the GPU apport hook trigger on RESET=1 rather
    than ERROR=1, as an attempt to prevent capturing bug reports on false
    gpu lockups.
    (LP: #983640)
  * apport/source_xorg.py:
    - Link to all technical support options, not just to Ask Ubuntu.
      Reword recommendation to explain why technical support should be used
      first. Add a 'referred-by-support' tag so we can give those bugs
      priority attention. Provide an option to just file the bug.
      (LP: #991602)
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
  * xdiagnose.desktop.in: Move xdiagnose to System/Settings menu. Provide
    a GenericName. Set the gettext domain.
  * debian/control: Add runtime dependency on librsvg2, required for
    displaying SVG icons.
    (LP: #969603)
  *
 -- Bryce Harrington <email address hidden> Tue, 19 Jun 2012 14:26:04 -0700

Changed in xdiagnose (Ubuntu):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

Brian, is there any chance you could verify that SRU?

Sebastien Bacher (seb128) wrote :

in fact that's easy to verify, just done that

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.5.2

---------------
xdiagnose (2.5.2) precise-proposed; urgency=low

  * apport/source_xorg.py:
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
 -- Bryce Harrington <email address hidden> Wed, 27 Jun 2012 10:18:45 -0700

Changed in xdiagnose (Ubuntu Precise):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Hello Brian, or anyone else affected,

Accepted xdiagnose into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xdiagnose/1.6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 1.6.1

---------------
xdiagnose (1.6.1) oneiric-proposed; urgency=low

  * apport/source_xorg.py:
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
    - Link to all technical support options, not just to Ask Ubuntu.
      (LP: #991602)
 -- Bryce Harrington <email address hidden> Wed, 27 Jun 2012 10:47:58 -0700

Changed in xdiagnose (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers