xdg-open depends on gnome-open, but it's not on the CD

Bug #804397 reported by Chad A. Davis on 2011-07-01
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Checkbox
Undecided
Unassigned
gvfs (Ubuntu)
High
Chris Coulson
Oneiric
High
Chris Coulson
xdg-utils (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

I discovered this while running checkbox from the Oneiric live CD (daily ISO 2011-07-01), because it uses xdg-open, which in turn requires gnome-open, to launch the application associated with a certain file type.

ubuntu@ubuntu:/usr/share/checkbox/data/images$ xdg-open *png
/usr/bin/xdg-open: 563: gnome-open: not found

gnome-open is currently available in libgnome2-0 but I imagine that is not supposed to be included on the CD. Will there be a Gnome3 replacement for gnome-open? I.e. is this a Gnome bug or a xdg-utils bug?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xdg-utils 1.1.0~rc1-2ubuntu3
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic x86_64
Architecture: amd64
Date: Fri Jul 1 17:58:09 2011
Dependencies:

LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110701)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xdg-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Kiwinote (kiwinote) wrote :

I can confirm that I get this same error from xdg-open on a fresh install of oneiric which hence also affects software-center and the likes.

tags: added: needs-reassignment
Sebastien Bacher (seb128) wrote :

Confirmed, it does suggests gvfs-bin but should probably recommends it instead to bring it on the CD

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Daniel Manrique (roadmr) wrote :

Hi,

Since it looks like checkbox is just an innocent victim here, I'll mark its task invalid. However, if it is determined that xdg-open is no longer the recommended way to open documents (which is what checkbox uses it for), please reopen the task so we can look at and perform any required changes.

Thanks!

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in checkbox:
status: New → Invalid
Bryce Harrington (bryce) wrote :

[Unsubbing sponsors since no patch or merge proposal was included. Perhaps a MIR is needed instead.]

James Westby (james-w) on 2011-07-21
Changed in xdg-utils (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-1
RedSingularity (redsingularity) wrote :

Problem also confirmed in update-manager version 152.7
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Doug McMahon (mc3man) wrote :

Just to add - the opening of the trash from unity launcher also requires (libgnome2
Bug #802964

Alex Solanos (hakermania) wrote :

So what's the proper way to open a file/url with the default application chosen by the user? xdg-open relies on gnome-open and these where the only ones I knew...

MestreLion (mestrelion) wrote :

@alexol: xdg-open does not rely on gnome-open anymore (since lucid i guess)... it only uses is as a fallback. In a default ubuntu install xdg-open uses gvfs-open to launch files.

Martin Pitt (pitti) wrote :

We'll add a recommends of gvfs-bin to gvfs, so that this will work for all desktops using gvfs (GNOME, XFCE, etc.), without pulling gvfs into e. g. Kubuntu.

Changed in gvfs (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in xdg-utils (Ubuntu Oneiric):
status: Confirmed → Won't Fix
milestone: ubuntu-11.10-beta-1 → none
importance: High → Low
Changed in xdg-utils (Ubuntu):
importance: High → Low
status: Confirmed → Triaged
Changed in gvfs (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-1
Changed in xdg-utils (Ubuntu):
milestone: ubuntu-11.10-beta-1 → none
Martin Pitt (pitti) on 2011-08-26
Changed in gvfs (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.9.3-0ubuntu2

---------------
gvfs (1.9.3-0ubuntu2) oneiric; urgency=low

  * Fix LP: #804397 - Make gvfs recommend gvfs-bin, so xdg-open works
    in the default install
 -- Chris Coulson <email address hidden> Fri, 26 Aug 2011 10:43:37 +0200

Changed in gvfs (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers