xdg-settings fails: awk: cannot open /home/user/.local/share/applications/mimeapps.list (No such file or directory)

Bug #776261 reported by Chris West on 2011-05-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdg-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xdg-utils

After upgrade, everything apart from Gnome Terminal honours my browser preference of "please, daddy, anything but firefox".

To rectify this, I tried:
faux@wilf:~% xdg-settings set default-web-browser google-chrome.desktop

Which prints:
awk: cannot open /home/faux/.local/share/applications/mimeapps.list (No such file or directory)
awk: cannot open /home/faux/.local/share/applications/mimeapps.list (No such file or directory)

And exits with exit status 4; having not worked.

Touching the named file fixes the problem.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xdg-utils 1.1.0~rc1-2ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: b0d31efda01870980e2e5a89390b685c
CheckboxSystem: 6ce041aeed0a2c17b3343b66d157175d
Date: Tue May 3 11:01:39 2011
Dependencies:

EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/zsh
SourcePackage: xdg-utils
UpgradeStatus: Upgraded to natty on 2011-05-03 (0 days ago)

Marc Bowes (marcbowes) wrote :

I too am affected by this bug. Touching the file resolved the issue for me.
I am on i686 and its a 10.10-upgraded install of Natty (Unity).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers