Ubuntu

xdg-mime query filetype FILE: no output at all

Reported by Romano Giannetti on 2010-07-07
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Xdg-utils
Fix Released
Medium
xdg-utils (Debian)
Fix Released
Unknown
xdg-utils (Ubuntu)
Medium
Scott Ritchie

Bug Description

Binary package hint: xdg-utils

The summary is quite clear. In Lucid Lynx, if I issue

xdg-mime query filetype ./myfile.pdf

I have no error but no output (I expected application/pdf). On the other hand,

xdg-open ./myfile.pdf

do work.

Related branches

Dan Cruz (dan-cruzalong) wrote :

I have also experienced this problem under Lucid where:

xdg-mime query filetype /bin/true

does not output any information. I tried:

XDG_UTILS_DEBUG_LEVEL=1 xdg-mime query filetype /bin/true

and did get a message

Running gnomevfs-info "/bin/true"

However, gnomevfs-info is not available on my PATH. The package libgnomevfs2-bin contains the /usr/bin/gnomevfs-info file, but this package was not installed. After installing libgnomevfs2-bin:

xdg-mime query filetype /bin/true

displays

application/octet-stream

The xdg-utils package lists libgnomevfs2-bin as a suggested package.

I update to Maverick (no manual installation of libgnomevfs2-bin) and all is well.

Changed in xdg-utils (Ubuntu):
status: New → Fix Released
Damjan Jovanovic (damjan-jov) wrote :

This is definitely NOT fixed on Maverick (x86_64):

$ xdg-mime query filetype file.txt
$ export XDG_UTILS_DEBUG_LEVEL=10
$ xdg-mime query filetype file.txt
Running gnomevfs-info "/home/user/file.txt"

There is no gnomevfs-info installed:

$ gnomevfs-info
The program 'gnomevfs-info' is currently not installed. You can install it by typing:
sudo apt-get install libgnomevfs2-bin

Scott Ritchie (scottritchie) wrote :

In Maverick:

apt-cache rdepends libgnomevfs2-bin
libgnomevfs2-bin
Reverse Depends:
  libgnomevfs2-0

apt-cache show libgnomevfs2-0
Suggests: libgnomevfs2-bin

libgnomevfs2-bin seems to be in universe and libgnomevfs2-0 is in main. This makes no sense to me since they come from the same source package.

Regardless xdg-utils should recommend libgnomevfs2-bin for the reason in this bug

Changed in xdg-utils (Ubuntu):
status: Fix Released → Confirmed
Scott Ritchie (scottritchie) wrote :

For this case, I propose: Recommends: gvfs-bin | libgnomevfs2-bin | kdebase-runtime

Changed in xdg-utils (Debian):
status: Unknown → New
Scott Ritchie (scottritchie) wrote :

After talking at Debian, I see where the bug is, and it's in a language I understand.

Changed in xdg-utils (Ubuntu):
assignee: nobody → Scott Ritchie (scottritchie)
importance: Undecided → Medium
Changed in xdg-utils (Ubuntu):
status: Confirmed → In Progress
Scott Ritchie (scottritchie) wrote :

The attached patch fixes it. Please sponsor, as I don't have main upload rights.

Changed in xdg-utils:
importance: Unknown → Medium
status: Unknown → Fix Released
Martin Pitt (pitti) wrote :

Sponsored, waiting in natty unapproved for end of beta-1 freeze. Thanks!

Changed in xdg-utils (Ubuntu):
status: In Progress → Fix Committed
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-utils - 1.1.0~rc1-2ubuntu1

---------------
xdg-utils (1.1.0~rc1-2ubuntu1) natty; urgency=low

  [ Martin Pitt ]
  * Add xdg-update-menu-caonicalize-defaults.list.diff: Don't overwrite a
    /usr/share/applications/defaults.list symlink. Thanks to Joe Ebel for the
    original patch! (LP: #703106)

  [ Scott Ritchie ]
  * debian/patches/xdg-generic-use-mimetype.diff:
    - Update to fallback to generic on Gnome (LP: #602799)
 -- Martin Pitt <email address hidden> Wed, 30 Mar 2011 13:11:39 +0200

Changed in xdg-utils (Ubuntu):
status: Fix Committed → Fix Released
Changed in xdg-utils (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.