xdg-mime can read .config/ defaults but can never set them

Bug #1518053 reported by Chad Miller on 2015-11-19
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xdg-utils (Ubuntu)
Medium
Chad Miller

Bug Description

mimeapps.list has changed

It used to be in .local/share/applications/ . Now it's in .config/ .

"xdg-mime query default" reads from both locations, but no "xdg-mime default NEWSETTING" can ever overwrite a setting in .config/mimeapps.list . It writes to .local/share/applications/mimeapps.list only.

Chad Miller (cmiller) wrote :
Changed in xdg-utils (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
summary: - xdg-mime can read defaults but always not set them
+ xdg-mime can read .config/ defaults but can never set them
Changed in xdg-utils (Ubuntu):
importance: Undecided → Medium
tags: added: patch
Chad Miller (cmiller) wrote :

Patch in the debdiff will update both locations on "xdg-mime default foo.desktop mimetype/mimetype" .

Didier Roche (didrocks) wrote :

Hey Chad! Thanks for this patch. This mostly look good to me (apart from a small typo in changelog, mind changing it?)
I would love though to have more rationale on why you dropped the other ubuntu patches (even if you told you have done it on purpose) for this merge and .

Also, your debdiff is against 1.1.0~rc3+git20150907-1ubuntu2 (which is the vivid version) where we have 1.1.0~rc3+git20150907-1ubuntu3 in xenial since the 11/20, mind rebasing on that?

And for extra bonus, providing a second debdiff against the debian version would rock!
Thanks a lot :) (setting it as incomplete meanwhile)

Changed in xdg-utils (Ubuntu):
status: New → Incomplete
Didier Roche (didrocks) wrote :

Also, please resuscribe the sponsor team once ready.

Chad Miller (cmiller) wrote :
Chad Miller (cmiller) wrote :
Changed in xdg-utils (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks Chad, the most recent changelog entry which describes the merge should have a summary of the remaining delta as well, see the previous 1.1.0~rc3+git20150907-1ubuntu1 entry. Could you update your patch to include those?

Chad Miller (cmiller) wrote :
Chad Miller (cmiller) wrote :
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package xdg-utils - 1.1.1-1ubuntu1

---------------
xdg-utils (1.1.1-1ubuntu1) xenial; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/patches/xdg-email-mutt-detect.diff
    - debian/patches/xdg-screensaver-restore-timeout.diff
    - debian/patches/lp779156-lubuntu.diff
    Removed patches because upstream implements:
    - xdg-email-envvar.diff
    - xdg-open-browser-multiword.diff
    - xdg-open-printf.diff
    - xdg-screensaver-new-gnome.diff
    - no-X.diff
    - fix-bashism-use-of-echo.patch
    - gnome-3.0.diff
    - filenames-with-spaces.patch
  * debian/patches/mimeappslist-file-location: "xdg-mime default"
    only set old deprecated mimeapps location. "xdg-mime query default"
    retrieved, but nothing could set. (LP: #1518053)

xdg-utils (1.1.1-1) unstable; urgency=medium

  * New upstream release.
    - xdg-open: Handle whitespace in filenames and fix generic mode
      regression. Closes: #801048.
    - xdg-screensaver: Reset DPMS timer. Closes: #745340.
  * Update debian/watch, primary URL is working again.
  * Update Description.

xdg-utils (1.1.0-1) unstable; urgency=medium

  * New upstream release.
    - Adds references to specifications to the manuals. Closes: #800826.
    - xdg-open: Handle files with '?' and '#' in their names in generic mode.
      Closes: #800355.
    - xdg-settings: Detect generic DE instead of failing. Closes: #787791.
    - xdg-open, xdg-email: Add iceweasel to the list of fallback browsers.
      Closes: #788047.
    - xdg-open: Fall back to generic mode if gvfs-open and gnome-open are
      missing. Closes: #685304.
    - xdg-mime: Check ~/.config/mimeapps.list for default application.
      Closes: #800825.
  * Don't build html documentation, we don't install it anyway.
  * Update Description.
  * Update Homepage.

xdg-utils (1.1.0~rc3+git20150922-1) unstable; urgency=medium

  * Merge latest upstream git tree.
    - xdg-icon-resource: Don't try to install anything into /.
      Closes: #799741.
  * Remove autotests/Makefile in distclean target.

xdg-utils (1.1.0~rc3+git20150919-1) unstable; urgency=medium

  * Rebase on latest upstream git tree.
    - Drop the following patches which were applied upstream:
      + xdg-email-detect-icedove.patch
      + xdg-email-thunderbird-quoting.patch
      + xdg-email-try-xdg-open.patch
      + xdg-open-browser-multiword.diff
      + xdg-open-printf.diff
      + fix-bashism-use-of-echo.patch
  * Maintain Debian patches in git instead of using quilt patches.
  * Update git URLs in debian/control.
  * xdg-open: Try $BROWSER first in generic mode if it is set by the
    user. Closes: #799568.
  * Add an automated test suite (under development).

xdg-utils (1.1.0~rc3+git20150907-2) unstable; urgency=medium

  * Add upstream bug URL to xdg-open-browser-multiword.diff.
  * Use local variable in patch xdg-open-browser-multiword.diff.
  * Add upstream bug URL to patch xdg-open-printf.diff.
  * Add upstream bug URL to fix-bashism-use-of-echo.patch.
  * Add xdg-email-try-xdg-open.patch: Try using xdg-open in xdg-email's
    generic mode. Closes: #691259.
  * Only try to auto-detect Mutt in xdg-email in generic mod...

Read more...

Changed in xdg-utils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers