xdg-mime query filetype does not work on KDE 5 (Fixed in Portland)

Bug #1454833 reported by MS on 2015-05-13
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xdg-utils (Ubuntu)
Undecided
Unassigned

Bug Description

System information:

cat /etc/lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu 15.04"

apt-cache policy xdg-utils:
xdg-utils:
  Installed: 1.1.0~rc1-2ubuntu10
  Candidate: 1.1.0~rc1-2ubuntu10
  Version table:
 *** 1.1.0~rc1-2ubuntu10 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

Expected behavior:

The command "xdg-mime query filetype $FILENAME" returns the MIME type of the specified file.

Actual behavior under KDE 5:

No output to stdout. If the specified file is executable, it is executed, e.g. "xdg-mime query filetype /usr/bin/xclipboard" executes the program xclipboard.

Source of error:

The xdg-mime script checks in the function "info_kde()" only for KDE version being 3 or 4. The new Kubuntu release bundles KDE 5 which is not checked against.

This bug is fixed in the Portland repository: http://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=18645a50fe25064b42ba421e231869c6063705f7

MS (caffeine-addicted) on 2015-05-13
summary: - xdg-mime does not work on KDE 5 (Fixed in Portland)
+ xdg-mime query filetype does not work on KDE 5 (Fixed in Portland)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-utils - 1.1.0~rc3+git20150907-1ubuntu1

---------------
xdg-utils (1.1.0~rc3+git20150907-1ubuntu1) wily; urgency=low

  * Merge from Debian unstable. Remaining changes: (LP: #1495273)
    - debian/patches:
      * gnome-3.0.diff: Correctly open preferred browser with
        gnome-open (LP: #670128)
      * lp779156-lubuntu.diff: Add open_lxde and run_sylpheed function
        for improved LXDE and sylpheed support (LP: #779156)
      * xdg-screensaver-restore-timeout.diff: restore previous X11
        screensaver timeout when xdg-screensaver resume is used (LP: #1363540)
  * New upstream release fixes the following bugs:
    - xdg-mime query filetype does not work on KDE 5 (LP: #1454833)
    - xdg-open doesn't properly detect Xfce/Xubuntu (LP: #1388922)
    - xserver-blanking patch in Ubuntu duplicates code (LP: #1330386)
    - Typo in manpage of 'xdg-icon-resource' (LP: #996304)
    - xdg-open (to gnome-open) fails to launch file:// URL with query string
      (LP: #396162)

 -- Sean Davis <email address hidden> Sun, 13 Sep 2015 12:39:10 -0400

Changed in xdg-utils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers