xdg-open handles file-URIs wrong in LXDE

Bug #1264988 reported by Flups Baumann on 2013-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdg-utils (Ubuntu)
Undecided
Unassigned

Bug Description

This regards xdg-open when it is used in LXDE.

When xdg-open is called with a file URI that contains special chars like %20, this URIs are handled wrong. E.g. I have a file in my home dir that is named "test file.pdf". xdg-open is called with:

xdg-open file:///home/flups/test%20file.pdf

The subroutine open_lxde splits the "file://" from the URI but does not treat the %20, so it tries to open the file:

/home/flups/test%20file.pdf

and this cannot work.

See attached to log that I created with sh -xv.

As a workaround I added the following two lines after line 480:

local printf=/usr/bin/printf
file="$($printf "$(echo "$file" | sed -e 's@%\([a-f0-9A-F]\{2\}\)@\\x\1@g')")"

I took this code from the subroutine open_generic().

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xdg-utils 1.1.0~rc1-2ubuntu7
ProcVersionSignature: Ubuntu 3.8.0-34.49-generic 3.8.13.12
Uname: Linux 3.8.0-34-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.5
Architecture: amd64
Date: Mon Dec 30 13:30:34 2013
InstallationDate: Installed on 2013-06-18 (194 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: xdg-utils
UpgradeStatus: Upgraded to raring on 2013-07-28 (154 days ago)

Flups Baumann (flups) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers