Applications ignore default browser settings in LXDE

Bug #1113452 reported by Lars Noodén on 2013-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdg-utils (Ubuntu)
Undecided
Unassigned

Bug Description

When clicking on links in an IRC chat, Konversation launches Chromium-browser regardless of what other browser may have been set in system preferences. What should have happened is that it uses Firefox, if Firefox was set, or Opera etc.

The settings are in the menu LXDE->Preferences->Preferred Applications->Firefox, but are ignored by Konversation.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: konversation 1.4-1ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-2.6-generic 3.8.0-rc4
Uname: Linux 3.8.0-2-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sat Feb 2 14:52:54 2013
InstallationDate: Installed on 2012-11-25 (68 days ago)
InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Alpha amd64+mac (20121124)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: konversation
UpgradeStatus: No upgrade log present (probably fresh install)

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :

This also occurs in Thunderbird, with https links, but not http links.

It also occurs when using ubuntu-bug. The bug reporter will launch Chromium instead of Firefox.

Hein (sho) wrote :

Konversation uses the standard API to launch a web browser offered by the KDE Platform lirbaries. The implementation of that API is designed to fall back to xdg-open if an application is not run inside a KDE workspace session. I'm guessing the LXDE developers haven't contributed an LXDE codepath to xdg-utils or something along those lines; in any case, this isn't anything Konversation should have to concern itself with.

Harald Sitter (apachelogger) wrote :

Moving to xdg-utils for investigation.

affects: konversation (Ubuntu) → xdg-utils (Ubuntu)
summary: - Konversation ignores default browser settings in LXDE
+ Applications ignore default browser settings in LXDE
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers