inconsistent labeling in Thunar

Bug #692815 reported by Book 'em Dano on 2010-12-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdg-user-dirs (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: thunar

If one was to open any window using Thunar, the Side Pane lists a shortcut for Download as Download, on the contrary the actual folder is labeled Downloads and the word Downloads appears in the title of the window when the Downloads folder is open and the label, Downloads, is evident when looking in the Home folder.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: thunar 1.0.1-3ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-26.48-generic 2.6.32.24+drm33.11
Uname: Linux 2.6.32-26-generic i686
Architecture: i386
Date: Mon Dec 20 19:24:43 2010
InstallationMedia: Xubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: thunar
---
Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Xubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
Package: xdg-user-dirs 0.12-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-27.49-generic 2.6.32.26+drm33.12
Tags: lucid
Uname: Linux 2.6.32-27-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Book 'em Dano (heymrdjd) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm this issue in fresh installations of Xubuntu.

Thanks for taking the time to make Ubuntu better!

Changed in thunar (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Book 'em Dano (heymrdjd) wrote :

This issue is apparent in maverick also.

summary: - inconsistent labelling in Thunar
+ inconsistent labeling in Thunar
tags: added: maverick
Book 'em Dano (heymrdjd) wrote :

It does not appear that this issue is evident in natty.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Natty Narwhal.

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in thunar (Ubuntu):
importance: Medium → Low
status: Triaged → Fix Released
Changed in thunar (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Low
Lionel Le Folgoc (mrpouit) wrote :

Nope, if there's a bug, it's in the localisation of xdg-user-dirs/xdg-user-dirs-gtk (one of them is responsible for creating the directories and the gtk bookmarks), not in thunar.

apport information

affects: xdg-user-dirs-gtk (Ubuntu) → xdg-user-dirs (Ubuntu)
tags: added: apport-collected
description: updated
Changed in thunar (Ubuntu Maverick):
importance: Undecided → Low
status: New → Triaged
Changed in thunar (Ubuntu Maverick):
status: Triaged → Invalid
Changed in thunar (Ubuntu Lucid):
status: Triaged → Invalid
Changed in thunar (Ubuntu):
status: Fix Released → Invalid
Sebastien Bacher (seb128) wrote :

"Downloads" is the correct spelling and not a bug:

"xdg-user-dirs (0.11-0ubuntu1) karmic; urgency=low

  * New upstream version:
    - Switch DOWNLOAD default to "Downloads" instead of "Download" to
      to match the other names"

Changed in xdg-user-dirs (Ubuntu Lucid):
importance: Undecided → Low
status: New → Invalid
Changed in xdg-user-dirs (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Changed in xdg-user-dirs (Ubuntu Maverick):
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

see bug #204567 which was the bug which asked the renaming

Charlie Kravetz (charlie-tca) wrote :

Actually, this bug was submitted because Download is not the same as Downloads, and does fail to open the "Downloads" sub-directory in Xubuntu 10.04.

Book 'em Dano (heymrdjd) wrote :

bug #204567 is not related to this bug

Changed in xdg-user-dirs (Ubuntu Maverick):
status: Invalid → New
Changed in xdg-user-dirs (Ubuntu Lucid):
status: Invalid → New
Changed in xdg-user-dirs (Ubuntu):
status: Invalid → New
Adolfo Jayme (fitojb) on 2013-06-22
no longer affects: thunar (Ubuntu)
no longer affects: thunar (Ubuntu Lucid)
no longer affects: thunar (Ubuntu Maverick)
no longer affects: xdg-user-dirs (Ubuntu Lucid)
no longer affects: xdg-user-dirs (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers