Ubuntu

[Hardy] Desktop Folder reported twice changing language in automatic changing folder name

Reported by Sergio Zanchetta on 2008-01-24
10
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Unassigned
menu-xdg (Ubuntu)
Undecided
Unassigned
xdg-user-dirs (Baltix)
Undecided
Unassigned
xdg-user-dirs (Ubuntu)
Undecided
Unassigned
xdg-user-dirs-gtk (Ubuntu)
Low
Unassigned
xdg-utils (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Hardy alpha 3 in English language, updated today, then I changed language in Italian removing English, after rebooting came up a window asking for automatic folder name switching.

Desktop Folder is reported twice.

See screenshot.

Caroline Ford (secretlondon) wrote :

Did it do the renaming okay?

Sergio Zanchetta (primes2h) wrote :

All went ok, except for the Desktop folder one.

Now in Home folder I have "Desktop" folder and "Scrivania" (Italian of Desktop) (see attachment)

"Desktop" contains 2 file (I had previously) and "Scrivania" is empty.

but if I go to Risorse(Places) -> Scrivania it opens "Desktop" folder not "Scrivania".

Sergio Zanchetta (primes2h) wrote :

Another thing.

Now, everytime I log in I get an error message like this:

"The language it_IT doesn't exist. It'll be used System Default."

Sergio Zanchetta (primes2h) wrote :

This bug is quite serious, because it implies a bad inconsistency in folder names.

I have a "Scrivania" folder (italian name for Desktop) but Risorse ("Places")->Scrivania ("Desktop") point to "Desktop" folder, not to "Scrivania" ones.

Sebastien Bacher (seb128) wrote :

no need to open a zillion bug tasks

Changed in xdg-user-dirs:
status: New → Invalid
Changed in xdg-utils:
status: New → Invalid
Changed in menu-xdg:
status: New → Invalid
Changed in language-selector:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

The desktop location is also used for downloads, not sure if that's a bug to let user specifiy a different directory there

Changed in xdg-user-dirs-gtk:
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

The language login issue is a gdm one and already known, you can select italian on the login screen as a workaround

Sergio Zanchetta (primes2h) wrote :

Thank you for explaining gdm issue.

About desktop location, maybe I explain it wrong.
I don't want to specify a different directory.

Just after installing Hardy, I installed Italian language removing English one.

After rebooting came up a window asking for automatic folder name switching (related to xdg-users-dir) in which there were a problem. see 1st screenshot.

Directly connected to this, after doing this automatic folder name switching, I have "Scrivania" place (in Places) pointing to "Desktop" folder instead of "Scrivania" one (which exist as well, created by automatic folder name switching).

In sum, this automatic folder name switching renamed correctly "Documents", "Pictures", "Music", "Video" in italian, but created a double folder for "Desktop" one, pointing to the wrong one. ("Desktop" instead of "Scrivania").

I hope to have been clear.

Sebastien Bacher (seb128) wrote :

The description is clear to confirm and send upstream by somebody having the issue

Sergio Zanchetta (primes2h) wrote :

Just another thing.

I suspect this bug is not related to Italian language only but it affects all other languages.

May someone try to reproduce it in another language in order to confirm it please?

Sergio Zanchetta (primes2h) wrote :

UPDATE.
This bug lead to a worse thing.

Programs like firefox 3 beta 3 or gnome-screenshot take "Desktop" as preferred folder for saving instead of "Scrivania".

So if I go to Place->Scrivania it opens "Scrivania" and I can't find downloaded files.

Sergio Zanchetta (primes2h) wrote :

In some way these other bugs are related...

Bug #160343
Bug #187056
Bug #187107
Bug #189074
Bug #189339

Very bad situation.

Sebastien Bacher (seb128) wrote :

Do you have easy steps to trigger the issue?

Perform a new hardy installation in English language.
Then change language to Italian (or another else) removing English at the
same time in System->Administration->Languages
After rebooting you face this problem (and everything related).

2008/3/18, Sebastien Bacher <email address hidden>:
>
> Do you have easy steps to trigger the issue?
>
>
> --
> [Hardy] Desktop Folder reported twice changing language in automatic
> changing folder name
> https://bugs.launchpad.net/bugs/185693
> You received this bug notification because you are a direct subscriber
> of the bug.
>

heidemann (hheidemann) wrote :

I have the same problem in Brazilian Portuguese language.

I read in a post that this could help:

 ln -s Scrivania Desktop

bapoumba (bapoumba) wrote :

I stumbled on this bug after a fresh hardy install on a new computer. I installed the system in French (by mistake, but I'm in France) and switched to English after the install was completed, not removing the French localization.

Both "Bureau" and "Desktop" files were present (all the other ones got properly updated). Mounted files were shown on "Bureau", which remained the actual desktop, when default screenshots were sent to "Desktop" for ex.

I played around with symlinks with no success (showed as broken). Choosing English language at GDM and accepting the locale update got it straightened up.

Ashley Hooper (ash-hooper) wrote :

Same problem for me, after changing the language of the computer from English to French.

I fixed by moving all contents of my old ~/Desktop folder to the new ~/Bureau, including the hidden file '.directory'. After that I logged out and logged back in and all was well.

Ashley Hooper (ash-hooper) wrote :

Forgot to mention, I also deleted the now empty ~/Desktop folder.

Arne Goetje (arnegoetje) wrote :

Is this still an issue in the latest Ubuntu release (Karmic)?

Sergio Zanchetta (primes2h) wrote :

It has been fixed in Karmic. (but not in Hardy I think)

Sebastien Bacher (seb128) wrote :

closing the bug since that works in karmic

Changed in xdg-user-dirs-gtk (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers