SRU xdg-desktop-portal 1.0.3

Bug #1817285 reported by Ken VanDine on 2019-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdg-desktop-portal (Ubuntu)
Medium
Unassigned
Xenial
Medium
Ken VanDine
Bionic
Medium
Ken VanDine

Bug Description

[Impact]

 * To improve the snap experience on the desktop we have been working with xdg-desktop-portal upstream to enable snap support. Portals will greatly improve the snap experience. Full snap support landed in xdg-desktop-portal 1.0. We're SRU'ing 1.0.3 as it includes bug fixes.

 * There is now an approved MIR for xdg-desktop-portal for bionic and xenial, so these will be promoted to main as well.

 https://bugs.launchpad.net/ubuntu/+source/xdg-desktop-portal/+bug/1749672

[Test Case]

 * This can be tested by installing the portal-test snap from the edge channel and xdg-desktop-portal-gtk also from proposed. Verify the file selection lets you select a file and open local opens test.txt in a text editor of your choice.

[Regression Potential]

 * No regression potential. This package was not seeded by default. It could only have been used by flatpak, however, the version in bionic had limited functionality. The package was never available in xenial.

[Other Info]

 * xdg-desktop-portal is in main and seeded by ubuntu-desktop in cosmic and disco.

Changed in xdg-desktop-portal (Ubuntu):
status: New → Invalid
Changed in xdg-desktop-portal (Ubuntu Xenial):
importance: Undecided → Medium
Changed in xdg-desktop-portal (Ubuntu Bionic):
importance: Undecided → Medium
Changed in xdg-desktop-portal (Ubuntu Xenial):
status: New → Triaged
Changed in xdg-desktop-portal (Ubuntu Bionic):
status: New → Confirmed
status: Confirmed → Triaged
Changed in xdg-desktop-portal (Ubuntu Xenial):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in xdg-desktop-portal (Ubuntu Bionic):
assignee: nobody → Ken VanDine (ken-vandine)
Steve Langasek (vorlon) on 2019-03-02
Changed in xdg-desktop-portal (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello Ken, or anyone else affected,

Accepted xdg-desktop-portal into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xdg-desktop-portal/1.0.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in xdg-desktop-portal (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed-bionic
tags: added: verification-done-bionic
removed: verification-needed-bionic
Andrew Hayzen (ahayzen) wrote :

FWIW this also passes from a flatpak point of view on bionic as noted in xdg-desktop-portal-gtk here https://bugs.launchpad.net/ubuntu/+source/xdg-desktop-portal-gtk/+bug/1817287/comments/2

Changed in xdg-desktop-portal (Ubuntu):
status: Invalid → Fix Released
importance: Undecided → Medium
Łukasz Zemczak (sil2100) wrote :

Ken: what kind of testing have you performed? What packages have you used during verification?
Also, it seems that the xdg-desktop-portal autopkgtests are failing for this upload. Could you take a look at those and see if they're not regressions?

Changed in xdg-desktop-portal (Ubuntu Bionic):
status: Fix Committed → Incomplete
Łukasz Zemczak (sil2100) wrote :

Ah, I suppose that Andrew's comment actually points to the testing done, I guess I got confused by one person changing the tags and another commenting! Still, I'd like someone to take a look at the failed autopkgtests.

Ken VanDine (ken-vandine) wrote :

I'm looking into the autopkgtests on bionic.

Ken VanDine (ken-vandine) wrote :

I've uploaded 1.0.3-0ubuntu0.2 which should fix the autopkgtest failure

Changed in xdg-desktop-portal (Ubuntu Bionic):
status: Incomplete → In Progress
Łukasz Zemczak (sil2100) wrote :

Hello Ken, or anyone else affected,

Accepted xdg-desktop-portal into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xdg-desktop-portal/1.0.3-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in xdg-desktop-portal (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
removed: verification-done-bionic
Ken VanDine (ken-vandine) wrote :

I've verified this on both xenial and bionic and confirmed the autopackage tests are passing now.

tags: added: verification-done verification-done-bionic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-xenial
Ken VanDine (ken-vandine) wrote :

I've stepped through the test case listed in the description on both xenial and bionic with the following package versions:

xenial:
  xdg-desktop-portal-gtk=1.0.2-0ubuntu0.0
  xdg-desktop-portal=1.0.3-0ubuntu0.0
bionic:
  xdg-desktop-portal-gtk=1.0.2-0ubuntu1.1
  xdg-desktop-portal=1.0.3-0ubuntu0.2

Łukasz Zemczak (sil2100) wrote :

Hey Ken! Do you know why the xdg-desktop-portal ppc64el tests are failing? Looks like it's reproducible. Is it something we should be worrying about?

Ken VanDine (ken-vandine) wrote :

@sil2100: jamesh has looked at that and wasn't able to see why it would be arch specific failure there. However, this is probably not interesting on ppc64el anyway. Perhaps best to just skip this test for that arch?

Brian Murray (brian-murray) wrote :

While the package may not be interesting on ppc64el it's odd that the autopkgtests pass on later releases e.g. cosmic and disco.

Andrew Hayzen (ahayzen) wrote :

FYI this not landing yet in xenial is preventing xdg-desktop-portal-gtk from being installed in xenial (see bug 1823054) as xenial doesn't have >= 0.10 of xdg-desktop-portal.

Ken VanDine (ken-vandine) wrote :

The failing autopkgtest is only on bionic, shouldn't be blocking for xenial. Can we get this in xenial-updates?

Łukasz Zemczak (sil2100) wrote :

Ken, could you please fill in a bug for the strange failing test so that it doesn't get lost? In the meantime I'll release it for both series. Thanks!

The verification of the Stable Release Update for xdg-desktop-portal has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-desktop-portal - 1.0.3-0ubuntu0.2

---------------
xdg-desktop-portal (1.0.3-0ubuntu0.2) bionic-proposed; urgency=medium

  * debian/patches/xdp_inode_kernel_unref_check.patch
    - make xdp_inode_kernel_unref check that kernel_ref_count > 0
      fixes autopkgtest failures

xdg-desktop-portal (1.0.3-0ubuntu0.1) bionic-proposed; urgency=medium

  * New upstream release 1.0.3 (LP: #1817285)

 -- Ken VanDine <email address hidden> Fri, 22 Mar 2019 09:50:55 -0400

Changed in xdg-desktop-portal (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-desktop-portal - 1.0.3-0ubuntu0.0

---------------
xdg-desktop-portal (1.0.3-0ubuntu0.0) xenial-proposed; urgency=medium

  * New upstream release 1.0.3 (LP: #1817285)

 -- Ken VanDine <email address hidden> Mon, 10 Dec 2018 15:44:10 -0500

Changed in xdg-desktop-portal (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers