xdeb trying to look up amd64-only package names on armel mirror

Bug #752287 reported by Steve Langasek
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xdeb (Ubuntu)
Fix Released
Medium
Wookey

Bug Description

Binary package hint: xdeb

running xdeb from trunk:

$ xdeb -a armel -b . -d . --only-explicit --prefer-apt cln
[...]
Build sequence: gmp* cln*
[...]
wget -N http://ports.ubuntu.com/ubuntu-ports/pool/main/g/gmp/lib32gmp3_4.3.2+dfsg-1ubuntu3_armel.deb
--2011-04-06 07:13:35-- http://ports.ubuntu.com/ubuntu-ports/pool/main/g/gmp/lib32gmp3_4.3.2+dfsg-1ubuntu3_armel.deb
Resolving ports.ubuntu.com... 91.189.92.175
Connecting to ports.ubuntu.com|91.189.92.175|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2011-04-06 07:13:35 ERROR 404: Not Found.

Traceback (most recent call last):
  File "../xdeb/trunk/xdeb.py", line 937, in <module>
    main()
  File "../xdeb/trunk/xdeb.py", line 921, in main
    native_crossed.extend(native_import(options, src))
  File "../xdeb/trunk/xdeb.py", line 539, in native_import
    cwd=options.builddirs[0])
  File "/home/vorlon/devel/linaro/xdeb/trunk/utils.py", line 29, in spawn
    raise SubprocessException, ret
utils.SubprocessException: 8

lib32gmp3 doesn't exist in the package file for armel, this is clearly an amd64-specific package. xdeb has gotten confused here.

Related branches

Revision history for this message
Steve Langasek (vorlon) wrote :

Not a regression - also reproducible with xdeb 0.6.3 in natty.

Changed in xdeb (Ubuntu):
assignee: nobody → Wookey (wookey)
Revision history for this message
Steve Langasek (vorlon) wrote :

diagnosed this as being triggered by my multiarch apt setting:
  APT::Architectures { "amd64"; "armel"; };

even though xdeb passes -oAPT::Architecture, packages for the other architectures listed here are still visible in apt-cache show, confusing xdeb.

Changed in xdeb (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon)
Changed in xdeb (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package xdeb - 0.6.5

---------------
xdeb (0.6.5) unstable; urgency=low

  [ Steve Langasek ]
  * If a package is Multi-Arch: foreign, we don't need to build it unless we
    also want to install it in its own right.
  * When calling apt-cache show, qualify the package name with an
    explicit architecture; this guards against attempts to import
    not-for-us binaries that are in the apt cache in a multiarch
    environment. LP: #752287.

  [ Wookey ]
  * Add some packages to black/whitelists
  * Improve graphing to only include binary deps that are
    actually depended on in the dependency tree
  * Update Standards-version
  * Depend on multiarch-capable dpkg-cross and invoke it with
    --convert-multiarch
  * Fix lintian test whinge
  * Don't fail if null dpkg-cross packages are found LP: #731079
  * Include lib64c in toolchain packages list - avoids
     multipleprovides exception on 64-bit arches. LP: #75574
  * Let xdeb grok binary package names as well as source ones. LP: #778506
  * Use 'apt-get download' rather than wget for native imports, provided
    that multiarch is configured. LP: #851427

  [ Steve McIntyre ]
  * Add initial support for armhf. LP: #772526

  [ Colin Watson ]
  * Convert to dh_python2.
  * Consistently use 'import utils' rather than 'from utils import ...'.
  * Suppress unusednames=_NATIVE_IMPORT_SOURCE_NAME in config.py, apparently
    due to a pychecker bug.
  * Split option parsing into a separate function to placate a pychecker
    warning about the length of main.
  * Extend need_loop_break hack to cover python2.7's build-dependency on
    libbluetooth-dev.
  * Add python2.7-dev to whitelist.
  * Fix installation of binutils-multiarch when cross-compiling.
  * Tolerate the removal of the fields collection in Lintian 2.5.2.
  * Don't install build-dependencies in --sequence mode.
  * Fix caching in Provides resolver.
  * Only skip Multi-Arch: foreign packages if the system is configured to be
    able to install packages of the appropriate foreign architecture.
  * Revamp build-dependency installation. We now point 'apt-get install' at
    a combination of the system sources.list and the destination directory
    rather than using 'dpkg -i', and we install build-dependencies
    immediately before building each package as well as in a block at the
    start of the run; this also allows us to be more selective about which
    crossed packages we install. The 'builddep_whitelist' configuration
    option is now unnecessary and has been removed.
  * Fix dependency resolver. We now only expand dependencies for binaries
    that are explicitly required to satisfy (build-)dependencies, rather
    than trying to expand all binaries in every source package we encounter.
  * If rebuilding a source package that had already been built, force a full
    regeneration of the apt repository and purge any previous incarnations
    of those binary packages.
  * Fix native_import to work again even if multiarch isn't configured.
  * Remove explicit code to install native imports; the new build-dependency
    installer can deal with that by itself.
  * Remove libreadline-dev from cross_...

Read more...

Changed in xdeb (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.