xchat does not do composite transparency, crashes if transparency is enabled with GTK RGBA

Bug #92028 reported by Matt Wheeler on 2007-03-13
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
XChat-GNOME
Fix Released
Wishlist
xchat
Unknown
Unknown
xchat (Ubuntu)
Wishlist
Unassigned
xchat-gnome (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xchat

xchat should be able to do transparency the way gnome-terminal does (should do), rather than just grabbing the desktop image and selecting the correct bit

Sebastian Breier (tomcat42) wrote :

This also affects xchat-gnome. I added it in Ubuntu & upstream.

Sebastian Breier (tomcat42) wrote :

I think it's not clear from the original bug report that this is a AIGLX/XGL issue, because gnome-terminal has the same transparency as xchat(-gnome) has with metacity.

Changed in xchat-gnome:
status: Unknown → Unconfirmed
William Grant (wgrant) on 2007-03-23
Changed in xchat:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in xchat-gnome:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Áron Sisak (asisak) on 2007-08-01
Changed in xchat:
status: Confirmed → Triaged
Jonas Wagner (veers) wrote :

I did some work on this issue. But I'm not using xchat anymore so I'll not finish it.
Here is the topic in the forum which contains my patch (and screenshots ;) )
http://forum.xchat.org/viewtopic.php?t=3187

Changed in xchat-gnome:
status: New → Confirmed
Changed in xchat-gnome:
status: Confirmed → Triaged
Maia Everett (linneris) wrote :

Patch.

Note to the core developers: since I hear there are plans for RGBA by default in Maverick, this patch is worth looking at for another reason: without it, xchat-gnome crashes if the old ("fake") transparency is enabled in RGBA window mode.

Maia Everett (linneris) wrote :

To clarify, that patch above is for xchat-gnome. I haven't worked on plain xchat for this.

Maia Everett (linneris) wrote :

Slightly modified patch.

Maia Everett (linneris) on 2010-06-01
summary: - xchat does not do composite transparency
+ xchat does not do composite transparency, crashes if transparency is
+ enabled with GTK RGBA
tags: added: gtk-csd
Maia Everett (linneris) wrote :

Debdiff.

xchat-gnome (1:0.26.1-1ubuntu3) maverick; urgency=low

  * Added debian/patches/22_rgba_transparency.patch:
    - Use alpha transparency if available; fix crash when transparency is set
      with GTK RGBA enabled (LP: #92028)

 -- Maia Kozheva <email address hidden> Tue, 01 Jun 2010 16:36:27 +0700

Maia Everett (linneris) on 2010-06-10
Changed in xchat-gnome (Ubuntu):
status: Triaged → Confirmed
Omer Akram (om26er) wrote :

xchat did not crash for me in Maverick did it crash for anyone else?

Maia Everett (linneris) wrote :

Updated patch for Maverick, fixing a text rendering issue with Cairo 1.9 by wrapping rectangle filling in cairo_save/cairo_restore.

tags: added: patch-forwarded-upstream
Changed in xchat-gnome:
importance: Unknown → Wishlist
status: Confirmed → Fix Released
Daniel Holbach (dholbach) wrote :

Fix has landed upstream. Does anybody know if there's a new release planned or should we package a snapshot?

Changed in xchat-gnome (Ubuntu):
status: Confirmed → Fix Committed
Micah Gersten (micahg) wrote :

Is there anything here that actually needs sponsoring?

Stefano Rivera (stefanor) wrote :

Unsubscribing ubuntu-sponsors, as there doesn't appear to be an upload that needs sponsoring. Please resubscribe us if necessary.

Bryce Harrington (bryce) wrote :

Can someone verify if the version in natty carries this fix? If not, then this should be re-added to sponsors queue to get packaged and included in natty.

Maia Everett (linneris) wrote :

Verified that the version in Natty fixes it, closing.

Changed in xchat-gnome (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.