Xchat fails to save sound preference Beep.

Bug #851104 reported by philinux on 2011-09-15
22
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xchat (Ubuntu)
Undecided
Unassigned

Bug Description

I had to manually edit sound.conf to make the setting stick permanently.

I use a .wav file in my Home folder. Xchat would use it when I set in but on restarting xchat it reverted to it's original setting.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xchat 2.8.8-3ubuntu8
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 15 18:14:30 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110910)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: xchat
UpgradeStatus: No upgrade log present (probably fresh install)

philinux (philcb) wrote :
philinux (philcb) wrote :

It doesn't save any settings.

The reason being I was quiting with the X window close button.

If you quit with xchat>quit or ctrl q it then saves any changed settings.

Bryce Harrington (bryce) wrote :

Can you describe this bug in better detail? Exact steps to reproduce the problem would likely help a lot.

Changed in xchat (Ubuntu):
status: New → Incomplete
philinux (philcb) wrote :

Yep as in post 2. Make a change in settings then quit using the X flake window button. Change does not get saved. If you quit with File > Quit it gets saved.

philinux (philcb) wrote :

Don't know how typo occurred. X close window button.

Launchpad Janitor (janitor) wrote :

[Expired for xchat (Ubuntu) because there has been no activity for 60 days.]

Changed in xchat (Ubuntu):
status: Incomplete → Expired
liamdawe (liamdawe) wrote :

Bug still happens, doesn't save settings.

Changed in xchat (Ubuntu):
status: Expired → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xchat (Ubuntu):
status: New → Confirmed
Bartosz Baranowski (baranowb) wrote :

Seems like xchat or OS does not handle existing file properly. Simple `rm sound.conf` and close op issued afterwards made xchat regenerate this file with proper content.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers