xchat tray icon doesn't appear if xchat is in Startup Applications

Bug #445509 reported by Gavin Chappell
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xchat (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: xchat

As a constant IRC user, I set Xchat up to start automatically when I login (using System->Preferences->Startup Applications). This was originally done on my Jaunty install which I recently upgraded to Karmic beta. Since the upgrade, now when I login there is no tray icon for Xchat although Xchat runs fine. If I then close the Xchat window then it gets "minimised" to the tray icon which I can't see.

If I quit Xchat with Ctrl-Q and then start it again, the tray icon shows up properly.

ProblemType: Bug
Architecture: amd64
Date: Wed Oct 7 15:49:46 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Error: [Errno 5] Input/output error
Package: xchat 2.8.6-4ubuntu2 [modified: usr/bin/xchat]
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.39-generic
SourcePackage: xchat
Uname: Linux 2.6.31-12-generic x86_64

Revision history for this message
Gavin Chappell (g-a-c) wrote :
Revision history for this message
Gavin Chappell (g-a-c) wrote :

It now seems that this may not be an xchat problem. I happened to notice yesterday that when I started my laptop up there was a little flicker, almost as if gnome-panel had been killed and then restarted instantly. If I do this manually (with "killall gnome-panel && gnome-panel" from a terminal) then when the gnome-panel restarts, it slowly redraws all the menus, launchers and icons, but does not redraw the xchat icon. All my other tray icons reappear (wicd, SpiderOak, bluetooth, gnome-power-manager, Pidgin, Volume Control) but not xchat.

So this bug seems to be a combination of two things; firstly that my gnome-panel seems to close and then re-open as soon as I log in, and xchat do something different with their tray icon which causes it not to be withdrawn when other icons are.

Revision history for this message
Kaaiman (kaaimangroep) wrote :

I have the same very annoying problem on Ubuntu 9.10 (final release) amd64. Does this problem also appear on i386 systems?

Rebuilding the deb doesn't work, so it seems not to be a packaging-only problem.
(apt-get source, apt-get build-dep, dpkg-buildpackage, dpkg -i)

I also tried to make a shell script in /usr/bin like this:

#! /bin/bash
#
xchat

I set autostart to this script file, but that doesn't make sense either after restarting X.

It's a pity XChat doesn't have functionality to force the tray icon to be absent or present.

Revision history for this message
Kaaiman (kaaimangroep) wrote :

I downgraded to the jaunty packages below and the tray icon is back, so I don't think it's a problem in gnome-panel.

xchat_2.8.6-2.1ubuntu4_amd64.deb
xchat-common_2.8.6-2.1ubuntu4_all.deb

Revision history for this message
Kaaiman (kaaimangroep) wrote :

After a total reboot the systray icon misses even with the downgraded packages. :(

Revision history for this message
Lauri Niskanen (ape3000) wrote :

This might work. Make a start up script and put it to your Startup Applications. The script should contain something like the following. Try to adjust the sleep time, if it doesn't work or you if you want to tweak it.

#!/bin/bash
sleep 30
xchat --minimize=2

James Milazzo (milazzo)
Changed in xchat (Ubuntu):
status: New → Confirmed
Revision history for this message
Kaaiman (kaaimangroep) wrote :

> This might work. Make a start up script and put it to your Startup Applications.

I tried and it works after a total reboot.

But it works around the real problem... :)

Revision history for this message
Kwinz (ldm) wrote :

see bug 410525
there is also a workaround
what we need now is a real fix

Revision history for this message
KIAaze (zohn-joidberg) wrote :

I'm having this problem too now that I'm using Gnome again.

However, I think it might be related to somethintg I noticed in KDE:
When I restart plasma-desktop, all system tray icons reappear in the system tray, except xchat which appears in it's own mini window (only an xchat icon + titlebar).

Revision history for this message
tux75 (tux1975) wrote :

i've the same problem but:
1. xchat is not in the startup list,
2. the system is fully updated.

I use gnome DE.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers