When adding a new network charset is not "System Default"

Bug #294873 reported by Fabián Rodríguez on 2008-11-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xchat (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xchat

When adding a new network, the charset defaults to IRC (Latin/Unicode Hybrid).

Shouldn't it be System Default ? In that case would it default to UTF-8 on standard US/US-English language systems ?

Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xchat (Ubuntu):
status: New → Incomplete
Fabián Rodríguez (magicfab) wrote :

Kamus, would you care to indicate what information is missing ?

Victor Vargas (kamus) wrote :

Dear Fabian can you attach a screenshot, logfiles, package version, ubuntu version or any other detail?, in this way I can try to reproduce this.

Fabian podrías indicar que versión de Bbuntu estas usando y que versión del paquete xchat?, de esta forma podría tratar de reproducir el problema y confirmar si se trata de un bug.

Saludos

Regards

Fabián Rodríguez (magicfab) wrote :

Ubuntu 8.10, xchat version is 2.8.6-2ubuntu1.

Steps to reproduce:

1) Open XChat
2) Go to XChat > Network List > Add..., press Enter to accept a default name, or edit the name as needed before pressing Enter
3) Once the network is added, make sure it's selected and click "Edit"
4) "Character set" default to "IRC (Latin/Unicode Hybrid)"

Expected behavior:
"Character set" should default to the system's default, in my case UTF 8 - Unicode.

Workaround:
Click on the "Character set" dropdown list and select the appropriate charset.

I've checked this in Jaunty (xchat 2.8.6-2.1ubuntu4) and the same problem persists.

Victor Vargas (kamus) wrote :

Dear Fabián, I can confirm this too in Ubuntu 9.04 and xchat 2.8.6-2.1ubuntu4.

Changed in xchat (Ubuntu):
status: Incomplete → New
Victor Vargas (kamus) wrote :
Victor Vargas (kamus) on 2009-07-08
Changed in xchat (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers