segmentation fault when set as away by GUI

Bug #153526 reported by nayif alhjazi on 2007-10-17
24
Affects Status Importance Assigned to Milestone
XChat-GNOME
Fix Released
High
xchat-gnome (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Low
Unassigned

Bug Description

Binary package hint: xchat-gnome

1-xchat-gnome
2-want to set ur self away
3-click on ur name
4-Mark as away
5-nothing happen

note:this happen to me b4 and after i disable all plug-in.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 17 11:17:14 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/xchat-gnome
Package: xchat-gnome 1:0.18-0ubuntu3
PackageArchitecture: i386
ProcCmdline: xchat-gnome
ProcCwd: /home/nayif
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xchat-gnome
Uname: Linux nayif.net 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

nayif alhjazi (nayifs) wrote :
Pedro Villavicencio (pedro) wrote :

Confirmed in Gutsy: Is a side effect of patch in bug 148124

Changed in xchat-gnome:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

Warnings of xchat-gnome when you try to activate the away from the GUI:

(xchat-gnome:30463): GLib-GObject-WARNING **: invalid uninstantiatable type
`-g-type-private--IFaceHolder' in cast to `GtkToggleButton'

(xchat-gnome:30463): Gtk-CRITICAL **: gtk_toggle_button_get_active: assertion
`GTK_IS_TOGGLE_BUTTON (toggle_button)' failed

Tom_OConnor (tom-twinhelix) wrote :

I've got this too.. Except when I try, it crashes SIGSEGV.
annoying++;

toconnor@tequila:~$ xchat-gnome 2>&1

(xchat-gnome:1600): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `GtkToggleButton'
Segmentation fault

toconnor@tequila:~$ lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04
toconnor@tequila:~$ apt-cache policy xchat-gnome
xchat-gnome:
  Installed: 1:0.18-2ubuntu4
  Candidate: 1:0.18-2ubuntu4
  Version table:
 *** 1:0.18-2ubuntu4 0

Saivann Carignan (oxmosys) wrote :

Since this bug now causes a segmentation fault, I change the importance to medium and I report this issue upstream. I also attach a backtrace and a valgrind to help developers fixing this.

Changed in xchat-gnome:
importance: Low → Medium
Changed in xchat-gnome:
status: Unknown → New
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Philip Wyett (philwyett) wrote :

Attached is an updated patch taken from version 2630 svn trunk of xchat-gnome and is a drop in replacement patch for hardy and intrepid. Hopefully this after review will find it's way in as updates to both.

Saivann Carignan (oxmosys) wrote :

Philip Wyett : Does this patch fixes the issue, or it disable the "away" functionality?

Philip Wyett (philwyett) wrote :

This patch maintains the away fix and it's functionality from svn and the previous patch it would supersede and also eliminates the crasher when trying to apply a change by clicking on the 'Change' button.

Saivann Carignan (oxmosys) wrote :

Nice, then this might be useful to patch it upstream. Can you attach your patch to the upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=549084 ?

Philip Wyett (philwyett) wrote :

This code was diffed from upstream svn revision 2630. I have been through a few bugs upstream and they don't seem to be getting much love and haven't for a while.

Saivann Carignan (oxmosys) wrote :

Philip Wuett : Oh then, since there seems to be many chances that there will be no new xchat-gnome release for intrepid, I believe that we should use this patch to fix xchat-gnome directly in intrepid. Firstly, can you look if this patch introduces other bug? If not, can you provide a debdiff so your works gets reviewed for intrepid? Thanks for your work so far!

Philip Wyett (philwyett) wrote :

Attached is the debdiff to intrepid.

A change to the away conflict was made for intrepid, but I see cleaning this functions code up to latest svn is no bad thing. Quite a number of issue with xchat-gnome for intrepid and hardy need to be addressed. With no xchat-gnome release in quite sometime, I may from now package svn for testing and hopefully fixes for hardy which is my main priority in my working life.

Sebastien Bacher (seb128) wrote :

the upstream bug should be closed if the bug is fixed in svn

Changed in xchat-gnome:
milestone: later → none
Saivann Carignan (oxmosys) wrote :

Ubuntu sponsors for universe : Can you review and consider the debdiff of Philip Wyett for upload to intrepid? I can confirm that this debdiff fixes the crash bug. I built this debdiff in my PPA so it can also be tested :

deb http://ppa.launchpad.net/saivann/ubuntu intrepid main

Philip Wyett (philwyett) wrote :

I would also propose the patch I attached prior to the debdiff be incorporated into hardy as an update to fix the crash bug introduced by the previous current away patch in 0.18-2ubuntu4.

Saivann Carignan (oxmosys) wrote :

Philip Wyett : I also agree. Can you provide a debdiff for hardy-proposed and subscribe motu-sru to the bug report? The intrepid debdiff cannot be applied to hardy because the patches are different, so we need another debdiff for hardy-proposed.

Philip Wyett (philwyett) wrote :

Attached is the debdiff for hardy.

Philip Wyett (philwyett) wrote :

Hopefully these patches are of the correct format and acceptable for processing and I hope they gain inclusion.

Thanks Saivann for the guidance and assistance in what is required. Much appreciated!

Saivann Carignan (oxmosys) wrote :

Philip Wyett : Thank you very much for your work on this! I forgot to mention you that hardy debdiff version number should have a appropriate version number for a Stable Release Update (generally followed by ~8.04.1). This is needed to avoid identical version numbers between different ubuntu releases. Also, I changed "hardy" for "hardy-proposed" in your distribution field in changelog. Many thanks again for the work!

MOTU SRU : I've reviewed and tested this patch, it builds and works fine. The reasons why this debdiff could qualify for a SRU is that it fixes a already existing patch which caused crash when setting as away. I believe that the situation where the crash can be reproduced is very common, and justify the SRU. Thanks for your review

Saivann Carignan (oxmosys) wrote :
Luca Falavigna (dktrkranz) wrote :

xchat-gnome is in main, subscribing ubuntu-sru instead. Thanks for your work!

Philip Wyett (philwyett) wrote :

Added updated debdiff. This adds the debian patch which eliminates the cpu to 100% jump that occurs when you open the preferences dialog. Please prefer this patch for SRU release.

This I believe covers the two critical bugs in hardy that needed to be fixed.

Changed in xchat-gnome:
status: New → Fix Released
Tom_OConnor (tom-twinhelix) wrote :

That patch works fine for me! It also fixes the CPU jump issue.

Sebastien Bacher (seb128) wrote :

does that still need to be fixed in intrepid? there seem to have no intrepid debdiff there

Changed in xchat-gnome:
status: Triaged → Incomplete
Philip Wyett (philwyett) wrote :

The debdiff for intrepid is further back in this report.

Or for clarity:

http://launchpadlibrarian.net/17133982/xchat-gnome_0.18-3ubuntu2.debdiff

Sebastien Bacher (seb128) wrote :

thank you for the clarification

Changed in xchat-gnome:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the intrepid version has been uploaded, next time could you reference the bug in the changelog so it gets closed on upload

Changed in xchat-gnome:
status: Incomplete → Fix Released
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xchat-gnome:
status: Confirmed → Fix Committed
Saivann Carignan (oxmosys) wrote :

So far it works perfectly, as expected, like xchat in intrepid.

Martin Pitt (pitti) wrote :

Copied hardy-proposed to hardy-updates.

Changed in xchat-gnome:
status: Fix Committed → Fix Released
Changed in xchat-gnome:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.