php5 SIGSEGV on XCache vars query

Bug #1189436 reported by Pierre Schweitzer
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xcache (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

Using the following config:
# php5 -v
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/apc.so' - /usr/lib/php5/20090626/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.3.10-1ubuntu3.6 with Suhosin-Patch (cli) (built: Mar 11 2013 14:31:48)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with XCache v1.3.2, Copyright (c) 2005-2011, by mOo

XCache package installed being: Version: 1.3.2-1

When using munin_xcache.php from http://www.ohardt.net/dev/munin/, php5 crashes with SIGSEGV:
[10-Jun-2013 11:50:23] WARNING: [pool www] child 1449 exited on signal 11 (SIGSEGV - core dumped) after 1206.035654 seconds from start

Please find attached XCache config.
You can find core dump here: http://fc.isima.fr/~schweitz/schweitz/core

Regards,

Revision history for this message
Pierre Schweitzer (pierre-jean-schweitzer) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xcache (Ubuntu):
status: New → Confirmed
Revision history for this message
Xuefer (xuefer) wrote :

can you provide gdb back trace output? the core file is useless without binaries as i don't have ubuntu installed in my box

Revision history for this message
Pierre Schweitzer (pierre-jean-schweitzer) wrote :

Unfortunately, I cannot reproduce with the up to date release of php5 on Ubuntu 12.04 LTS. So I guess it's "resolved".
Version being now:
# php5 -v
PHP 5.3.10-1ubuntu3.13 with Suhosin-Patch (cli) (built: Jul 7 2014 18:54:55)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

Changed in xcache (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments