DVD playback no longer works on Trusty / XBMC Frodo 12.3

Bug #1315873 reported by Fuujuhi on 2014-05-04
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xbmc (Ubuntu)
Undecided
Unassigned

Bug Description

XBMC no longer plays back DVD media (whole disc or VOBs) since upgrade to Ubuntu Trusty 14.04 (from Precise 12.04).

Tested to occur on 3 different PCs, so it does not seem to be an hardware related thing.

Here some test cases:

1) Play DVD media disc - FAILED
2) Play VOB on DVD media disc - FAILED
3) Play ripped DVD (i.e. from HDD) - FAILED
4) Play VOB on ripped DVD - SUCCESS

Case (1) gives multiple errors in dmesg:
  [29947.860192] sr 1:0:0:0: [sr0]
  [29947.860198] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
  [29947.860201] sr 1:0:0:0: [sr0]
  [29947.860203] Sense Key : Illegal Request [current]
  [29947.860209] sr 1:0:0:0: [sr0]
  [29947.860213] Add. Sense: Read of scrambled sector without authentication
  [29947.860216] sr 1:0:0:0: [sr0] CDB:
  [29947.860218] Read(10): 28 00 00 00 03 fa 00 00 02 00

Other failures do not give any relevant error messages. xbmc.log does not contain any relevant information it seems.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xbmc 2:12.3+dfsg1-3ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
Date: Sun May 4 15:07:21 2014
PackageArchitecture: all
SourcePackage: xbmc
UpgradeStatus: Upgraded to trusty on 2014-04-23 (10 days ago)

Fuujuhi (fuujuhi) wrote :
Fuujuhi (fuujuhi) wrote :

Just tried the latest unstable xbmc release (XBMC 13.0 Gotham RC1), and it fixes the DVD playback issue.
Not sure this qualifies as a valid fix since this is not yet a stable release.

Fuujuhi (fuujuhi) wrote :

... actually XBMC 13.0 Gotham just turned stable some hours ago. So a possible fix would be to bump xbmc release to 13.0 in official ubuntu repo.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xbmc (Ubuntu):
status: New → Confirmed
Ricardo Graça (devius) wrote :

Theoretically, according to this guide: https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs it's also necessary to run the following command:

    sudo /usr/share/doc/libdvdread4/install-css.sh

I did that, but I still can't play dvds. I also get the same error about "Add. Sense: Read of scrambled sector without authentication" which seems to indicate that it's not possible to decode the copy protection mechanism, even though libdvdcss is installed.

Ricardo Graça (devius) wrote :

After running the previous command the only difference is that dmesg no longer shows the "Add. Sense" errors. In fact there are no erros, but XBMC still hangs in the "Loading" part when trying to playback a DVD.

Using vlc to play the same DVD works fine though.

Fuujuhi (fuujuhi) wrote :

Did you try xmbc 13.0 ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers