v4lctl show color return undefined symbol: tan

Bug #821916 reported by corentin barbu on 2011-08-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xawtv (Debian)
Fix Released
Unknown
xawtv (Ubuntu)
Undecided
Julian Taylor
Natty
Undecided
Unassigned

Bug Description

It looks like v4lctl cannot find the math library.
$ v4lctl show color
dlopen: /usr/lib/xawtv/flt-disor.so: undefined symbol: tan
dlopen: /usr/lib/xawtv/flt-gamma.so: undefined symbol: pow
ioctl: VIDIOC_G_STD(std=0xbfa78e6f0000005c [PAL_G,PAL_H,PAL_I,PAL_D1,(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)]): Invalid argument
fixme: 404 color
I'm under Ubuntu 11.04 and

$ apt-cache policy xawtv
xawtv:
  Instalados: 3.95.dfsg.1-8.1ubuntu2
  Candidato: 3.95.dfsg.1-8.1ubuntu2
  Tabla de versión:
 *** 3.95.dfsg.1-8.1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status
I traced this from skype not displaying the webcam image ok, cheese either trying to change the settings with xawtv improved the thing but was not working as expecting graphically, finally setting directly the video parameters with v4lctl bring this stupid link error, maybe related to #778292. In this case I think it's priority should be a little higher than medium as it affects a large range of package including webcam that is a master piece o user adoption of Ubuntu by lambda user.

Related branches

Changed in xawtv (Ubuntu):
status: New → Confirmed
Julian Taylor (jtaylor) on 2011-08-06
Changed in xawtv (Ubuntu):
assignee: nobody → Julian Taylor (jtaylor)
Julian Taylor (jtaylor) on 2011-08-06
tags: added: patch-forwarded-debian
Felix Geyer (debfx) on 2011-08-06
Changed in xawtv (Ubuntu Natty):
status: New → Confirmed
Julian Taylor (jtaylor) wrote :

it is not related to bug 778292
ld --as-needed used to compile it and its dependencies dropped the libm link which these plugins directly needed but only linked indirectly.
The fix is to simply link them explicitly. Additionally conv-mjpeg is missing a link against libjpeg.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xawtv - 3.95.dfsg.1-8.1ubuntu5

---------------
xawtv (3.95.dfsg.1-8.1ubuntu5) oneiric; urgency=low

  * Add 104_fix_plugin_links.dpatch: (LP: #821916)
    - link some plugins against libm and libjpeg
 -- Julian Taylor <email address hidden> Sat, 06 Aug 2011 23:19:29 +0200

Changed in xawtv (Ubuntu):
status: Confirmed → Fix Released
Changed in xawtv (Debian):
status: Unknown → New
corentin barbu (corentin-barbu) wrote :

And where is it released exactly, is it possible to get it or will it be automatically included in the normal updates? If yes, have you an idea of the time this may takes?
Thanks

Julian Taylor (jtaylor) wrote :

the fix was released in the ubuntu development version 11.10 oneiric.
But I'm not sure it will fix your skype problem, it only fixes the linking of these two plugins in xawtv.

can you test it in natty or oneiric, and report back it solves your problem.

To build and install the fix in natty do:
apt-get install devscripts equivs
dget -ux https://launchpad.net/ubuntu/+archive/primary/+files/xawtv_3.95.dfsg.1-8.1ubuntu5.dsc
cd xawtv-3.95.dfsg.1/
mk-build-deps -i -r
dch -b -v "3.95.dfsg.1-8.1ubuntu4.1~natty1" -m "test backport"
debuild -us -uc
#install all packages
debi ../xawtv_3.95.dfsg.1-8.1ubuntu4.1~natty1_amd64.changes
apt-get install -f
# or install only selected packages use these listed by: ls -ltr ../*deb with the tool of your choice

to remove the build dependencies again use: apt-get autoremove xawtv-build-deps

Thank you Julian for your detailed explanation, I've a workarround for the
skype problem but I tried this to check the fix. I got:

Everything ok until:
>dch -b -v "3.95.dfsg.1-8.1ubuntu4.1~natty1" -m "test backport"
dch warning: new version (3.95.dfsg.1-8.1ubuntu4.1~natty1) is less than
the current version number (3.95.dfsg.1-8.1ubuntu5).

>debuild -us -uc
issue a bunch of warnings (really an awful lot)

Then I changed:
>debi ../xawtv_3.95.dfsg.1-8.1ubuntu4.1~natty1_amd64.changes
for
>deb ../xawtv_3.95.dfsg.1-8.1ubuntu4.1~natty1_i386.changes
as I use a ubuntu 32 bit version (it's a pretty old computer)

Then in ..
sudo apt-get install ./*deb
That issues a lot of
E: No se encontró la Distribución
«xawtv-tools_3.95.dfsg.1-8.1ubuntu4.1~natty1_i386.deb»
and an awful lot of these with various
****3.95.dfsg.1-8.1ubuntu4.1~natty1_i386.deb

Then actually the tan problem disappear:
v4lctl show color
ioctl: VIDIOC_G_STD(std=0xbfa44e480000005c
[PAL_G,PAL_H,PAL_I,PAL_D1,(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)]):
Invalid argument
fixme: 404 color

It also fix the impossibility to set move the Bright and the Contrast in the
graphic interface of xawtv.

However the Gamma and the Sharpness cannot be changed "up" should I open an
other but for this?

Corentin

2011/8/11 Julian Taylor <email address hidden>

> the fix was released in the ubuntu development version 11.10 oneiric.
> But I'm not sure it will fix your skype problem, it only fixes the linking
> of these two plugins in xawtv.
>
> can you test it in natty or oneiric, and report back it solves your
> problem.
>
> To build and install the fix in natty do:

apt-get install devscripts equivs
> dget -ux
> https://launchpad.net/ubuntu/+archive/primary/+files/xawtv_3.95.dfsg.1-8.1ubuntu5.dsc
> cd xawtv-3.95.dfsg.1/
> mk-build-deps -i -r
> dch -b -v "3.95.dfsg.1-8.1ubuntu4.1~natty1" -m "test backport"
> debuild -us -uc
> #install all packages
> debi ../xawtv_3.95.dfsg.1-8.1ubuntu4.1~natty1_amd64.changes
> apt-get install -f
> # or install only selected packages use these listed by: ls -ltr ../*deb
> with the tool of your choice
>
> to remove the build dependencies again use: apt-get autoremove xawtv-
> build-deps
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/821916
>
> Title:
> v4lctl show color return undefined symbol: tan
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/xawtv/+bug/821916/+subscriptions
>

--
___________________
Corentin Barbu-Covantes
http://corentin.barbu.free.fr
Sauvé pour Aimer et Servir.

Changed in xawtv (Debian):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in xawtv (Ubuntu Natty):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.