Ubuntu

Warning in file "/usr/share/applications/xarchiver.desktop": usage of MIME type "multipart/x-zip" is discouraged

Reported by Laurent Bonnaud on 2010-04-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xarchiver (Debian)
Fix Released
Unknown
xarchiver (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xarchiver

Here is the problem:

# update-desktop-database
[...]
Warning in file "/usr/share/applications/xarchiver.desktop": usage of MIME type "multipart/x-zip" is discouraged ("multipart" is a media type that probably does not make sense in this context)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xarchiver 1:0.5.2+20090319+dfsg-4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic-pae 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic-pae i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Tue Apr 27 19:09:07 2010
EcryptfsInUse: Yes
SourcePackage: xarchiver

This bug is still in maverick (the package version did not change).

summary: - discouraged MIME type in /usr/share/applications/xarchiver.desktop
+ Warning in file "/usr/share/applications/xarchiver.desktop": usage of
+ MIME type "multipart/x-zip" is discouraged

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xarchiver (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged

This bug is still in oneiric since the package version did not change.

DNS (dns) wrote :

Not sure why its still not fixed, i attach an update of the mime patch...
And here are builds with the new patch: https://launchpad.net/~dns/+archive/misc/+packages?field.name_filter=xarchiver&field.status_filter=published&field.series_filter=

Changed in xarchiver (Debian):
status: Unknown → New

The attachment "02-mime-types.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in xarchiver (Debian):
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

 xarchiver (1:0.5.2+20090319+dfsg-4.1) unstable; urgency=low

   * Non-maintainer upload.
   * Add patch 04-fix-7z-crash.patch and restore the ability to open and view
     7z archives again. (Closes: #665642)
   * Remove discouraged MIME type multipart/x-zip from desktop file.
     (Closes: #656301)
   * Don't mention xarchive in the package description because it isn't
     available in Debian. (Closes: #692261)

Changed in xarchiver (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.