Tutorials and Help not found

Bug #34693 reported by Peter Garrett on 2006-03-13
10
Affects Status Importance Assigned to Milestone
xaos (Ubuntu)
Medium
Unassigned

Bug Description

Using xaos_3.1r-8ubuntu4_i386 (Breezy) ,
Steps to reproduce:
1- Call xaos, or xaos -fullscreen

2.clicking the Help-Tutorial menu entry and selecting any sub - entry results in an error "Tutorial files not found - reinstall XaoS" - which flashes up rather quickly and then disappears ;-) The Help files are also not found, with similar results.

I assume the path to the help/tutorial files that the program expects is incorrect.

 dpkg -l xaos
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-====================-====================-========================================================
ii xaos 3.1r-8ubuntu4 real-time interactive fractal zoomer

Nicholas Wheeler (dragoncow2) wrote :

This doesn't appear to be a bug in the most current version, so, this issue must have been resolved.

dpkg -l xaos
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii xaos 3.1r-14ubuntu2 real-time interactive fractal zoomer

Nicholas Wheeler (dragoncow2) wrote :

Fix Released, newest version doesn't have this problem.

Changed in xaos:
status: Unconfirmed → Fix Released
alex (alex-astroscu) wrote :

It doesn't seem to work on Feisty, I mean, It happens the same thing, clicking the Help-Tutorial menu entry and selecting any sub - entry results in an error "Tutorial files not found - reinstall XaoS"

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii xaos 3.2-3ubuntu1 real-time interactive fractal zoomer

On Sat, 03 Mar 2007 03:22:28 -0000
alex <email address hidden> wrote:

> It doesn't seem to work on Feisty, I mean, It happens the same thing,
> clicking the Help-Tutorial menu entry and selecting any sub - entry
> results in an error "Tutorial files not found - reinstall XaoS"

Confirmed: this bug is back one year after it was fixed :)

Running the Feisty version on the live Desktop Herd 5 CD here results in
the same old problem.

I compiled, on the live CD session, from the orig.tar.gz source code for
this version, using apt-get source xaos, apt-get build-dep , ./configure &&
make
- and when compiled from the vanilla source this problem does not exist.

Using apt-get source -b xaos makes a package which *does* return the error
in question.

The tutorial runs, for example, from the vanilla ".orig" source compile -
whereas the Ubuntu package returns an error as reported above by alex. I
therefore assume this is a packaging problem, either from the Debian
package, or the Ubuntu package derived from it?

LaserJock (laserjock) wrote :

I can't reproduce this on Feisty. The help and tutorials work fine for me.

ii xaos 3.2-3ubuntu1 real-time interactive fractal zoomer

Peter Garrett (peter-garrett) wrote :

This seems to have reappeared - see my mail concerning the difference between a compile from .orig and from apt-get source -b xaos

Changed in xaos:
status: Fix Released → Confirmed
Peter Garrett (peter-garrett) wrote :

Perhaps there is a hardware related issue - I have just confirmed the bug, as outlined above. i am running on the i386 architecture, using a SiS onboard graphics card, Celeron 2 GHz CPU

 $ lspci | grep VGA
0000:01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter

 $ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Celeron(R) CPU 2.00GHz
stepping : 7
cpu MHz : 2018.312
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips : 4040.58

512 MB RAM, 32 MB shared with graphics, no acceleration, of course

LaserJock (laserjock) wrote :

I kinda doubt it's hardware if the error is that it can't find the docs. For what it's worth I have similar hardware.
What does the following commands give you:
ls -lh /usr/share/doc/xaos/examples
ls /usr/share/XaoS/

Peter Garrett (peter-garrett) wrote :

On Sat, 03 Mar 2007 07:09:02 -0000
Jordan Mantha <email address hidden> wrote:

> I kinda doubt it's hardware if the error is that it can't find the docs. For what it's worth I have similar hardware.

Heh - yes, agreed. I need more coffee...

> What does the following commands give you:
> ls -lh /usr/share/doc/xaos/examples
> ls /usr/share/XaoS/

$ ls -lh /usr/share/doc/xaos/examples
lrwxrwxrwx 1 root root 19 2007-03-03 07:32 /usr/share/doc/xaos/examples
-> ../../XaoS/examples

$ ls /usr/share/XaoS/
catalogs examples help tutorial

Both of which look fine. However, possible clues follow:

Launched from the terminal with "xaos", I see no error. Launched from
the menu I see the error every time

Also, if I use the *full menu command* as read from the properties , viz.
"xaos -driver x11" , there is no error _when launched from a terminal_.

I tried this a number of times, with the same result. Apparently when
launched from the terminal, it finds the docs and examples, but *not* when
launched from the Gnome menu. I also tried it from a launcher created by
dragging the menu entry from the menu to the panel. Got the error every
time.

Same with an icon dragged to the desktop from the menu - errors every time.

Hope that gives you something to go on - I don't know enough to diagnose
it but it seems to be something to do with the Gnome environment
(panel, menus, desktop... ?? )

LaserJock (laserjock) wrote :

OK, I figured out why it was working sometime but not others for me. If I am in /usr/share/Xaos/ or in the Xaos source it finds the help just fine, otherwise it doesn't. It looks like it's able to find the files only if they are in the current directory. Perhaps Xaos is not figuring out what the datadir is.

mlamertz (ubuntu-tweety) wrote :

stracing xaos shows, that a configure-variable isn't properly expanded in the compiled binary:

Try 'strace -e open xaos', then hit F1 and you'll see among others

open("${prefix}/share/XaoS/help/xaos.hlp", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/home/mlamertz//help/xaos.hlp", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/home/mlamertz//../help/xaos.hlp", O_RDONLY) = -1 ENOENT (No such file or directory)
open("./help/xaos.hlp", O_RDONLY) = -1 ENOENT (No such file or directory)
open("../help/xaos.hlp", O_RDONLY) = -1 ENOENT (No such file or directory)
open("./xaos.hlp", O_RDONLY) = -1 ENOENT (No such file or directory)

Note the first line's "${prefix}/share/..."?

LaserJock (laserjock) wrote :

This has been fixed in gutsy

Changed in xaos:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers