x264 [error]: not compiled with MP4 output support

Bug #464797 reported by phenest on 2009-10-30
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
x264 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: x264

I've just upgraded from Jaunty to Karmic to discover that the x264 package was not compiled with MP4 support. I'm resorting to using the package for Jaunty.

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x264 - 2:0.85.1442.1+git781d30-1

---------------
x264 (2:0.85.1442.1+git781d30-1) lucid; urgency=low

  * use proper upstream version
    (NB: the first number (85) is the API version,
         the second the number of git commits so far)
  * New upstream version should fix: LP: #315697, #463516
  * Many ARM Neon Optimisations, LP: #388388
  * this package is properly maintained in ubuntu. Indicate this by using
    "-N" as versioning scheme.
  * change versioning scheme as discussed with upstream. Requires bumping
    epoch, though.
  * ensure that MP4 output support is enabled, LP: #464797
 -- Reinhard Tartler <email address hidden> Thu, 18 Feb 2010 07:39:51 +0100

Changed in x264 (Ubuntu):
status: New → Fix Released
Rory McCann (rorymcc) wrote :

This is error is still happening. I have tried versions 2:0.85.1442.1+git781d30-1 and 2:0.85.1448+git1a6d32-2 of x264 and I still get the same error message:

x264 [error]: not compiled with MP4 output support

This bug should be re-opened.

Rory McCann (rorymcc) wrote :

I have successfully patched and recompiled x264 to enable MP4 output. I'm attaching a debdiff against 2:0.85.1448+git1a6d32

llogan (loul) wrote :

I didn't test your patch, but --enable-mp4-output is not a valid option for r1448. x264 should automatically detect the presence of gpac (required for mp4 output) during ./configure.

Changed in x264 (Ubuntu):
status: Fix Released → Triaged
tags: added: patch

fixed package is uploaded, pending approval and awaiting publication
--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x264 - 2:0.85.1448+git1a6d32-3

---------------
x264 (2:0.85.1448+git1a6d32-3) lucid; urgency=low

  [ Loïc Minier ]
  * Finish confflags logic and/or add workarounds

  [ Reinhard Tartler ]
  * build depend on libgpac-dev to enable mp4 support, LP: #464797
  * simplify configure line, LP: #538555
  * generate manpage with help2man to keep it up-to-date, LP: #391281
 -- Reinhard Tartler <email address hidden> Sun, 14 Mar 2010 10:10:26 +0100

Changed in x264 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers