bime and brdo options in x264 dropped (now set with subme), x264 and mencoder man pages need to be updated

Bug #371786 reported by Loïc Martin on 2009-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MPlayer
Fix Released
Undecided
Unassigned
x264 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: x264

As of r996, bime and brdo options aren't used any more in x264, instead subme values goes up to 9 (previously only 7) and their meaning have changed.

See http://forum.doom9.org/showthread.php?t=141569 for an explanation.

Using bime and/or brdo options lead to a failure of the encode.

Both x264 and mplayer (since mencoder man page is the one from mplayer) man pages refer to bime and brdo, this should be deleted and description of subme changed (see thread linked above for reference).

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: x264 1:0.svn20081230-0.0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: x264
Uname: Linux 2.6.28-11-generic i686

Related branches

Loïc Martin (loic-martin3) wrote :
Loïc Martin (loic-martin3) wrote :

Just for information, more recent versions of mplayer (provides mencoder) ship with a man page that has been updated.

Reinhard Tartler (siretart) wrote :

fixed in mplayer upstream according to loic.

Changed in mplayer:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x264 - 1:0.svn20090621+git364d7d-0ubuntu2

---------------
x264 (1:0.svn20090621+git364d7d-0ubuntu2) karmic; urgency=low

  * update symbol files with architecture specific symbols.
  * remove reference to the now removed bime version, LP: #371786

 -- Reinhard Tartler <email address hidden> Sun, 21 Jun 2009 18:18:51 +0200

Changed in x264 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers