mencoder crashed with SIGSEGV in x264_ratecontrol_mb()

Bug #315697 reported by Philipp Dreimann on 2009-01-10
6
Affects Status Importance Assigned to Milestone
x264 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mplayer

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/mencoder
NonfreeKernelModules: fglrx
Package: mencoder 2:1.0~rc2-0ubuntu17
ProcCmdline: mencoder ../Download/Anne_Will_09.01.04_21-45_ard_60_TVOON_DE.mpg.avi -passlogfile /tmp/Anne_Will_09.01.04_21-45_ard_60_TVOON_DE.mpg.avi.2pass.log -o /tmp/Anne_Will_09.01.04_21-45_ard_60_TVOON_DE.mpg.avi.temp.avi -ovc x264 -x264encopts pass=2:bitrate=450:vbv_maxrate=768:vbv_bufsize=244:nocabac:level_idc=13:turbo=1:me=umh:frameref=5:subq=6:partitions=all:trellis=1:direct_pred=auto:threads=auto: -vf pullup,softskip,crop=512:384:0:0,scale=320:-10,harddup -oac faac -faacopts mpeg=4:br=128:object=2 -channels 2 -srate 48000 -ofps 24000/1001
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.UTF-8
Signal: 11
SourcePackage: mplayer
Stacktrace:
 #0 0x00007f4b7ecadfb2 in x264_ratecontrol_mb () from /usr/lib/libx264.so.59
 #1 0x00007f4b7ecc1800 in ?? () from /usr/lib/libx264.so.59
 #2 0x00007f4b7ea523ba in start_thread () from /lib/libpthread.so.0
 #3 0x00007f4b7a55106d in clone () from /lib/libc.so.6
 #4 0x0000000000000000 in ?? ()
StacktraceTop:
 x264_ratecontrol_mb () from /usr/lib/libx264.so.59
 ?? () from /usr/lib/libx264.so.59
 start_thread () from /lib/libpthread.so.0
 clone () from /lib/libc.so.6
 ?? ()
Title: mencoder crashed with SIGSEGV in x264_ratecontrol_mb()
Uname: Linux 2.6.28-4-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare scanner tape vboxusers video

Related branches

StacktraceTop:x264_ratecontrol_mb (h=0x27e6f80,
x264_slices_write (h=0x27e6f80)
start_thread () from /lib/libpthread.so.0
error_at_line () from /lib/libc.so.6
?? ()

visibility: private → public
affects: mplayer (Ubuntu) → x264 (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x264 - 2:0.85.1442.1+git781d30-1

---------------
x264 (2:0.85.1442.1+git781d30-1) lucid; urgency=low

  * use proper upstream version
    (NB: the first number (85) is the API version,
         the second the number of git commits so far)
  * New upstream version should fix: LP: #315697, #463516
  * Many ARM Neon Optimisations, LP: #388388
  * this package is properly maintained in ubuntu. Indicate this by using
    "-N" as versioning scheme.
  * change versioning scheme as discussed with upstream. Requires bumping
    epoch, though.
  * ensure that MP4 output support is enabled, LP: #464797
 -- Reinhard Tartler <email address hidden> Thu, 18 Feb 2010 07:39:51 +0100

Changed in x264 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers