x11proto-(gl,randr,dri2)-dev need to be updated for backport stack

Bug #1081122 reported by Maarten Lankhorst on 2012-11-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
x11proto-dri2 (Ubuntu)
High
Maarten Lankhorst
Precise
High
Maarten Lankhorst
x11proto-gl (Ubuntu)
High
Maarten Lankhorst
Precise
High
Maarten Lankhorst
x11proto-randr (Ubuntu)
High
Maarten Lankhorst
Precise
High
Maarten Lankhorst

Bug Description

[Impact]
 * For the lts stack updates to x11proto-dri2, x11proto-gl and x11proto-randr are required
 * x11proto-gl and x11proto-dri2 are used for building xorg-server and mesa
 * x11proto-randr are used for building xorg-server and libxrandr

[Test Case]
 * Not really available, but rebuilding mesa, libxrandr and xorg-server should be good enough
 to verify it works correctly.

[Regression Potential]
 * Low, but have to look out for builds failing with defines conflicting with /usr/include/X11/extensions

[Other Info]
 * the x11proto headers only define structs and parameters used by the x11 protocol in a backwards compatible fashion.
 For testing the x stack I've had to rebuild the older xorg-server and mesa during testing, which worked fine with the newer headers.

affects: apt (Ubuntu) → x11proto-dri2 (Ubuntu)
Changed in x11proto-dri2 (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in x11proto-gl (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in x11proto-randr (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in x11proto-dri2 (Ubuntu):
importance: Undecided → High
Changed in x11proto-gl (Ubuntu):
importance: Undecided → High
Changed in x11proto-randr (Ubuntu):
importance: Undecided → High
Changed in x11proto-gl (Ubuntu):
milestone: none → ubuntu-12.04.2
Changed in x11proto-randr (Ubuntu):
milestone: none → ubuntu-12.04.2

Hello Maarten, or anyone else affected,

Accepted x11proto-dri2 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/x11proto-dri2/2.8-1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in x11proto-dri2 (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Maarten, or anyone else affected,

Accepted x11proto-randr into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/x11proto-randr/1.4.0+git20120101.is.really.1.4.0-0ubuntu1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in x11proto-randr (Ubuntu Precise):
status: New → Fix Committed
Changed in x11proto-gl (Ubuntu Precise):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Maarten, or anyone else affected,

Accepted x11proto-gl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/x11proto-gl/1.4.16-1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Maarten Lankhorst (mlankhorst) wrote :

I'll mark this as verification-done when the renamed mesa, xorg-server, and libxrandr are in precise-proposed, since those are the users of the new x11proto definitions.

Steve Langasek (vorlon) on 2012-12-04
Changed in x11proto-dri2 (Ubuntu):
status: New → Invalid
Changed in x11proto-gl (Ubuntu):
status: New → Invalid
Changed in x11proto-randr (Ubuntu):
status: New → Invalid
Changed in x11proto-randr (Ubuntu Precise):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
milestone: none → ubuntu-12.04.2
Changed in x11proto-gl (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Maarten Lankhorst (mlankhorst)
milestone: none → ubuntu-12.04.2
Changed in x11proto-dri2 (Ubuntu Precise):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
milestone: none → ubuntu-12.04.2
tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) wrote :

Those three packages, and indeed the entire backport stack, are built in precise-proposed.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-dri2 - 2.8-1~precise1

---------------
x11proto-dri2 (2.8-1~precise1) precise-proposed; urgency=low

  * Upload to precise for the hw enablement backport stack (LP: #1081122).
 -- Timo Aaltonen <email address hidden> Tue, 20 Nov 2012 21:02:02 +0200

Changed in x11proto-dri2 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-gl - 1.4.16-1~precise1

---------------
x11proto-gl (1.4.16-1~precise1) precise-proposed; urgency=low

  * Upload to precise for the hw enablement backport stack (LP: #1081122).
 -- Timo Aaltonen <email address hidden> Tue, 20 Nov 2012 21:06:06 +0200

Changed in x11proto-gl (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-randr - 1.4.0+git20120101.is.really.1.4.0-0ubuntu1~precise1

---------------
x11proto-randr (1.4.0+git20120101.is.really.1.4.0-0ubuntu1~precise1) precise-proposed; urgency=low

  * Upload to precise for the hw enablement backport stack (LP: #1081122).
 -- Timo Aaltonen <email address hidden> Tue, 20 Nov 2012 21:13:23 +0200

Changed in x11proto-randr (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers