xrandr --scale XxY crashed with SIGSEGV in __libc_start_main()

Bug #354715 reported by Felix Kuehling
6
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
x11-xserver-utils (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: x11-xserver-utils

I'm using Latest Jaunty as at Apr 3, 2009, 3PM. Running xrandr --scale XxY or xrandr --transform ... ends in a segfault in xrandr. The transformation is not applied.

I'm running Xorg with an empty xorg.conf on a Radeon HD 3600 using the radeon driver (/usr/lib/xorg/modules/drivers//radeon_drv.so). I've seen the same problem with a Radeon X1200 (AMD 690G) using the same driver.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/xrandr
Package: x11-xserver-utils 7.4+1
ProcCmdline: xrandr --scale 0.5x0.5
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #39-Ubuntu SMP Thu Apr 2 03:00:35 UTC 2009
Signal: 11
SourcePackage: x11-xserver-utils
Stacktrace:
 #0 0x080498af in ?? ()
 #1 0x0804ff6a in ?? ()
 #2 0xb7d5f775 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
 #3 0x080495a1 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
 __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
 ?? ()
Title: xrandr crashed with SIGSEGV in __libc_start_main()
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
XorgConf:
 Section "ServerFlags"
  Option "DontZap" "off"
 EndSection

[lspci]
00:00.0 Host bridge [0600]: ATI Technologies Inc RS690 Host Bridge [1002:7910]
     Subsystem: ATI Technologies Inc RS690 Host Bridge [1002:7910]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV630 [Radeon HD 2600XT] [1002:9588]
     Subsystem: ATI Technologies Inc Device [1002:2542]

Revision history for this message
Felix Kuehling (fxkuehl) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt (retraced)

StacktraceTop:init_transform (transform=0xac)
main (argc=3, argv=0xbfc02464) at ../xrandr/xrandr.c:2327

Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt (retraced)
Changed in x11-xserver-utils (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Bryce Harrington (bryce)
tags: added: crash
Changed in x11-xserver-utils (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce)
description: updated
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

that's because the driver only supports randr 1.2, and scale needs 1.3. Try 9.10 alpha3 livecd.

visibility: private → public
affects: x11-xserver-utils (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Felix Kuehling (fxkuehl) wrote :

xrandr --output <bla> --scale or --transform works fine with Jaunty. The segfault only happens when I omit the --output parameter. In a way it makes sense, since --scale and --transform are output-specific. Would be nice though, if xrandr could print an error message pointing out my mistake instead of just crashing.

Revision history for this message
Bryce Harrington (bryce) wrote :

Please check if it is still happening with Karmic, before we send it upstream. Thanks ahead of time.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
Felix Kuehling (fxkuehl) wrote :

Still happens on Karmic with x11-xserver-utils 7.4+2. I ran xrandr --scale 1x1 which resulted in a segfault.

Bryce Harrington (bryce)
tags: added: jaunty
Bryce Harrington (bryce)
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new version of the -ati driver is now available in Karmic.

This is a significant update to -ati which brings in kernel mode-setting
(currently disabled) and scores of fixes for DRI2, EXA, etc.

I've posted the new version of this driver to the following PPA,
would you mind testing it and seeing if it resolves the bug you
reported?

  https://edge.launchpad.net/~bryceharrington/+archive/ppa/+sourcepub/709908/+listing-archive-extra

If you're not running this release of Ubuntu, you can try booting the Karmic
LiveCD and loading the PPA onto it, and then log out/in to restart X.
ISOs are available at http://cdimages.ubuntu.com/releases/

After testing Karmic, report back here whether it's still an issue or not,
and if it is please post a fresh Xorg.0.log and 'dmesg' output.

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug xorg'.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Felix Kuehling (fxkuehl) wrote :

The problem persists with the new Radeon driver PPA. I strongly suspect that this problem is not driver-specific.

xrandr --output VGA-0 --scale 0.5x0.5 works as expected
xrandr --scale 0.5x0.5 segfaults.

It should report an error message instead of just crashing.

Revision history for this message
In , Bryce Harrington (bryce) wrote :

Created an attachment (id=29095)
0001-Check-output-pointer-validity-for-sale-and-transform.patch

Running xrandr --scale 1x1 or --transform, without specifying --output, causes crash.

Forwarding from
https://bugs.edge.launchpad.net/ubuntu/+source/xrandr/+bug/354715

Bryce Harrington (bryce)
affects: xserver-xorg-video-ati (Ubuntu) → xrandr (Ubuntu)
Bryce Harrington (bryce)
affects: xrandr (Ubuntu) → x11-xserver-utils (Ubuntu)
Changed in xorg-server:
status: Unknown → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11-xserver-utils - 7.4+2ubuntu2

---------------
x11-xserver-utils (7.4+2ubuntu2) karmic; urgency=low

  * 100_xrandr-output.patch: Replace with patch sent upstream.
    (LP: #354715)

 -- Bryce Harrington <email address hidden> Wed, 02 Sep 2009 02:15:48 -0700

Changed in x11-xserver-utils (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
In , Julien Cristau (jcristau) wrote :

adding qa contact.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.