Hardy alpha 1 wants to use compiz in vmware

Bug #173012 reported by Martin Pitt on 2007-11-30
2
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
x11-xserver-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

In Gutsy, compiz was blacklisted on the vmware driver. However, in Hardy Alpha 1 this doesn't seem to be the case: compiz tries to start, and I immediately land in gdm again because it fails. I'll attach .xsession-errors, Xorg.0.log and xorg.conf.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

After I hack /usr/bin/compiz to blacklist the driver, the session works again.

Changed in compiz:
status: New → Confirmed
Travis Watkins (amaranth) wrote :

The real bug is that we can't tell what driver you're using because we can't find the log file.

seamuso (seamuso) wrote :

Same issue here, 32bit and 64bit from gutsy to hardy upgrade and from cd image install of hardy alpha1. Crash back to GDM unless failsafe session is used, an alternate (I use xfce4 as an alternate) window manager is used or the driver is switched to vesa

driver-
xserver-xorg-video-vmware

version-
1:10.15.2-1(hardy)

blacklisting with the following cures the problem

T="$T 15ad:0405 " # VMware SVGA II

seamuso (seamuso) wrote :

Realized I forgot the compiz info for my previous post

compiz version info -

1:0.6.2+git20071119-0ubuntu1

Travis Watkins (amaranth) wrote :

x11-xserver-utils 7.3+1ubuntu1 fixes xset so it gives us the log file again.

Changed in compiz:
status: Confirmed → Fix Released
Changed in compiz:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers