Grey stripe covering the menu with gnome classic

Bug #996407 reported by dauriac on 2012-05-08
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Audacity
Fix Released
Unknown
wxWidgets
Fix Released
Unknown
wxwidgets2.8 (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned

Bug Description

Sometimes a gray stripe appears above the menu. This gray stripe cover everything except the very beginning of the File entry, and prevents from clicking on the covered entries. It disappears when re-sizing the window.

It seems to be linked to libdbusmenu as we have the following message appearing multiple time in the terminal when closing Audacity (no matter if we triggered the bug or not) :

(Audacity:15303): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

[Test Case]
Open Audacity.
Go to Preferences.
Close Preferences (Enter or click on "OK" button)

This is very similar to bug #955293 https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/955293

Created an attachment (id=209)
screenshot

Tested with
Audacity 1.3.13,
Audacity 1.3.14 svn Nov 18th
Audacity 1.3.14 rc1

Debian Squeeze with Gnome 3 and Gnome Classic (fallback)
Also tested on Debian stable in Virtualbox.

Steps to reproduce:
1) Open Audacity
2) Open Preferences (Ctrl+P or from menu)
3) Close Preferences (Enter or click on "OK" button)
The main menu disappears leaving just "Fi" showing (screenshot below).
The menu does not disappear if the "Cancel" button is clicked.
The menu returns to normal as soon as the window is resized.

In , Gale (gale) wrote :

I'm still on Ubuntu 10.10 (yay) and "Gnome 2.24.1-6ubuntu1". I can clearly see
that "Fi" after closing Preferences but a second or so after it, all the menus
seem to be refreshed. If I thrash the disk with some task I can make the "Fi"
last for several seconds.

(In reply to comment #1)
OK, so it looks like it is probably not specific to Gnome 3 so I've taken out
the Gnome 3 reference in the bug title.

I did not have the issue on Ubuntu 10.x, but on my current Debian set-up the
menus do not reappear on their own. Resizing the Audacity window is required to
get the menu back.

In , Gale (gale) wrote :

1.3.12 repo build against wxWidgets 2.8.11 on Ubuntu 10.10 behaves same as HEAD
for me ("Fi" for a second or two before the full menus appear).

(In reply to comment #3)
I'm building against WxWidgets 2.8.12

(In reply to comment #4)
The problem appears to be with WxWidgets 2.8.12
I've "downgraded" to WxWidgets 2.8.10 and although there is still a short pause
before the menu refreshes, the menu reappears after a fraction of a second.

In , Gale (gale) wrote :

(In reply to comment #5)
> The problem appears to be with WxWidgets 2.8.12
It is a problem with 2.8.12 on some (more recent?) distros. I don't see this
issue on Ubuntu 10.10 building HEAD against 2.8.12.

Gale

(In reply to comment #6)
I'm currently using Debian Squeeze (stable). It's not really a "more recent"
distribution (released in Feb 2011).

I didn't get the problem on Ubuntu 10.10, perhaps something in Debian is too
old?

In , Gale (gale) wrote :

(In reply to comment #6)
> I don't see this issue on Ubuntu 10.10 building HEAD against 2.8.12
Nor on Ubuntu 11.10 with 2.8.11 or 2.8.12 (having logged in with the Gnome
fallback shell and so disabled the Unity "global menu").

I can reproduce the bug on Debian unstable and Ubuntu 12.04 (precise) with
wxgtk 2.8.12. Older versions of wxgtk do not trigger it.

dauriac (dauriac) wrote :
Benjamin Drung (bdrung) on 2012-05-08
Changed in audacity (Ubuntu):
status: New → Confirmed
importance: Undecided → High

Confirmed on Fedora 16 and openSUSE 12.1 when built against WxWidgets 2.8.12.
http://forum.audacityteam.org/viewtopic.php?f=48&t=65589

As more distros are moving up to WxWidgets 2.8.12 I think the bug priority will
soon need increasing to P3 or even P2.

In , Gale (gale) wrote :

(In reply to comment #10)
I still don't think it's as simple as "which Widgets version". On Ubuntu 10.10
there is no issue, even if Audacity is built against wx2.8.12. On 11.10 on my
netbook, I can reproduce the issue using gnome-session-fallback in Audacity
built against both 2.8.11 (PPA Daily Build) and 2.8.12 (my own build of HEAD).

If using Unity (which most users will do) the only symptom is an added black
square after closing Preferences (where the "Fi" appears under
gnome-session-fallback).

Still, I agree the problem will get worse as time goes on and should be P2, so
promoted.

(In reply to comment #11)
Bug confirmed on Ubuntu Studio 12.04 with XFCE.

Does not occur in Ubuntu 12.04 with Unity desktop because the menu is in the
top panel and not in the Audacity window.

This is apparently fixed in wx head:http://trac.wxwidgets.org/ticket/13280.
We could wait till 2.8.13 (which should be soon) or apply the patch linked from
that trac url to wxGTK.

Thanks Michael, this seems to be exactly the issue and fix we need. I've
applied changeset 67929 to my local copy of 2.8.12 and it now works properly
(slight flicker on close, but I don't loose the menu bar).

There is not a lot we can do with this fix directly, because we don't build
wxwidgets. However we can point distribution packagers here to get the fix they
need to put into their wx packages, which is useful.

This link will get you the patch, but it has to be applied with -p4 because of
repository paths in the patch
http://trac.wxwidgets.org/changeset/67929?format=diff&new=67929

I'll take care to get this wxwidgets patch into Ubuntu 12.04 (precise) and
later.

(In reply to comment #15)
Thanks, that should reduce the number of reports we get in.

Benjamin Drung (bdrung) wrote :

Which version of Ubuntu are you running?

Benjamin Drung (bdrung) on 2012-05-27
affects: audacity (Ubuntu) → wxwidgets2.8 (Ubuntu)
Changed in audacity:
status: Unknown → Won't Fix
Changed in wxwidgets:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.12.1-9ubuntu1

---------------
wxwidgets2.8 (2.8.12.1-9ubuntu1) quantal; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/rules: re-enable mediactrl. This allows libwx_gtk2u_media-2.8 to be
      built, as this is required by some applications (LP: #632984)
    - debian/control:
      - Build-dep on libxt-dev, libgstreamer-plugins-base0.10-dev,
        and libgconf2-dev for mediactrl.
      - Add conflict on python-wxgtk2.8 (<< 2.8.12.1-6ubuntu1~) to
        python-wxversion to guarantee upgrade ordering when moving from
        pycentral to dh_python2.
    - Patches
      + fix-bashism-in-example.patch
  * Backport patch to fix calling SetMenuBar() twice causes the menubar to not
    resize correctly in GTK. (LP: #996407)

wxwidgets2.8 (2.8.12.1-9) unstable; urgency=low

  * Switch to "3.0 (quilt)" to fix issues with patches not getting applied at
    the right time, fixing FTBFS on buildds since they started to use
    build-arch. (Closes: #670447)

wxwidgets2.8 (2.8.12.1-8) unstable; urgency=low

  * New patch handle-positional-printf-arguments.patch. (Closes: #631696)
  * debian/patches/remove-refs-to-FPB_DEFAULT_STYLE.patch: Strip CR.
  * New patch debian/patches/de.po.patch. (Closes: #663488)
  * Standards-Version: 3.9.3 (no changes required).

wxwidgets2.8 (2.8.12.1-7) unstable; urgency=low

  * Fix path to one of the bogus executable files in wx2.8-examples so it gets
    made non-executable as intended, really fixing the final lintian warning.
  * Add patch remove-refs-to-FPB_DEFAULT_STYLE.patch to fix warning upon
    refresh in XRCed. (Closes: #654990)
  * Fix syntax of "Bug-Debian" header in fix-wxcmdline-segv.patch.
  * Add patch fix-more-typos.patch which fixes an assortment of typos in
    documentation, documentation comments, and docstrings.
  * "debian/rules clean" now removes wxPython/build-options.cache.
 -- Benjamin Drung <email address hidden> Sun, 27 May 2012 17:32:13 +0200

Changed in wxwidgets2.8 (Ubuntu):
status: Confirmed → Fix Released
Benjamin Drung (bdrung) on 2012-05-27
description: updated
Benjamin Drung (bdrung) wrote :

Here's the debdiff for Ubuntu 12.04 (precise).

Changed in wxwidgets2.8 (Ubuntu Precise):
status: New → Fix Committed

Hello dauriac, or anyone else affected,

Accepted wxwidgets2.8 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Benjamin Drung (bdrung) wrote :

wxwidgets2.8 2.8.12.1-6ubuntu2.1 fixes this bug, but the changed wxwidgets2.8 causes 100% CPU load when using appmenu. I have uploaded 2.8.12.1-6ubuntu2.2, which should fix the high CPU usage as well.

Clint Byrum (clint-fewbar) wrote :

Hi Benjamin, thanks for the quick fix. Accepted into precise-proposed.

dauriac (dauriac) wrote :

Thank you for the bug corrected. After some package upgrade, a new bug replaced the old one. Now, when launching Audacity outside of Unity, the menu doesn't appear in the first window. It is still available if using keyboard shortcut, or clicking to a very very precise and small area. See attached screenshot. When opening a new window from Audacity, the new window has the menu working with the right size.
Also, opening and then closing the Preference windows seems to re-initialize something that makes the menu appear again.

Audacity also output some dbus-menu related message in stderr :

(Audacity:17083): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(appears 9 times in a row)

Version of the packages are :
- libwxbase2.8-0 : 2.8.12.1-6ubuntu2.2
- libwxgtk2.8-0 : 2.8.12.1-6ubuntu2
- libdbusmenu-gtk4 : 0.6.1-0ubuntu3

Sebastien Bacher (seb128) wrote :

setting verification-failed since the update created issues according to comment #25

tags: added: verification-failed
removed: verification-needed
Benjamin Drung (bdrung) wrote :

Agreed. wxwidgets 2.8.12.1-6ubuntu2.2 should be held back until we have a working solution for all three environments:

1) Unity
2) Unity with UBUNTU_MENUPROXY set to 0
3) not Unity (like GNOME Classic)

Julian Taylor (jtaylor) wrote :

see bug 1029016 for another or same regression of the proposed version

Scott Kitterman (kitterman) wrote :

I'm going to remove the package from proposed.

Scott Kitterman (kitterman) wrote :

Done. Setting back to confirmed and clearing tags.

Changed in wxwidgets2.8 (Ubuntu Precise):
status: Fix Committed → Confirmed
tags: removed: verification-failed
Scott Kitterman (kitterman) wrote :

Someone should check and see if this is really fixed in quantal. Unsubscribing ubuntu-sru for now.

Benjamin Drung (bdrung) on 2012-11-17
Changed in wxwidgets2.8 (Ubuntu):
status: Fix Released → Confirmed
tags: added: patch
In , Gale (gale) wrote :

Changed Status from to "VERIFIED - WONTFIX" to "RESOLVED - FIXED" after Leland applied a patch to Menus.cpp in r12639 that fixes this.

Leland wrote:
> This should be removed with wxWidgets 2.8.13 is released.
Does the Widgets fix http://trac.wxwidgets.org/changeset/67929?format=diff&new=67929 also prevent the black square corruption under Unity (where "Fi" of "File" would be in the Audacity Menu Bar)?

Your patch does so, but the official Widgets patch had that problem when I last tried it, and Ubuntu seem to have problems getting that patch to fix all the scenarios.

Changed in audacity:
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.