[12.04] libwx_gtk2u_media-2.8.so.0: cannot open shared object file

Bug #928894 reported by Manoj Iyer on 2012-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wxwidgets2.8 (Ubuntu)
Medium
Ayan George

Bug Description

12.04 (Feb 8 2012) build is missing wxwidgets2.8 which is causing applications that use libwx_gtk2u_media-2.8.so.0 to report errors such as:

$ dvdstyler
dvdstyler: error while loading shared libraries: libwx_gtk2u_media-2.8.so.0: cannot open shared object file: No such file or directory

Manoj Iyer (manjo) wrote :

Looks like a similar bug was fixed in 11.10 so this is a regression in 12.04,
please refer to 11.10 bug http://launchpad.net/bugs/632984

Changed in wxwidgets2.8 (Ubuntu):
importance: Undecided → High
assignee: nobody → Fabrice Coutadeur (fabricesp)
Ayan George (ayan) on 2012-02-09
Changed in wxwidgets2.8 (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → Ayan George (ayan)
Ayan George (ayan) on 2012-02-09
Changed in wxwidgets2.8 (Ubuntu):
importance: High → Medium
status: New → In Progress
affects: wxwidgets2.8 (Ubuntu) → dvdstyler
affects: dvdstyler → wxwidgets2.8 (Ubuntu)
Ayan George (ayan) on 2012-02-09
no longer affects: dvdstyler
Fabrice Coutadeur (fabricesp) wrote :

Hi,

wxwidgets2.8 is just missing a b-d on libgstreamer-plugins-base0.10-dev and libgconf2-dev to fully enable mediactrl.

@ayan: will you upload that fix? It was assigned to me and began to work on it, and you then assigned it to you, so I'm not sure what to do.

Thanks,
Fabrice

Fabrice Coutadeur (fabricesp) wrote :

(by the way, I was upgrading dvdstyler and was blocked by that same error: this is why I didn't answer to the bug report assigned to me)

Fabrice Coutadeur (fabricesp) wrote :

Hi,

As I want to upload dvdstyler before Feature Freeze and won't have time to do it next week, I will upload a fixed version. Sorry Ayan.

Fabrice

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.12.1-6ubuntu2

---------------
wxwidgets2.8 (2.8.12.1-6ubuntu2) precise; urgency=low

  * debian/control: add b-d on libgstreamer-plugins-base0.10-dev and
    libgconf2-dev to fully enable mediactrl and build libwx_gtk2u_media-2.8
    (LP: #928894)
 -- Fabrice Coutadeur <email address hidden> Sun, 12 Feb 2012 15:51:26 +0100

Changed in wxwidgets2.8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers