Ubuntu

libwx_gtk2u_media-2.8.so.0 missing from libwxgtk2.8-0

Reported by Yassen Bantchev on 2010-09-08
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
wxwidgets2.8 (Debian)
Fix Released
Unknown
wxwidgets2.8 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libwxgtk2.8-0

Ubuntu 10.10 Maverick, 11.04 Natty
libwxgtk2.8-0 2.8.11.0-0ubuntu4
This library should be packaged as well as part of the standard wxwidgets installation as is the case in previous versions of Ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 10.10, 11.04
Package: libwxbase2.8-0 2.8.11.0-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Wed Sep 8 11:32:50 2010
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/usr/bin/fish
SourcePackage: wxwidgets2.8

Yassen Bantchev (yassenb) wrote :

This also keeps the wxruby gem from running.

Marvin Gülker (sutniuq) wrote :

Yeah, that's the reason why I'm affected by this, too. I solved this by compiling wxWidgets myself to /opt/wxwidgets-2.8.11. However, this is only a temporary solution as I don't like installing software that is already provided by the package system.

Debian removed --enable-mediactl in 2.8.10.1-1, to close Debian bug #493090 (libwxgtk2.8-0: unwanted dependency on libgconf) and remove wx's dependency on gconf. Fair enough, but they really should have provided a wxmedia package instead of just removing it. :-(

Maxim Sokolovskij (a-x-e-1) wrote :

I'm writining GUI apps on Ruby with wxRuby as GUI lib. Now all that work great on Lucid doesn't even start with this error:

<internal:lib/rubygems/custom_require>:29:in `require': libwx_gtk2u_media-2.8.so.0: cannot open shared object file: No such file or directory - /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wxruby2.so (LoadError)
 from <internal:lib/rubygems/custom_require>:29:in `require'
 from /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wx.rb:12:in `<top (required)>'
 from <internal:lib/rubygems/custom_require>:33:in `require'
 from <internal:lib/rubygems/custom_require>:33:in `rescue in require'
 from <internal:lib/rubygems/custom_require>:29:in `require'
 from simplegui.rbw:3:in `<main>'

So, all who use this lib are affected.

Rob Echlin (rob-echlin) wrote :

This bug affects me as well. Ubuntu 10.10 (Well, xfce)

Man this really gets on my nerves... And I'm only just trying to getting wxruby up and running so I can start learning it.

agent 8131 (agent-8131) on 2011-03-02
Changed in wxwidgets2.8 (Ubuntu):
status: New → Confirmed
Changed in wxwidgets2.8 (Debian):
status: Unknown → New
Maxim Sokolovskij (a-x-e-1) wrote :

Also affects Ubuntu 11.04 Natty Narwhal:

naturel@naturel-desktop:~$ ruby1.9.1 -e "require 'wx'"
<internal:lib/rubygems/custom_require>:29:in `require': libwx_gtk2u_media-2.8.so.0: cannot open shared object file: No such file or directory - /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wxruby2.so (LoadError)
 from <internal:lib/rubygems/custom_require>:29:in `require'
 from /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wx.rb:12:in `<top (required)>'
 from <internal:lib/rubygems/custom_require>:33:in `require'
 from <internal:lib/rubygems/custom_require>:33:in `rescue in require'
 from <internal:lib/rubygems/custom_require>:29:in `require'
 from -e:1:in `<main>'

tags: added: natty
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.11.0-0ubuntu9

---------------
wxwidgets2.8 (2.8.11.0-0ubuntu9) oneiric; urgency=low

  * debian/rules: reenable mediactrl. This allows libwx_gtk2u_media-2.8 to be
    built, as this is required by some applications (LP: #632984)
 -- Fabrice Coutadeur <email address hidden> Thu, 05 May 2011 04:28:06 +0000

Changed in wxwidgets2.8 (Ubuntu):
status: Confirmed → Fix Released
Maxim Sokolovskij (a-x-e-1) wrote :

Will it be published in natty backports?

agent 8131 (agent-8131) wrote :

It should actually be a stable release update for 10.10 and 10.04:

"Bugs which represent severe regressions from the previous release of Ubuntu. This includes packages which are totally unusable, like being uninstallable or crashing on startup."

https://wiki.ubuntu.com/StableReleaseUpdates#When

Fabrice Coutadeur (fabricesp) wrote :

Hi,

I'm not sure this will be accepted as a SRU, as there is only one functionality that is missing n the package and all the remaining package works fine.

Anyway, as I was requiring it for a package I maintain, I backported it in a PPA. You can find the fixed packages there: https://launchpad.net/~dvdstyler-maintainers/+archive/ppa/+packages

Fabrice

Marvin Gülker (sutniuq) wrote :

Glad that this is fixed, but wxRuby now complains like this (I'm running Natty with Fabrice's PPA updates applied):

$ ruby1.9.1 /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/samples/bigdemo/bigdemo.rb
<internal:lib/rubygems/custom_require>:29:in `require': /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wxruby2.so: symbol wxDefaultVideoMode, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference - /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wxruby2.so (LoadError)
 from <internal:lib/rubygems/custom_require>:29:in `require'
 from /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/lib/wx.rb:12:in `<top (required)>'
 from <internal:lib/rubygems/custom_require>:33:in `require'
 from <internal:lib/rubygems/custom_require>:33:in `rescue in require'
 from <internal:lib/rubygems/custom_require>:29:in `require'
 from /var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86-linux/samples/bigdemo/bigdemo.rb:8:in `<main>'

Shall I file another bug for this one?

Marvin

Fabrice Coutadeur (fabricesp) wrote :

@Marvin Gülker: it seems that your problem has already been detected and a workaround has been found. Please see https://bugs.launchpad.net/ubuntu/+source/libwx-perl/+bug/754513

Marvin Gülker (sutniuq) wrote :

Sadly, I'm not a Perl programmer, so the comments about CPAN don't help me much. It seems, that installing wxPerl via CPAN means compiling it, and compiling wxRuby is quite an adventure (I've done it some times [takes nearly eternity...], but at the moment it just refuses to build--however, this is something the wxRuby devs have to solve).

Incredible, I just wanted to verify bug #756237 for Ubuntu Natty, but each time I think I'm a step nearer to it, something else prevents me from doing it. Lol, I can't get an application to start that I want to crash later on. :p

Marvin

John Franklin (john-quinze) wrote :

This bug is marked as 'fix released'. What do I have to do to correct it? Uninstall the package and reinstall? Or is there an easier way?

Stefano Rivera (stefanor) wrote :

John: it's released in oneiric. If you want this fix for natty or maverick, look at the PPA Fabrice mentioned.

Changed in wxwidgets2.8 (Debian):
status: New → Fix Committed
Changed in wxwidgets2.8 (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.