python2.6 assert failure: python: ../../src/xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.

Bug #563207 reported by Karel Kozlik on 2010-04-14
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Exaile
Invalid
Undecided
Unassigned
wxwidgets2.8 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: python2.6

I have been testing something with wxpython and opencv. Attaching my simple program that caused the crash of python.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: python2.6-minimal 2.6.5-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
AssertionMessage: python: ../../src/xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.
Date: Wed Apr 14 18:37:21 2010
ExecutablePath: /usr/bin/python2.6
ProcCmdline: python tracker.py dd
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=cs_CZ.UTF-8
 LANGUAGE=
Signal: 6
SourcePackage: python2.6
StacktraceTop:
 *__GI_raise (sig=<value optimized out>)
 *__GI_abort () at abort.c:92
 *__GI___assert_fail (
 ?? () from /usr/lib/libX11.so.6
 _XEventsQueued () from /usr/lib/libX11.so.6
Title: python2.6 assert failure: python: ../../src/xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.
UserGroups: adm admin cdrom davfs2 dialout lp lpadmin plugdev sambashare vboxusers

Karel Kozlik (karel.kozlik) wrote :

StacktraceTop:
 *__GI_raise (sig=<value optimized out>)
 *__GI_abort () at abort.c:92
 *__GI___assert_fail (
 process_responses (dpy=0x1799470,
 _XEventsQueued (dpy=0x1799470,

Changed in python2.6 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Matthias Klose (doko) on 2010-04-14
affects: python2.6 (Ubuntu) → wxwidgets2.8 (Ubuntu)
visibility: private → public
Eugene Savelov (savelov) wrote :

the same assertion failures happen in other applications, such as pidgin (bug #604150), firefox/openjdk (bug #590497), f-spot (bug #564949)

Dave Gilbert (ubuntu-treblig) wrote :

Yeh, I've just triggered this on Synergy (server)

synergys: ../../src/xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.

Having said that, there is a patch in the Ubuntu synergy package that is supposed to stop this assert (from bug
https://bugs.launchpad.net/ubuntu/+source/synergy/+bug/299152 ) - but it's just triggered on 1.3.1-6ubuntu1.

It suggests something else is going on.

Dave

Michael (mkanz) wrote :

I got this failure which crashed exaile-0.3.2.0 from exaile-devel PPA on Lucid. The error message was exactly the same as in opening post, so that is how I got here.

Dave Gilbert (ubuntu-treblig) wrote :

Still happening on current natty synergys - very rare but just tripped.

Dave

reacocard (reacocard) wrote :

Not sure why this is double-filed against Exaile, seeing as Exaile hasn't used wxwidgets in years.

Changed in exaile:
status: New → Invalid
Dave Gilbert (ubuntu-treblig) wrote :

Aren:
  What makes you think this is saying that it's due to Exaile using wxwidgets?
I think it's just saying that someone has triggered it in exaile and someone has triggered it in a wxwidgets app
(and in my case synergy which is neither).

Dave

reacocard (reacocard) wrote :

Sorry that was a poor assumption, but the bug and comments all seem to be about WXwidgets, and contain nothing specific to exaile at all. Without any information from the user about HOW they are triggering this bug in Exaile, much less what exaile version and distro, the report is useless anyways, hence I marked it invalid. If the user who reported it against Exaile wishes to reopen it, they should do so and include information about their setup and how they are causing the bug, since otherwise there is no chance of being able to fix it.

billjoie (joie-bill) wrote :

I also get this error message on Exaile 0.3.2.0, on two different Ubuntu 10.10 machines, done all my updates. Find the terminal output bellow. I get this bug just playing music (most often Flacs?). I cannot quite find a pattern, sometimes Exaile plays fine, other times it will quickly crash after playing a tune. Any additional info needed? Hope this helps

bill@billjoie:~$ exaile
INFO : Loading Exaile 0.3.2.0...
INFO : Loading settings...
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO : Loading plugins...
INFO : Loading collection...
INFO : Loading devices...
INFO : Loading interface...
INFO : Loading main window...
INFO : Connecting main window events...
INFO : Loading panels...
INFO : Connecting panel events...
INFO : Done loading main window...
INFO : Playing file:///home/bill/mamusique/Leonard%20Cohen/2004_Dear_Heather/07%20-%20leonard%20cohen%20-%20villanelle%20for%20our%20time.mp3
INFO : WARNING: could not open podcast file
Exception in thread Thread-12:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/threading.py", line 484, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/share/exaile/plugins/notifyosd/__init__.py", line 108, in update_track_notify
    self.notify.set_icon_from_pixbuf(pixbuf)
TypeError: Notify.Notification.set_icon_from_pixbuf() argument 1 must be gtk.gdk.Pixbuf, not None

INFO : Playing file:///home/bill/mamusique/Dan%20Bigras/Les%20Immortelles/2%20-%20Les%20Mensonges%20d'un%20p%C3%A8re%20%C3%A0%20son%20fils.flac
/usr/lib/python2.6/urllib.py:1224: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  res = map(safe_map.__getitem__, s)
Exception in thread Thread-16:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/threading.py", line 484, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/share/exaile/plugins/lyricsviewer/__init__.py", line 230, in get_lyrics
    lyrics_found = self.exaile.lyrics.find_all_lyrics(track)
  File "/usr/lib/exaile/xl/lyrics.py", line 206, in find_all_lyrics
    (lyrics, source, url) = method.find_lyrics(track)
  File "/usr/share/exaile/plugins/lyricwiki/__init__.py", line 50, in find_lyrics
    title = urllib.quote(title.replace(' ','_'))
  File "/usr/lib/python2.6/urllib.py", line 1224, in quote
    res = map(safe_map.__getitem__, s)
KeyError: u'\xe8'

/usr/lib/exaile/xlgui/guiutil.py:343: GtkWarning: gdk_pixbuf_copy_area: assertion `src_y >= 0 && src_y + height <= src_pixbuf->height' failed
  5, 5
/usr/lib/exaile/xlgui/guiutil.py:353: GtkWarning: gdk_pixbuf_copy_area: assertion `src_y >= 0 && src_y + height <= src_pixbuf->height' failed
  10, 10
python: ../../src/xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.

Changed in exaile:
status: Invalid → New
mp (m-p) wrote :

I get this every time I add files from file browser:

$ exaile
INFO : Loading Exaile 0.3.2.0...
INFO : Loading settings...
INFO : Loading plugins...
INFO : Loading collection...
INFO : Loading devices...
INFO : Loading interface...
INFO : Loading main window...
INFO : Connecting main window events...
INFO : Loading panels...
INFO : Connecting panel events...
INFO : Done loading main window...
python: ../../src/xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.

Dave Gilbert (ubuntu-treblig) wrote :

Hi mp,
  It's interesting if you can repeat this on demand; I don't think any one else has managed to do that - I just get it occasionally.
Can you:

  1) Confirm the version of Ubuntu you're using
  2) Provide the version of the libX11-6 package (from dpkg -l libx11-6)
  3) Some basic details of your machine (e.g. processor/number of cores)
  4) Since you can repeat it, can you try running exaile under ltrace and do the thing that causes it to die, and attach the log.
Something like:

    ltrace -f `which exaile` -o exaile.log

  and then attach that exaile.log

Dave

reacocard (reacocard) on 2011-07-19
Changed in exaile:
status: New → Incomplete
Jeremie L (jeremie-leclere) wrote :

Hi,

I've just came to this page while searching for this assert failure case, which is 100% reproducible in my case :

python2.6 ../../src/xcb_io.c:249: process_responses: L'assertion "(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)" a échoué.

It's the first time I enter a comment in such a bug tracking system, so I'll give information ~corresponding to Dave Gilbert's questions above:

1. Ubuntu 10.04 LTS
2. libxll-6: 2:1.3.2-1ubuntu3
3. Intel(R) Core(TM) i5 / 4 cores

Actually, I'm not reproducing it with Exaile, but with a simple python application I'm developping, based on wxPython (2.8.10.1) & pyaudio (http://people.csail.mit.edu/hubert/pyaudio/).

My application doesn't crash at anytime in Windows environment, but systematically crashes on Ubuntu. I was wondering if it was a PyAudio problem or a wxPython problem ... Guess I got the answer now.

Please feel free to ask for more details if necessary !

Jérémie

Jeremie L (jeremie-leclere) wrote :

Just tried to run this application with ltrace, and didn't managed to get it crashed. Only got a nice 230Mo log.

Changed in wxwidgets2.8 (Ubuntu):
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Hi Jeremie,
  I get a similar but different error if I run that app in my environment:

python: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
python: ../../src/xcb_io.c:140: dequeue_pending_request: Assertion `req == dpy->xcb->pending_requests' failed.
Aborted (core dumped)

For those trying to reproduce it, I took Jermeie's program and had to

apt-get install python-wxgtk2.8 python-matplotlib python-pyaudio

I run it, ok the error about the missing icon, and hit the start button, I get the following output:

ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
python: ../../src/xcb_io.c:140: dequeue_pending_request: Assertion `req == dpy->xcb->pending_requests' failed.
Aborted (core dumped)

I got the interesting error (the one at the end) 3 times out of 4 tries.

This is on Oneiric on an i7-860 running KDE desktop. It's possible it's the same problem given it's a similar error - and the fact his test is so reproducable seems a good start.

Dave

Dave

This is probably not related to exaile, or if it is then it's old enough where we don't support it. File a new bug if you produce it on a current version of python + exaile.

Changed in exaile:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers