Ubuntu

editra is provided by both the editra package and python-wxtools and conflicts

Reported by Peter Magnusson on 2010-04-10
96
This bug affects 17 people
Affects Status Importance Assigned to Milestone
editra (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned
wxwidgets2.8 (Ubuntu)
Medium
Devid Antonio Filoni
Lucid
Undecided
Unassigned

Bug Description

package python-wxtools (not installed) failed to install/upgrade: trying to overwrite '/usr/bin/editra', which is also in package editra 0:0.5.30-1

I installed Editra from the editra package and then also wanted PyShell which is provided by python-wxtools. If I remove the standalone editra package and instead try the editra version installed by python-wxtools doesn't work because of some import errors ( described in for example https://bugs.launchpad.net/ubuntu/+source/wxwidgets2.8/+bug/470378 ).

I think removing editra from wxtools package would be a good thing since editra and perhaps other parts of the wxtools package have their own release schedules. That would also allow better granularity in what you have installed.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: python-wxtools (not installed)
ProcVersionSignature: Ubuntu 2.6.32-19.29-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: wl
AptOrdering:
 python-wxtools: Install
 python-wxtools: Configure
Architecture: i386
Date: Sat Apr 10 08:08:26 2010
ErrorMessage: trying to overwrite '/usr/bin/editra', which is also in package editra 0:0.5.30-1
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
SourcePackage: wxwidgets2.8
Title: package python-wxtools (not installed) failed to install/upgrade: trying to overwrite '/usr/bin/editra', which is also in package editra 0:0.5.30-1

Peter Magnusson (kmpm) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.
Confirmed in lucid.

Changed in wxwidgets2.8 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in editra (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Amol Karmarkar (amol-karmarkar) wrote :

I am seeing the same issue.

Changed in wxwidgets2.8 (Ubuntu):
assignee: nobody → Devid Antonio Filoni (d.filoni)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.11.0-0ubuntu2

---------------
wxwidgets2.8 (2.8.11.0-0ubuntu2) maverick; urgency=low

  * Merge *some* changes from Debian package (version 2.8.10.1-3). This should
    make merges easier. Also fixes LP: #559822. Also merged several patches.
  * Remove debian/patches/editra_pixmaps.dpatch patch, we don't ship editra
    anymore.
  * Remove files which broke update-alternatives (LP: #379573).
  * Switch to format 3.0 (quilt).
 -- Devid Antonio Filoni <email address hidden> Tue, 20 Jul 2010 01:55:41 +0200

Changed in wxwidgets2.8 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package editra - 0.5.30-1ubuntu1

---------------
editra (0.5.30-1ubuntu1) maverick; urgency=low

  * debian/control: add python-wxtools (<< 2.8.11.0-0ubuntu2) to Conflicts
    field (LP: #559822, #513546).
 -- Devid Antonio Filoni <email address hidden> Tue, 20 Jul 2010 06:47:22 +0200

Changed in editra (Ubuntu):
status: Triaged → Fix Released
Changed in wxwidgets2.8 (Ubuntu Lucid):
assignee: nobody → Devid Antonio Filoni (d.filoni)
status: New → In Progress
Changed in editra (Ubuntu Lucid):
assignee: nobody → Devid Antonio Filoni (d.filoni)
status: New → In Progress
Devid Antonio Filoni (d.filoni) wrote :

ubuntu-sru ACK for wxwidgets2.8 and editra uploaded packages.

Changed in editra (Ubuntu Lucid):
assignee: Devid Antonio Filoni (d.filoni) → nobody
status: In Progress → Confirmed
Changed in wxwidgets2.8 (Ubuntu Lucid):
assignee: Devid Antonio Filoni (d.filoni) → nobody
status: In Progress → Confirmed

Accepted editra into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in editra (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in wxwidgets2.8 (Ubuntu Lucid):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted wxwidgets2.8 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

corrie (corrie-engelbrecht) wrote :

+15 hrs now, and still no editra nor python-wxtools in lucid-proposed?

corrie (corrie-engelbrecht) wrote :

The current packages in proposed also do not work:

1. Installing editra first:
package lucid-proposed/universe editra 0.5.30-1ubuntu0.1 installs with no issues

But then:
Unpacking python-wxtools (from .../python-wxtools_2.8.10.1-0ubuntu1.1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python-wxtools_2.8.10.1-0ubuntu1.1_all.deb (--unpack):
 trying to overwrite '/usr/bin/editra', which is also in package editra 0:0.5.30-1ubuntu0.1
Errors were encountered while processing:
 /var/cache/apt/archives/python-wxtools_2.8.10.1-0ubuntu1.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

2. Installing python-wxtools first, and then editra, also fails, for the same reason.

I confirm that version of python-wxtools in lucid-proposed doesn't fix this issue despite what is mentioned in the changelog (the fix is ok in maverick)

# dpkg -S $(which editra); LANG=C apt-cache policy python-wxtools
python-wxtools: /usr/bin/editra
python-wxtools:
  Installed: 2.8.10.1-0ubuntu1.1
  Candidate: 2.8.10.1-0ubuntu1.1
  Version table:
 *** 2.8.10.1-0ubuntu1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ lucid-proposed/universe Packages
        100 /var/lib/dpkg/status
     2.8.10.1-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ lucid/universe Packages

Marking as verification-failed.

Changed in wxwidgets2.8 (Ubuntu Lucid):
status: Fix Committed → Confirmed
tags: added: verification-failed
removed: verification-needed
Thierry Carrez (ttx) wrote :

Apparently the wxwidgets2.8 package in -proposed breaks pgadmin3, until a no-op rebuild is done on it. See bug 610975.

New packages uploaded to lucid-proposed. ubuntu-sru ACK.

@Thierry: we can rebuild it later, after packages acceptance.

Jonathan Riddell (jr) wrote :

Accepted editra into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Jonathan Riddell (jr) wrote :

Accepted wxwidgets2.8 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in wxwidgets2.8 (Ubuntu Lucid):
status: Confirmed → Fix Committed
Jonathan Riddell (jr) wrote :

unsubscribing ubuntu-archive

SRU verification for Lucid:
I have reproduced the problem with python-wxtools 2.8.10.1-0ubuntu1 in lucid and have verified that the version of python-wxtools 2.8.10.1-0ubuntu1.2 in -proposed fixes the issue. I have verified that the conflict between the packages is handled correctly.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
corrie (corrie-engelbrecht) wrote :

lucid-proposed/universe python-wxtools 2.8.10.1-0ubuntu1.2 works fine with lucid/universe editra 0.5.30-1

The two packages do not conflict, so the proposed python-wxtools package does work.

I only tested a few of the tools installed, and they all worked.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.10.1-0ubuntu1.2

---------------
wxwidgets2.8 (2.8.10.1-0ubuntu1.2) lucid-proposed; urgency=low

  * python-wxtools: do not ship /usr/bin/editra too (LP: #559822).
 -- Devid Antonio Filoni <email address hidden> Fri, 06 Aug 2010 17:36:33 +0200

Changed in wxwidgets2.8 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package editra - 0.5.30-1ubuntu0.2

---------------
editra (0.5.30-1ubuntu0.2) lucid-proposed; urgency=low

  * debian/control: set python-wxtools version to << 2.8.10.1-0ubuntu1.2 in
    Conflicts field (LP: #559822).
 -- Devid Antonio Filoni <email address hidden> Fri, 06 Aug 2010 20:21:11 +0200

Changed in editra (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers