Ubuntu

python-wxgtk2.8 missing wx.media in ubuntu 13.10

Reported by jmxhyz on 2013-09-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
wxwidgets2.8 (Debian)
New
Unknown
wxwidgets2.8 (Ubuntu)
High
Fabrice Coutadeur
Saucy
Undecided
Fabrice Coutadeur

Bug Description

Upgrade to ubuntu 13.10 (saucy).
Also, python-wxgtk2.8 from "2.8.12.1-11ubuntu4" upgraded to "2.8.12.1-14ubuntu1".
But missing this fle: /usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_media.so.
It is wrong when import wx.media.

[Impact]
This is a regression and even if 70 packages depends on python-wxgtk2.8 (according to apt-cache), I don't know which ones are impacted (maybe none in the repository). If any of the affected can add that info, that would bring more value to the update.

[Test Case]
1- launch the python interpreter with the following command: python
2- try to import wx.media with the following command: import wx.media
3- this bring the following error: "ImportError: no module named media"
The import does not fails with the 1.1 package

[Regression Potential]
Comparing the resulting package with original one only gives 3 differences:
- python files for wx.media lib
- real changelog instead of a link to libwxbase2.8-0's one. This may be an optimization of the builders that I don't have locally
- an additional dependency on libwxgtk-media2.8 for python-wxgtk2.8
Also, we are just adding something back that was there before the merge, thus the regression risks seem pretty low

William Grant (wgrant) on 2013-09-13
affects: launchpad → wxwidgets2.8 (Ubuntu)
Changed in wxwidgets2.8 (Debian):
status: Unknown → New
John D (johndcarmack) wrote :

I upgraded yesterday and was hit with this this morning. Why was it removed, and, more importantly, what is the solution? This is not my program, and I don't know Python.

Dmitry Shachnev (mitya57) wrote :

Hi Fabrice, can you please comment on this bug?

Changed in wxwidgets2.8 (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
Fabrice Coutadeur (fabricesp) wrote :

Hi,

This was intentional, but to be honest with you, I should have created a "python-wxgtk-media2.8" package for the dependency on media instead of dropping it completly.

For Ubuntu, it should be enough to disable the patch disable_media_python.patch and rebuild the package to have a working python package.
I'll check later today if it works and if it's ok, upload a -proposed package.

Fabrice

Changed in wxwidgets2.8 (Ubuntu):
status: New → In Progress
Fabrice Coutadeur (fabricesp) wrote :

uploaded to -proposed. Awaiting approval.

Changed in wxwidgets2.8 (Ubuntu):
importance: Undecided → High
Changed in wxwidgets2.8 (Ubuntu Saucy):
status: New → In Progress
assignee: nobody → Fabrice Coutadeur (fabricesp)
John D (johndcarmack) wrote :

There was an update to Python available today in Ubuntu 13.10, but it appears to me this issue is still the same.

John D (johndcarmack) wrote :

Sorry, I see now there are Fixed Committed and Fixed Released statuses that come after In Progress. I'm still getting to know this site.

description: updated
Changed in wxwidgets2.8 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.12.1-14ubuntu2

---------------
wxwidgets2.8 (2.8.12.1-14ubuntu2) trusty; urgency=low

  * disable disable_media_python.patch to add wx.media to python-wxgtk2.8
    (LP: #1224528)
 -- Fabrice Coutadeur <email address hidden> Fri, 18 Oct 2013 20:29:34 +0200

Changed in wxwidgets2.8 (Ubuntu):
status: Fix Committed → Fix Released
John D (johndcarmack) wrote :

So, does that mean it is now in proposed for Saucy, or only for the next version?

Dmitry Shachnev (mitya57) wrote :

John, it's fixed in Trusty, and the fix for Saucy is waiting approval at https://launchpad.net/ubuntu/saucy/+queue?queue_state=1.

oh (oystein-homelien) wrote :

This bug broke a number of wx apps for me, specifically those using the AGW library and persistence, which I assume are not few apps. So it's quite a showstopper and I've had to defer upgrading many machines.

Dmitry/anyone,

1. Is there an easy, clean way to temporarily work around the bug (I see packages have been uploaded but are not approved?) - How do I use these?

2. Is there a way to accelerate the approval process for the bugfix packages?

Oh: you can try to install .debs from Trusty, and ping #ubuntu-release on
Freenode to ask them if they can approve it quicker.

Fabrice Coutadeur (fabricesp) wrote :

You can also install it from there: https://launchpad.net/~fabricesp/+archive/testbuild, even if the version number is not the good one.
This way, you can install the fixed package before his availability.

Hello jmxhyz, or anyone else affected,

Accepted wxwidgets2.8 into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/wxwidgets2.8/2.8.12.1-14ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wxwidgets2.8 (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
RickJ (rick-activeservice) wrote :

Just installed version 2.8.12.1-14ubuntu1.1 from the -proposed repository and it works fine.

The bug was preventing EasyABC from working, but it's all OK now.

Thanks.

John D (johndcarmack) wrote :

Yes, that is much better now in Saucy. I upgraded using -proposed because I could not figure out how to get it from the testbuild area.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.12.1-14ubuntu1.1

---------------
wxwidgets2.8 (2.8.12.1-14ubuntu1.1) saucy-proposed; urgency=low

  * disable disable_media_python.patch to add wx.media to python-wxgtk2.8
    (LP: #1224528)
 -- Fabrice Coutadeur <email address hidden> Fri, 18 Oct 2013 20:29:34 +0200

Changed in wxwidgets2.8 (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.