Merge wxwidgets2.6 2.6.3.2.2-2 from Debian(Unstable)

Bug #193658 reported by Stefan Ebner
4
Affects Status Importance Assigned to Milestone
wxwidgets2.6 (Ubuntu)
Undecided
Emilio Pozuelo Monfort

Bug Description

Debian changelog's entries since latest Ubuntu one:

 wxwidgets2.6 (2.6.3.2.2-2) unstable; urgency=low

   [ Ron Lee ]
   * Fix a prang removing notebook pages. Closes: #445729.
   * 'Fix' bashisms in debian/rules. Closes: #459160.

   [ Matthias Klose ]
   * Merge the following changes from Ubuntu:
     - Fix build failure with python2.5. Closes: #439002.
     - Build for all supported python versions.
     - Build a python-wxgtk2.6-dbg package.
     - Move the wx.pth symlink handled by update-alternatives into
       the python-wxversion package; adjust dependencies accordingly.
     - Build using debhelper v5.
     - Fix build failures with g++-4.2.
     - Install wxPython header files in wx2.6-headers. Closes: #326440.
     - Remove extra '-' in the index.html symlink destination in rules.
       Closes: #374337, #402472, #422306, #436737.
     - debian/rules (clean): Be cleaner. Closes: #374176.
     - src/gtk/settings.cpp: Patch from upstream SVN (r48002) to stop using
       private Gtk API which results in segfaults since Gtk 2.11.6.
       https://sourceforge.net/tracker/?func=detail&atid=109863&aid=1767485&group_id=9863
     - Fix for GTK warnings in wxNotebook::DoRemovePage.
     - wxPython/config.py: Use the default python cflags.
   * Fix build failure on the Hurd. Closes: #458289.
   * Make wxGetKeyState() work for non-meta keys too. Closes: #410491.

 -- Matthias Klose <email address hidden> Sun, 10 Feb 2008 20:14:20 +0100

Remaining changes to be merged:

    - Add build-dep on bc.
    - Bump debhelper compatibility to v5.
    - Remove debian/python-version, use pyversions -d.
    - Set DEBIAN_WX_DEFAULT_VERSION to 2.8 in rules.
    - Build the existing -dbg package for the python-dbg build (unlist
      $(package_gtk_dbg_py) from extra_packages in rules.
    - Don't let the -dbg package conflict with the normal build, but depend on
      it.
    - Remove python-wxgtk-dbg installation scripts.
    - Remove dh_python calls in rules.
    - Install wxPython header files in wx2.6-headers; Ubuntu #2887.
    - Remove extra '-' in the index.html symlink destination in rules;
      Ubuntu #110335.
    - Use const char * instead of char * in wxPython/contrib/stc/gtk/*.cpp to
      fix some warnings.
    - Move "from __future__ import nested_scopes" to the begin of
      wxPython/wx/py/introspect.py.
    - Use the default python flags for the wxPython builds in config.py.
    - Fix build of src/gtk/settings.cpp.
  * Build for all supported python versions.
  * Move the wx.pth symlink handled by update-alternatives into
    the python-wxversion package; adjust dependencies accordingly.
  * Fix build failure with python2.4.

Stefan Ebner (sebner)
Changed in wxwidgets2.6:
assignee: nobody → hellboy195
Stefan Ebner (sebner)
Changed in wxwidgets2.6:
status: New → In Progress
Revision history for this message
Stefan Ebner (sebner) wrote :
Changed in wxwidgets2.6:
assignee: hellboy195 → nobody
status: In Progress → Confirmed
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Unsubscribing u-u-s. I'm reviewing it

Changed in wxwidgets2.6:
assignee: nobody → pochu
status: Confirmed → In Progress
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

The debdiff looks fine except that you forgot to list two changes in debian/changelog (the updated dependencies and conflicts due to the python-wxversion changes, and the notebook.cpp fix which should have been fixed in Debian but it wasn't for some reason, although it's listed as fixed in the changelog).

I'm going to build and test it and I'll upload if everything works fine.

Thanks for the work!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.6 - 2.6.3.2.2-2ubuntu1

---------------
wxwidgets2.6 (2.6.3.2.2-2ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. (LP: #193658) Remaining Ubuntu changes:
    - Add build-dep on bc and ajust debian/control.
    - Set DEBIAN_WX_DEFAULT_VERSION to 2.8 in rules.
    - Set Ubuntu maintainer address.
    - Adjust dependencies and conflicts for the python-wxversion changes,
      which were applied in Ubuntu in 2.8.6.1-0ubuntu2.
    - src/gtk/notebook.cpp:
      + Keep patching it. It should have been fixed in Debian but the patch
        from Debian #445729 wasn't really applied. (LP #59138)

 -- Stefan Ebner <email address hidden> Tue, 12 Feb 2008 10:35:43 +0100

Changed in wxwidgets2.6:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers