Port to wxwidgets 3.0 or remove from archive?

Bug #1544170 reported by Bryan Quigley on 2016-02-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wxbanker (Ubuntu)
High
Michael Rooney

Bug Description

Debian is removing wxwidgets 2.8 [1] from their archive. Odds are Ubuntu will follow suite which might cause this package to be removed.

Please port this to wxwidgets 3.0.

[1] https://wiki.debian.org/Teams/WxWidgets/Transition2.8to3.0

Michael Rooney (mrooney) wrote :

Thanks Bryan! It should work fine on wxwidgets 3 from the latest github source, I just haven't attempted to package and submit an update because dealing with the packaging and the update requests has always been a nightmare; I only do it once a year or so and have to re-learn a slightly different process each time.

Are you familiar with the process for updating packages in the archives? If so, and you don't mind helping, I'd love to work with you on this! Basically, I'd some testing of https://github.com/mrooney/wxbanker on the latest Ubuntu, make sure it works happily with the wxwidgets 3 package there, and figure out how to get the latest source as a package there.

Changed in wxbanker (Ubuntu):
status: New → Confirmed
assignee: nobody → Michael Rooney (mrooney)
Bryan Quigley (bryanquigley) wrote :

HI Michael,

I'm no expert on that myself (never submitted a new version to LP). First would be making a new release for 0.9.2 to have the changes I guess? If there haven't been many changes (and wxw3 should work in 0.9.1) I can easily make a debdiff to just change it to use wxw3.

Which method makes sense pursuing?

Martin Pitt (pitti) wrote :

Note that this is the only package that still holds wx2.8 in Xenial (which in turn blocks the gstreamer 0.10 removal). So having a new upstream release which is compatible to 3.0 soon would be highly appreciated, as otherwise this is a likely removal candidate. I'm happy to help with the packaging.

Martin Pitt (pitti) wrote :

wxbanker currently crashes merely if you have python-wxgtk3.0 installed (alongside 2.8):

Traceback (most recent call last):
  File "/usr/bin/wxbanker", line 2, in <module>
    from wxbanker.main import main
  File "/usr/lib/python2.7/dist-packages/wxbanker/main.py", line 40, in <module>
    from wx.lib.pubsub import Publisher
ImportError: cannot import name Publisher

As everything else in the archive uses wx 3.0 now, I moved wxbanker to -proposed and removed wxwidgets 2.8. As soon as it gets moved over to 3.0 it will migrate to -release again.

Changed in wxbanker (Ubuntu):
importance: Undecided → High
Michael Rooney (mrooney) on 2016-03-16
Changed in wxbanker (Ubuntu):
status: Confirmed → In Progress
Michael Rooney (mrooney) wrote :

Got it, thanks for your help! The latest release works happily in the latest Xenial for me, and I just release it as https://github.com/mrooney/wxbanker/releases/tag/v1.0.0.

In case it is useful, these are the updated Depends and Suggests:
Depends: python (>= 2.7.1-0ubuntu2), python (<< 2.8), python-wxgtk3.0, python-dateutil, python-numpy, python-simplejson, python-xdg, python-beautifulsoup, python-pyquery, python-keyring, python-requests, python-xmltodict, python-cairo
Suggests: wx3.0-i18n

Martin, let me know if you need anything else! Thanks again for your help in getting this package updated :)

Martin Pitt (pitti) wrote :

Packaged for xenial and uploaded. Thanks Michael!

Changed in wxbanker (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxbanker - 1.0.0-0ubuntu1

---------------
wxbanker (1.0.0-0ubuntu1) xenial; urgency=medium

  * New upstream release which now works with wx 3.0. (LP: #1544170)
  * Adjust dependencies for wx 3.0.
  * Bump Standards-Version to 3.9.7.

 -- Martin Pitt <email address hidden> Wed, 16 Mar 2016 23:23:52 +0100

Changed in wxbanker (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers