[MIR] wsmancli

Bug #1262290 reported by Kent Baxley
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Dell-poweredge project
Undecided
Unassigned
wsmancli (Ubuntu)
Undecided
Unassigned

Bug Description

Please consider adding wsmancli to the main repository for Ubuntu Server.

Availability - Latest upstream stable release was added to Universe for Trusty Tahr. Dell had previously been building unofficial ports of this package for Ubuntu for their server user base.

Rationale - wsmancli provides a command-line interface for either interacting with a server running openwsman, and it can also be used for out-of-band administration of Dell PowerEdge 11G and 12G servers via the systems' integrated Dell Remote Access Controller (iDRAC ). Many of our users run Ubuntu on PowerEdge hardware.

Lots of details here:

http://en.community.dell.com/techcenter/b/techcenter/archive/2010/07/19/wsman-for-remote-management-of-dell-poweredge-11g-servers.aspx

wsmancli also works with Intel's AMT technology:
http://software.intel.com/en-us/articles/ws-management-and-intel-active-management-technology-a-primer

An additional use case for wsmancli is remote Windows management via WinRM. See http://msdn.microsoft.com/en-us/library/aa384426(v=vs.85).aspx for details.

Security - There currently are no open vulnerability reports on the package

QA - The project is maintained upstream on sourceforge, with the latest release being 2.3.6, released in November 2012:

http://sourceforge.net/projects/openwsman/files/wsmancli/

There is an active development forum: http://sourceforge.net/mailarchive/forum.php?forum_name=openwsman-devel

No exotic hardware is involved to use this software. The Dell DRAC devices are supported in Ubuntu and are IPMI 2.0 compliant. Intel AMT technology has been out for a while now and will work under linux with the right tools (wmancli and amttool).

The following additional packages need to be pulled into main as well, since wsmancli depends on them:

libopenwsman1

I will file a separate request for libopenwsman1

Related branches

Revision history for this message
Kent Baxley (kentb) wrote :
description: updated
Revision history for this message
Michael Terry (mterry) wrote :

Can someone look into enabling the tests? Looks like you'll have to pass --with-tests, add libcunit1-dev to the Build-Deps, and manually run tests/cunit/wsman_cunit_tests. But even then, I'm seeing some errors.

Changed in wsmancli (Ubuntu):
status: New → Incomplete
Revision history for this message
Klaus Kämpf (kkaempf-suse) wrote :

The tests can not be run standalone. You need openwsmand (openwsman deamon) and a CIMOM (sblim-sfcb or tog-pegasus) with base instrumentation (sblim-cmpi-base) running.

Revision history for this message
Klaus Kämpf (kkaempf-suse) wrote :

There's an additional use-case for wsmancli which should be added to the initial description: Remote Windows management via WinRM. See http://msdn.microsoft.com/en-us/library/aa384426(v=vs.85).aspx for details.

Revision history for this message
Michael Terry (mterry) wrote :

OK, we can not worry about tests. But I notice that we don't seem to properly apply hardening flags:
W: wsmancli: hardening-no-relro usr/bin/wseventmgr
W: wsmancli: hardening-no-relro usr/bin/wsman

I don't think we need a full security audit though.

Kent Baxley (kentb)
description: updated
Revision history for this message
Kent Baxley (kentb) wrote :

Added what I believe are the proper flags to the rules file so we don't get the relro warnings from lintian. I also cleaned up the copyright file a bit. Let me know if you need anything else.

Revision history for this message
Michael Terry (mterry) wrote :

Did you upload those flag changes?

Revision history for this message
Kent Baxley (kentb) wrote : Re: [Bug 1262290] Re: [MIR] wsmancli

Unfortunately I don't have upload rights, so, I'll need a sponsor.

On Wed, Jan 8, 2014 at 4:00 PM, Michael Terry
<email address hidden> wrote:
> Did you upload those flag changes?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1262290
>
> Title:
> [MIR] wsmancli
>
> Status in The Dell PowerEdge project:
> New
> Status in “wsmancli” package in Ubuntu:
> Incomplete
>
> Bug description:
> Please consider adding wsmancli to the main repository for Ubuntu
> Server.
>
> Availability - Latest upstream stable release was added to Universe
> for Trusty Tahr. Dell had previously been building unofficial ports
> of this package for Ubuntu for their server user base.
>
> Rationale - wsmancli provides a command-line interface for either
> interacting with a server running openwsman, and it can also be used
> for out-of-band administration of Dell PowerEdge 11G and 12G servers
> via the systems' integrated Dell Remote Access Controller (iDRAC ).
> Many of our users run Ubuntu on PowerEdge hardware.
>
>
> Lots of details here:
>
> http://en.community.dell.com/techcenter/b/techcenter/archive/2010/07/19
> /wsman-for-remote-management-of-dell-poweredge-11g-servers.aspx
>
> wsmancli also works with Intel's AMT technology:
> http://software.intel.com/en-us/articles/ws-management-and-intel-active-management-technology-a-primer
>
> An additional use case for wsmancli is remote Windows management via
> WinRM. See http://msdn.microsoft.com/en-
> us/library/aa384426(v=vs.85).aspx for details.
>
> Security - There currently are no open vulnerability reports on the
> package
>
> QA - The project is maintained upstream on sourceforge, with the
> latest release being 2.3.6, released in November 2012:
>
> http://sourceforge.net/projects/openwsman/files/wsmancli/
>
> There is an active development forum:
> http://sourceforge.net/mailarchive/forum.php?forum_name=openwsman-
> devel
>
> No exotic hardware is involved to use this software. The Dell DRAC
> devices are supported in Ubuntu and are IPMI 2.0 compliant. Intel AMT
> technology has been out for a while now and will work under linux with
> the right tools (wmancli and amttool).
>
> The following additional packages need to be pulled into main as well,
> since wsmancli depends on them:
>
> libopenwsman1
>
> I will file a separate request for libopenwsman1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dell-poweredge/+bug/1262290/+subscriptions

--
Kent Baxley
Field Engineer, Canonical
<email address hidden>

Revision history for this message
Kent Baxley (kentb) wrote :

I, unfortunately, don't have upload rights, so, I'll need someone to sponsor the changes.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Uploaded Kent's changes to trusty.

Changed in wsmancli (Ubuntu):
status: Incomplete → New
Michael Terry (mterry)
Changed in wsmancli (Ubuntu):
status: New → Fix Committed
Revision history for this message
Matthias Klose (doko) wrote :

asking ubuntu-server if that is still relevant

Changed in wsmancli (Ubuntu):
assignee: nobody → Ubuntu Server (ubuntu-server)
Revision history for this message
Matthias Klose (doko) wrote :

this depends on LP: #1262299, which is marked as incomplete. So setting this to incomplete as well.

Changed in wsmancli (Ubuntu):
status: Fix Committed → Incomplete
Revision history for this message
David Britton (dpb) wrote :

Ubuntu server will not be sponsoring this at this time.

Changed in wsmancli (Ubuntu):
status: Incomplete → Won't Fix
assignee: Ubuntu Server (ubuntu-server) → nobody
Jeff Lane (bladernr)
Changed in dell-poweredge:
status: New → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers