[FreezeExpcetionRequest] wslu 2.3.6 to 3.2.1

Bug #1895525 reported by Patrick Wu on 2020-09-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wslu (Ubuntu)
High
Unassigned

Bug Description

This is a freeze exception request;
1. This update is part of WSL team's Ubuntu WSL Onboarding Experience for 20.10 cycle;
2. This update is to match with the upstream version of wslu as other distributions (e.g., Alpine Linux);
3. Ubuntu version of `wslu` is very outdated and users are asking about missing features (e.g., wslact);
4. This also allow to address multiple bugs(#64, #66, #93, #94, #100, #113, #117, #118, #125, #129, #133, #138, #141, #143, #144 and #146 on GitHub);
5. This also contains improvements for future snapd on Ubuntu WSL support (#143 and #146 om GitHub).

Patrick Wu (callmepk) wrote :
Changed in wslu (Ubuntu):
milestone: none → ubuntu-20.10
Patrick Wu (callmepk) wrote :
Changed in wslu (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) wrote :

This is an isolated package which impacts only the WSL images, and following the upstream experience is sensible.

What kind of testing is this going to go through between now and release?

Changed in wslu (Ubuntu):
status: New → Incomplete
Patrick Wu (callmepk) wrote :

Hi Steve,

The testing will be going as the following:

1. checkout the ubuntu/master branch on wslu GitHub or launchpad repository;
2. running `autopkgtest path/to/folder -- null` locally with Ubuntu WSL 20.04 on WSL2/WSL1 on Windows machine;
3. View the result of the test, with 7 Windows Explorer open and 3 webpage open on the default browzer.

Here is a sample of local run result:
https://cdn.patrickwu.space/garage/screenshots/Screenshot%202020-09-18%20at%2012.46.54%20AM.png

Patrick Wu (callmepk) wrote :

^ The sample test run is also based on ubuntu/master 20.04 build running on top of Ubuntu 20.04.

Steve Langasek (vorlon) wrote :

Thanks, that sounds like an appropriate level of testing for this. FFe granted.

Changed in wslu (Ubuntu):
status: Incomplete → Confirmed
Changed in wslu (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wslu - 3.2.1-0ubuntu1

---------------
wslu (3.2.1-0ubuntu1) groovy; urgency=medium

  * Update from 2.3.6 to 3.2.1 to provide new features and
    address some issues (ffe lp: #1895525)
    - Documentation: add section 7 manpage: `wslu`
    - Documentation: updated manpage system
    - Documentation: New README language Esperanto
    - Project: updated build system
    - Project: versioning system update
    - Project: add separate Fedora Remix support
    - header: add `--verbose`
    - header: refactor the header in order to speed up
    - header: handling empty ~/.config/wslu/baseexec
    - header: use the proper color definition
    - header: fix `ubuntu.exe` detection issue
    - header: prevent localappdata not found in env
    - header: improvements on the system drive detection.
      (GH: #133, LP: #1888869)
    - header: fix badly generated shortcut issue (GH: #141)
    - wslact: brand new CLI
    - wslact: adding `--mount-options` for auto-mounting feature
    - wslact: fix an i18n related issue in time-sync feature
      (GH: #113 by @ricardosantos9521)
    - wslact: add back-compatibility for the auto-mounting feature.
    - wslusc: brand new helper script (GH: #93)
    - wslusc: brand new shortcut icon
    - wslusc: always use the absolute path (fixes #129)
    - wslusc: fixes a possible white space path issue
    - wslusc: add convert not found warning
    - wslusc: fix the problem that the previous version that GUI shortcut
      generated won't work.
    - wslusc: When TMP is empty, try TEMP
    - wslusc: fix an issue that wsl.exe execute with wrongly passed param
      (GH: #138)
    - wslfetch: colorbar expanded
    - wslfetch: `--no-colorbar` become `--colorbar`
    - wslfetch: speed up execution time (GH: #100)
    - wslfetch: new display for WSL with WSL version displayed
    - wslfetch: use the proper logo for Ubuntu
      (Reported by Martin Wimpress, LP: #1883920)
    - wslview: alias of `wslstart`, `wstart`, `wview` (GH: #64)
    - wslview: browser registration parameter change
    - wslview: handling file:/// protocol (GH: #66)
    - wslview: fix a mistake in `converted_file_path`
    - wslview: properly detect all different protocols and path styles
      (GH: #118)
    - wslview: mistake in calling a variable (fixes #118 again)
    - wslview: fix a bug that it won't open `file:///mnt/c/...`
      or `/mnt/c/...`
    - wslview: add wslview.desktop (GH: #143 and #146)
    - wslsys: Display Scaling Factor (help with Pengwin GH: #559)
    - wslsys: Windows Locale
    - wslsys: Windows Theme
    - wslsys: speed up execution time
    - wslsys: add WSL version option
    - wslsys: fix an issue in DPI scaling getting wrong value due to the API
      change in Latest fast ring insider build (Reported by @crramirez)
    - wslsys: fix an issue that the WSL Version shown is wrong.
    - package: missing call to `configure.sh`
    - package: fix alpine dependency issue (GH: #117)
    - tests: update the test system and tests. (GH: #125)

 -- Patrick Wu <email address hidden> Sun, 13 Sep 2020 22:36:33 +0800

Changed in wslu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments