Maintainer scripts fail due to unopkg lock file issues

Bug #220911 reported by Daniel Holbach on 2008-04-23
228
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Unknown
openoffice.org (Debian)
Invalid
Undecided
Unassigned
openoffice.org (Ubuntu)
High
Unassigned
Hardy
High
Chris Cheney
writer2latex (Debian)
Fix Released
Unknown
writer2latex (Ubuntu)
High
Unassigned
Hardy
High
Unassigned

Bug Description

Binary package hint: writer2latex

This seems to be a permutation of bug 200979, bug 218246 and bug 219703.

The unopkg call seems to fail in lots of different ways and on DVD installations this triggers a nasty "prerm failed" popup.

As a workaround I suggest adding "|| true" to the unopkg calls. If unopkg can't be fixed the installation should at least not fail or leave the dpkg world in a broken state.

Changed in writer2latex:
importance: Undecided → High
Daniel Holbach (dholbach) wrote :
Michael Vogt (mvo) wrote :
Daniel Holbach (dholbach) wrote :

If failed in amd64-dvd-ubiquity-de-autoresize-20080423, but not in amd64-dvd-ubiquity-de-oem-erasedisk-20080423.

Michael Vogt (mvo) wrote :

From dholbachs syslog:

Apr 23 07:42:33 ubuntu ubiquity: ENTFERNE OPENOFFICE.ORG-WRITER2LATEX ...^M
Apr 23 07:42:40 ubuntu ubiquity: REMOVING EXTENSION ORG.OPENOFFICE.LEGACY.WRITER2LATEX.UNO.PKG...
Apr 23 07:42:42 ubuntu ubiquity: ^M
Apr 23 07:42:42 ubuntu ubiquity: ERROR: ^M
Apr 23 07:42:42 ubuntu ubiquity: ^M
Apr 23 07:42:42 ubuntu ubiquity: UNOPKG FAILED.^M
Apr 23 07:42:42 ubuntu ubiquity: DPKG: FEHLER BEIM BEARBEITEN VON OPENOFFICE.ORG-WRITER2LATEX (--PURGE):^M
Apr 23 07:42:42 ubuntu ubiquity: UNTERPROZESS PRE-REMOVAL SCRIPT GAB DEN FEHLERWERT 1 ZURüCK^M
...
Apr 23 07:52:22 ubuntu ubiquity: DPKG: OPENOFFICE.ORG-JAVA-COMMON: ABHäNGIGKEITSPROBLEME, ABER ENTFERNE ES AUF ANFRAGE DENNOCH:^M
Apr 23 07:52:22 ubuntu ubiquity: OPENOFFICE.ORG-WRITER2LATEX HäNGT AB VON OPENOFFICE.ORG-JAVA-COMMON (>= 1:2.3.0~OOG680M1).^M
Apr 23 07:52:22 ubuntu ubiquity: ENTFERNE OPENOFFICE.ORG-JAVA-COMMON ...^M
Apr 23 07:52:22 ubuntu ubiquity: ENTFERNE BSH ...^M
Apr 23 07:52:22 ubuntu ubiquity: LöSCHE KONFIGURATIONSDATEIEN VON BSH ...^M
Apr 23 07:52:22 ubuntu ubiquity: PROCESSING TRIGGERS FOR LIBC6 ...^M
Apr 23 07:52:22 ubuntu ubiquity: LDCONFIG DEFERRED PROCESSING NOW TAKING PLACE^M
Apr 23 07:52:22 ubuntu ubiquity: FEHLER TRATEN AUF BEIM BEARBEITEN VON:^M
Apr 23 07:52:22 ubuntu ubiquity: OPENOFFICE.ORG-WRITER2LATEX^M

Daniel Holbach (dholbach) wrote :

Didn't fail in another amd64-dvd-ubiquity-de-autoresize-20080423 session.

Matthias Klose thought the failure might be related to a missing gij or openoffice.org-java-common - I'm not sure how such a situation could arise. In fact openoffice.org-writer2latex does not Pre-Depends on openoffice.org-common although it uses unopkg in its preinst.

Daniel Holbach (dholbach) wrote :

Please attach your complete syslog if you run into this issue too. The order of removal of packages might be relevant for this issue.

Chris Cheney (ccheney) wrote :

Good catch about the pre-depends. I don't know that this will solve the problem, but it probably should be a pre-depends like you say. I will talk to Rene about this as well to see what he thinks about the issue with not being install on a fresh system.

Chris Cheney (ccheney) wrote :

I have attached the upstream issue which I believe is the root cause of this problem. However, it is possible it may be only one of multiple causes.

Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :

Also good to review this to make sure we are doing everything properly:

http://fedoraproject.org/wiki/Packaging/OpenOffice.orgExtensions

Chris Cheney (ccheney) wrote :

IRC conv:

06:45 <@calc> caolan: do you happen to know if there is any fix for the unopkg --shared failing issue?
06:45 <@calc> caolan: i saw you were discussing it in the ooo bugtracker before
06:45 <@sewardj> kendy: so, I don't know if this is a duplicate or not, but ...
06:46 <@caolan> calc: what's failing in particular, there's a lot of problems with unopkg in a unix distro world vs the windows world from which it seems to have come
06:46 <@caolan> let me find my patch for the problems that plagued me
06:46 <@sewardj> kendy: my ooinstall fails with "ERROR: Missing files in function: remove_Files_Without_Sourcedirectory"
06:46 <@calc> caolan: it fails during package installation to register/unregister extensions
06:47 <@sewardj> kendy: in the logfile is: ERROR: Removing file libmsworkslx.so from file list. and ERROR: Removing file libwpgimportlx.so from file list.
06:47 <@_rene_> how exactly?
06:47 <@calc> caolan: presumably for locking reasons, but i am not certain what is causing it
06:47 <@_rene_> yes, it will fail if you have OOos lockfile there
06:47 <@_rene_> or it will fail if you have the extension incompletely removed and you tr to register it :)
06:47 <@calc> _rene_: yea i found the bug to request it stop using locking for --shared, wasn't sure if that would fix the entire problem or not
06:48 <@caolan> calc: _rene_: this might resolve your problems
                http://cvs.fedoraproject.org/viewcvs/*checkout*/devel/openoffice.org/openoffice.org-2.4.0.ooo86080.unopkg.bodge.patch
06:48 <@caolan> i.e. for "--shared" always use a temp dir for the lock and random crap it needs
06:48 <@caolan> avoids locking, avoids creating a ~/.openoffice.org2 belonging to root in a users home dir
06:48 <@calc> caolan: ah cool :)
06:49 <@caolan> avoids having no display if a11y is enabled with java as gcj
06:49 <@_rene_> we already use the -env stuff for UserProfile, ACCESSIBILITY etc
06:49 <@_rene_> "of course" only in the maintainer scripts, so if users do it they might run into the problem ;-(
06:49 <@calc> _rene_: this would fix the writing into user dir for locking issue, though i think?
06:50 <@caolan> I decided to dump it right into the unopkg itself for all users if they use shared
06:51 <@caolan> of course there is a complicated set of steps to be done for upgrading/removing etc extensions
                http://fedoraproject.org/wiki/Packaging/OpenOffice.orgExtensions
06:51 <@caolan> because the damnable unopkg will only remove the contents of packages when unopkg is run again, i.e. delete only schedules a removal
06:52 <@caolan> and OOo3 will move the uno_packages dir into a new location, so extensions registered with 2.0 will get lost when moving to 3.0 unless some distro-level magic is used to reuse the old 2.0 extensions dir
06:53 <@caolan> additionally I'd like to be able to *link* extensions in rather than copy when deployed, i.e.
                http://cvs.fedoraproject.org/viewcvs/*checkout*/devel/openoffice.org/openoffice.org-2.3.1.ooo83878.unopkg.enablelinking.patch
06:53 <@caolan> but upstream has little enthusiasm for that for some reason

Changed in openoffice.org:
milestone: none → ubuntu-8.04.1
importance: Undecided → High
status: New → In Progress
Changed in writer2latex:
milestone: none → ubuntu-8.04.1
Chris Cheney (ccheney) wrote :

I milestoned this bug for both OOo and w2l for 8.04.1 but I think it will probably only need actual fixing in OOo. Though it will need testing in w2l obviously.

Changed in openoffice:
status: Unknown → In Progress
Changed in writer2latex:
status: Unknown → Fix Released
Colin Watson (cjwatson) wrote :

Chris: could you add the || true even if you can fix it in other ways? It would be good to make the prerm/postrm as robust as possible, as the consequences of failure are pretty awkward.

(Not disagreeing at all that unopkg should be fixed!)

  • unnamed Edit (1.1 KiB, text/html; charset=ISO-8859-1)

Don't think this went where intended...you might want to re-xmit...

    Love,
            Wook

On Fri, May 16, 2008 at 1:40 AM, Colin Watson <email address hidden>
wrote:

> Chris: could you add the || true even if you can fix it in other ways?
> It would be good to make the prerm/postrm as robust as possible, as the
> consequences of failure are pretty awkward.
>
> (Not disagreeing at all that unopkg should be fixed!)
>
> --
> Maintainer scripts of openoffice.org-writer2latex fail
> https://bugs.launchpad.net/bugs/220911
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Wook,

Nope cjwatson's comment was about the fact that unopkg is not very good and so we probably should '|| true' the command to make it always pass.

Colin,

I can add it but it would potentially leave the installed package in an unusable state, of course that would probably still be better than the current situation where it causes package system to barf. :-( I will definitely be fixing or at least applying the patch that should fix the problem for 8.04.1.
 It works around the issue by creating a temporary location for the .openoffice.org dotdir so there will be no chance of a lockfile to conflict with.

Chris

Colin Watson (cjwatson) on 2008-05-20
Changed in openoffice.org:
assignee: nobody → ccheney
Martin Pitt (pitti) on 2008-05-28
Changed in openoffice.org:
milestone: ubuntu-8.04.1 → none
status: In Progress → Fix Committed
Changed in writer2latex:
milestone: ubuntu-8.04.1 → none
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in writer2latex:
milestone: none → ubuntu-8.04.1
status: Fix Committed → New
Steve Langasek (vorlon) on 2008-05-30
Changed in openoffice.org:
milestone: none → ubuntu-8.04.1
Changed in writer2latex:
milestone: ubuntu-8.04.1 → none
Steve Langasek (vorlon) on 2008-06-02
Changed in openoffice.org:
milestone: ubuntu-8.04.1 → none
Chris Cheney (ccheney) wrote :

This should be fixed in 1:2.4.1~ooh680m14-1ubuntu1 and 1:2.4.1~rc2-1ubuntu1. I accidentally dropped the patch in 1:2.4.1~rc1-1ubuntu1 but it is back now and won't accidentally disappear again since I committed it into ooo-build svn as well.

Thanks,

Chris

  • unnamed Edit (1.2 KiB, text/html; charset=iso-8859-1)

Thank you

----- Mensaje original ----
De: Chris Cheney <email address hidden>
Para: <email address hidden>
Enviado: martes, 3 de junio, 2008 20:32:20
Asunto: [Bug 220911] Re: Maintainer scripts fail due to unopkg lock file issues

** Summary changed:

- Maintainer scripts of openoffice.org-writer2latex fail
+ Maintainer scripts fail due to unopkg lock file issues

--
Maintainer scripts fail due to unopkg lock file issues
https://bugs.launchpad.net/bugs/220911
You received this bug notification because you are a direct subscriber
of the bug.

      ____________________________________________________________________________________
Yahoo! Deportes Beta
¡No te pierdas lo último sobre el torneo clausura 2008! Entérate aquí http://deportes.yahoo.com

Steve Langasek (vorlon) wrote :

I can confirm that this fixes the problem with openoffice.org-writer2latex, which was failing to install for me here until the fix became available.

Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: In Progress → Triaged
Changed in writer2latex:
status: New → Invalid
status: New → Invalid
Martin Pitt (pitti) wrote :

The hardy-proposed SRU was copied to intrepid some time ago.

Changed in openoffice.org:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in openoffice.org:
status: Fix Committed → Fix Released
Changed in openoffice:
status: In Progress → Invalid
Changed in openoffice.org (Debian):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.