package wpasupplicant 0.7.3-6ubuntu1 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1. Upgraded 11.10 to 12.04 alpha 2. 11.10 install was via alternate CD using wifi. Wifi connection working but device not manged by wifi control in menu bar.

Bug #935678 reported by Dan Rollason on 2012-02-18
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
wpasupplicant (Ubuntu)
Undecided
Unassigned

Bug Description

Upgraded 11.10 to 12.04 alpha. 11.10 install was via alternate CD using wifi. Wifi connection working but device not manged by wifi control in menu bar as it was in the state left by the alternate install.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: wpasupplicant 0.7.3-6ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sat Feb 18 18:58:22 2012
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
SourcePackage: wpasupplicant
Title: package wpasupplicant 0.7.3-6ubuntu1 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-02-18 (0 days ago)

Dan Rollason (dan-rollason) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wpasupplicant (Ubuntu):
status: New → Confirmed
Anthony Fok (foka) wrote :
Download full text (3.2 KiB)

I tried the upgrade to 12.04 LTS (beta) on 2012-03-16, and experienced the same problem, and Update Manager got stuck with "wpasupplicant" and its dependencies "network-manager", "network-manager-gnome" and "ubuntu-desktop" left uninstalled.

I then tried to fix the problem manually by using "sudo apt-get -f install", and saw the following:

================================================================
Setting up wpasupplicant (0.7.3-6ubuntu1) ...
mv: `/lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.wlan0.pid' and `/run/sendsigs.omit.d/wpasupplicant.wpa_supplicant.wlan0.pid' are the same file
dpkg: error processing wpasupplicant (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of network-manager:
 network-manager depends on wpasupplicant (>= 0.7.3-1); however:
  Package wpasupplicant is not configured yet.
dpkg: error processing network-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-gnome:
 network-manager-gnome depends on network-manager (>= 0.8.998); however:
  Package network-manager is not configured yet.
dpkg: error processing network-manager-gnome (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on wpasupplicant; however:
  Package wpasupplicant is not configured yet.
dpkg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                    No apport report written because MaxReports is reached already
                                  Errors were encountered while processing:
 wpasupplicant
 network-manager
 network-manager-gnome
 ubuntu-desktop
E: Sub-process /usr/bin/dpkg returned an error code (1)
================================================================

Hmm... looks like a problem with "/lib/init/rw" to "/run" migration, which I cannot quite remember when it happened on Ubuntu.
On my computer, I see:

    $ ls -l /lib/init/rw
    lrwxrwxrwx 1 root root 4 Oct 17 08:11 /lib/init/rw -> /run

Checking wpasupplicant postinst script /var/lib/info/dpkg/wpasupplicant.postinst, Lines 27-36:

  # Migrate existing sendsigs omission pid files to /run
  if [ -d /run/sendsigs.omit.d/ ] && \
     [ -d /lib/init/rw/sendsigs.omit.d/ ]; then
   for f in /lib/init/rw/sendsigs.omit.d/wpasupplicant.*.pid
   do
    if [ -f "$f" ]; then
     mv "$f" /run/sendsigs.omit.d/
    fi
   done
  fi

The "mv" command above fails because /lib/init/rw is a symlink to /run, hence the error:

    mv: `/lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.wlan0.pid' and
           `/run/sendsigs.omit.d/wpasupplicant.wpa_supplicant.wlan0.pid' are the same file

As a quick workaround, I changed

    mv "$f" /run/sendsigs.omit.d/

to

    mv "$f" /run/sendsigs.omit...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wpasupplicant - 0.7.3-6ubuntu2

---------------
wpasupplicant (0.7.3-6ubuntu2) precise; urgency=low

  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 16 Mar 2012 09:55:12 -0400

Changed in wpasupplicant (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers