wpa_supplicant crashed with SIGSEGV in nla_put()

Bug #918415 reported by Anders Kaseorg on 2012-01-18
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
wpasupplicant (Ubuntu)
Medium
Unassigned

Bug Description

Not sure how to reproduce.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: wpasupplicant 0.7.3-5ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sat Jan 14 17:53:49 2012
ExecutablePath: /sbin/wpa_supplicant
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcCmdline: /sbin/wpa_supplicant -u -s -O /var/run/wpa_supplicant
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0x7fd9489855c2 <__memcpy_ssse3_back+9874>: lddqu 0x2a(%rsi),%xmm0
 PC (0x7fd9489855c2) ok
 source "0x2a(%rsi)" (0x0000002a) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: wpasupplicant
StacktraceTop:
 nla_put () from /lib/libnl-3.so.200
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: wpa_supplicant crashed with SIGSEGV in nla_put()
UpgradeStatus: Upgraded to precise on 2011-11-16 (63 days ago)
UserGroups:

Anders Kaseorg (andersk) wrote :

StacktraceTop:
 nla_put (msg=0x25df420, attrtype=<optimized out>, datalen=58, data=0x0) at /usr/include/x86_64-linux-gnu/bits/string3.h:52
 wpa_driver_nl80211_scan (priv=<optimized out>, params=0x7fffe999bb60) at ../src/drivers/driver_nl80211.c:1676
 wpa_drv_scan (params=0x7fffe999bb60, wpa_s=<optimized out>) at driver_i.h:78
 wpa_supplicant_trigger_scan (wpa_s=0x24903b0, params=0x7fffe999bb60) at scan.c:195
 bgscan_simple_timeout (eloop_ctx=<optimized out>, timeout_ctx=<optimized out>) at bgscan_simple.c:56

Changed in wpasupplicant (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Anders Kaseorg (andersk) on 2012-01-18
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wpasupplicant (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers