merge patch for segfault when using smartcards with NetworkManager

Bug #528087 reported by David Smith on 2010-02-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wpasupplicant (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

[Impact]
<fill me in with explanation of severity and frequency of bug on users and justification for backporting the fix to the stable release>

[Development Fix]
Fixed upstream in the precise version of wpasupplicant.

[Stable Fix]
lp:~mathieu-tl/ubuntu/lucid/wpasupplicant/dbus-pkcs11-eapol

[Text Case]
<fill me in with detailed *instructions* on how to reproduce the bug. This will be used by people later on to verify the updated package fixes the problem.>
1.
2.
3.
Broken Behavior:
Fixed Behavior:

[Regression Potential]
<fill me in with a discussion of likelihood and potential severity of regressions and how users could get inadvertently affected.

[Original Report]
When using wpasupplicant with NetworkManager and PKCS#11 smartcard devices (see lp bug #120363), there is a segfault in wpasupplicant when the smartcard parameters are changed over dbus. A fix for this has been merged upstream, http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=d7199342f0633b5ab147dca5b885530fe32ceaeb;hp=355d36a7bf5b14df80e3f73d71b9089008fd517b) and is in Debian sid. It is a tiny change, the diff is very easy to understand. Please grant a freeze exemption to merge this patch in lucid.

Related branches

Changed in wpasupplicant (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Jeremy Zimmer (jeremyz) on 2010-02-26
tags: added: glucid
tags: added: lucid
removed: glucid
tags: added: glucid

It's too late for a freeze exception for Lucid, but this is possibly worth an SRU.

I've linked a branch which includes that patch, based on the current version of wpasupplicant in Lucid. I won't be able to test this myself for lack of smartcards, so when it hits lucid-proposed please test it and report back here.

Bryce Harrington (bryce) on 2012-01-27
Changed in wpasupplicant (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
Bryce Harrington (bryce) on 2012-01-27
description: updated
Martin Pitt (pitti) wrote :

Please fix this in precise first.

This is already in precise.

The patch used is an old committed patch to wpasupplicant which is now equivalent to the code in wpas_dbus_iface_set_smartcard_modules() at line 1420 in wpa_supplicant/dbus/dbus_old_handlers.c (there simply has been a rather large number of changes since 0.6.9).

Martin Pitt (pitti) on 2012-02-21
Changed in wpasupplicant (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

Mathieu, could you please fill out the bug description with the missing information necessary for this SRU to go forward?

description: updated

Hello David, or anyone else affected,

Accepted wpasupplicant into lucid-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in wpasupplicant (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed

I fixed the description to the best of my knowledge. David Smith reported the issue and may be in a better position to further flesh out the procedure for testing this fix or it's exact regression potential.

Bartosz Kosiorek (gang65) wrote :

After install package from Proposed I do not notice crash any more.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wpasupplicant - 0.6.9-3ubuntu3.1

---------------
wpasupplicant (0.6.9-3ubuntu3.1) lucid-proposed; urgency=low

  * debian/patches/git_dbus_smartcard_eapol_d719934.patch: cherry-pick a patch
    from Git to correctly re-initialize pointers in the WPA state machine to
    avoid crashing when smartcard parameters change over DBUS (LP: #528087)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 06 Jan 2012 11:49:41 -0500

Changed in wpasupplicant (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers