Ubuntu

wpasupplicant doesn't connect

Reported by Cillean on 2009-03-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wpasupplicant (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wpasupplicant

wpasupplicant in Jaunty (0.6.6-2) is unable to connect to WPA/WPA2 networks on certain hardware, e.g. EeePC 1000H. Personally, I own an AVM FRITZ! WLAN USB Stick (ID 057c:6201) driven by ndiswrapper.

I have tried different keys, as well as network-manager-gnome and wicd. Both seem to be able to connect (NetworkManager gets the second lamp green), but are unable to retrieve an IP address. In the system log of my router (AVM FRITZ! Box Fon WLAN 7050) there's just "authentication failed", but the key I pasted was correct. NetworkManager will abort the connection attempt after nearly 60 seconds.

The connection was okay in Intrepid. Connection works when using WEP or no encryption.

Attached is the part of syslog which documents the connection attempt.

Cillean (mirpud) wrote :
UbuntuFlo (ubuntuflo) wrote :

I can confirm this bug and the above mentioned behaviour with an Eee PC 1000H, network-manager and enabled WPA2. Same WPA2 key works with my router and another laptop flawlessly though.

Manufacturer of the Wifi-Card is Ralink, it comes with a rt2860 driver. Adam states as a known issue: "Poor connectivity when using WPA2 encrypted access points. " (http://www.array.org/ubuntu/rt2860.html)

He has built a package for Intrepid to provide WPA2-encrypted Wifi for Eee-PCs (http://www.array.org/ubuntu/dists/intrepid/eeepc/binary-i386/rt2860-dkms_1.7.1.1_all.deb) which works fine with Intrepid but certainly not with Jaunty...

Regards, Flo

Ren (milchmannag) wrote :

I have a similar bug. With a Netgear WG311v3 (drivers loaded with ndiswrapper) in Ubuntu 9.04 64bit Beta I can connect to a network without encryption or with WEP.
A connection with WPA or WPA2 does not work.

derJens (jens-bekemeierweb) wrote :

Confirm this Bug with an EEE PC 1000h too. Connection with WPA or WPA2 doesn't work, no connection to the router possible.

Regards Jens

The same bug as described for the EeePC 1000H and WPA/WPA2 wireless networks can be confirmed for the EeePC 901 model, too. In my case, the 901 runs on a fully updated (via wired interface) 9.04/Jaunty beta, the wireless network uses WPA2 and advertises its SSID.

Best regards,
Martin

Ren (milchmannag) wrote :

Solved for me. With an alternative driver the Netgear WG311v3 works alo with WPA/WPA2 and not just WEP.

Helmuth Gronewold (cisa) wrote :

Did you try to connect when you are near the AP?

https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/474692

Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 348008 and any other logs that are relevant for this particular issue.

Changed in wpasupplicant (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for wpasupplicant (Ubuntu) because there has been no activity for 60 days.]

Changed in wpasupplicant (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments