PS3: NetworkManager doesn't list available wireless networks even though "iwlist wlan0 scan" does

Bug #289977 reported by Dan Munckton on 2008-10-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Colin Watson
Ubuntu PS3 Port
Low
Dan Munckton
wpasupplicant (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

As summary. Manual setup using the "Connect to hidden wireless network" option works well though, so not a show stopper. Will attach logs later.

Experienced on Intrepid as of 2008-10-24.

Dan Munckton (munckfish) on 2008-10-27
Changed in ubuntu-ps3-port:
status: New → Incomplete
Changed in network-manager:
status: New → Incomplete
Changed in ubuntu-ps3-port:
importance: Undecided → Low
Dan Munckton (munckfish) on 2008-10-27
description: updated
Dan Munckton (munckfish) wrote :

Suggested text for release notes:

"On PS3 NetworkManager does not list available wireless networks. However it is possible to connect to a wireless network with a known SSID using the 'connect to hidden wireless network' option."

Alexander Sack (asac) wrote :

guessing that this is a wpasupplicant issue as NM does all its scanning through wapsupplicant.

What driver/chipset does PS3 use? Please reproduce and attach your complete /var/log/wpa_supplicant.log

Dan Munckton (munckfish) wrote :

Attaching /var/log/syslog from the PS3. Note very interesting messages in the log:

Oct 28 20:45:08 ps3 NetworkManager: <info> wlan0: driver does not support SSID scans (scan_capa 0x00).

This is blatantly not true as a network scan can be successfully carried out with "iwlist scan".

The PS3 network driver is 'ps3_gelic'.

Dan Munckton (munckfish) wrote :

On Tue, Oct 28, 2008 at 10:02:41PM -0000, Dan Munckton wrote:
> Attaching /var/log/syslog from the PS3. Note very interesting messages
> in the log:
>
> Oct 28 20:45:08 ps3 NetworkManager: <info> wlan0: driver does not
> support SSID scans (scan_capa 0x00).
>
> This is blatantly not true as a network scan can be successfully carried
> out with "iwlist scan".

Well, the scan_capa doesn't really say "we can/cannot scan", it refers
to advanced features wrt scanning which a driver should have nowadays.

Usually scan_capa = 0 indicates that the driver is either old or is in
bad shape. Drivers that use the new in-kernel mac stack all should
have scan_capa > 0, fwiw.

Anyway, even with scan_capa=0x0 basic scanning is done by NM itself,
but it definitly shows that the driver isn't on top of the latest and
greatest - which probably is the reason why this doesnt really work.

 - Alexander

Thanks that's loads to be going along with. I'll do some experimenting
and see what I can find.

It doesn't surprise me the driver appears old, the ports kernels use
2.6.25. NCommander has started work on a 2.6.27 based kernel for Jaunty,
I'm going to test it on PS3 soon and I'll see if this improves the
situation.

On Wed, Oct 29, 2008 at 03:29:05PM -0000, Dan Munckton wrote:
> Thanks that's loads to be going along with. I'll do some experimenting
> and see what I can find.
>
> It doesn't surprise me the driver appears old, the ports kernels use
> 2.6.25. NCommander has started work on a 2.6.27 based kernel for Jaunty,
> I'm going to test it on PS3 soon and I'll see if this improves the
> situation.
>

Yes, there should be considerable improvements ... though not sure for
the PS3 driver ;)

 - Alexander

Colin Watson (cjwatson) wrote :

Release notes text added:

== PlayStation 3 issues ==

There are a variety of other known issues affecting Play``Station 3 systems, documented in more detail in the [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]]. They include:

 * To get back to the Sony Play``Station 3 XMB operating system from the boot prompt, users need to type `game` and press the Return key ([[https://launchpad.net/bugs/277839|bug 277839]]). If this is for some reason not possible, carrying out a hard-reset (see PS3 instruction manual) will return to the XMB on next run.
 * Users may occasionally see an intermittent shutdown hang with a message like "IRQ 50: nobody cared". The problem has been reported upstream. Press and hold the PS3 power button until you hear 2 beeps will force power off. The system will boot normally on next run ([[https://launchpad.net/bugs/220370|bug 220370]]).
 * Network``Manager does not list available wireless networks, although it is possible to connect to a wireless network with a known SSID using the "connect to hidden wireless network" option ([[https://launchpad.net/bugs/289977|bug 289977]]); and it cannot connect to WPA/WPA2 wireless networks, although WEP works ([[https://launchpad.net/bugs/289982|bug 289982]]).

Changed in ubuntu-release-notes:
assignee: nobody → kamion
status: New → Fix Released
Dan Munckton (munckfish) wrote :

Have identified the following 3 commit set in 2.6.27 which **may** be the solution to this problem:

7fd871edf437362b62ddd807542638cbda8d8a39 PS3: gelic: Add support for ESSID scan
f409e348005693016281bf29535c9d0a91b21f77 PS3: gelic: Deprecate the private ioctls in the gelic driver
04b2046c856e36c3c9cf382adb2c0bc8ba780cf7 PS3: gelic: Use the new PMK interface in the gelic driver

And the following thread which explains a little more about them:

http://marc.info/?l=linux-wireless&m=121213332232618&w=2

I also find them in the work-in-progress section of Geoff's 2.6.26-stable branch of this patches tree:

http://git.kernel.org/?p=linux/kernel/git/geoff/ps3-linux-patches.git;a=tree;f=ps3-wip;h=38960dd53f645947d008b0a5005f5e69b1ebdf3e;hb=v2.6.26-stable

So plenty of patches to try. Will recompile and test these as soon as I can.

Dan Munckton (munckfish) on 2008-11-03
Changed in ubuntu-ps3-port:
assignee: nobody → munckfish
status: Incomplete → In Progress
Dan Munckton (munckfish) wrote :

Ok backported those commits this week, but no joy. Tried out the new 2.6.27 based Jaunty ports kernel and suddenly scan list appears in NM. Clearly I need some other commits too. Will try to work out which this week.

Alexander Sack (asac) wrote :

On Fri, Nov 07, 2008 at 09:55:10PM -0000, Dan Munckton wrote:
> Ok backported those commits this week, but no joy. Tried out the new
> 2.6.27 based Jaunty ports kernel and suddenly scan list appears in NM.
> Clearly I need some other commits too. Will try to work out which this
> week.
>

Any update on this?

 - Alexander

dopple (graham-macleod) wrote :

Has anyone found a resolution for this yet?

Dan Munckton (munckfish) wrote :

I can thankfully say this issue is solved in Jaunty. The 2.6.28 kernel includes the necessary changes in the ps3_gelic_wireless driver to support the WEXT interface properly. So NetworkManager now shows the wireless scan list. Closing.

Changed in wpasupplicant:
status: Incomplete → Invalid
Changed in ubuntu-ps3-port:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers