[ndiswrapper] [acx] [netgear wg311v2] fails to associate

Bug #102385 reported by PearzooPeter on 2007-04-03
20
Affects Status Importance Assigned to Milestone
wpasupplicant (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wpasupplicant

Hi,

I'm not sure if I should be logging bugs for a beat release, but I hope it helps.

Running Feisty Beta on two machines, one with Intel pro wireless and one with Netgear wg311v2 (acx).

No problems on Intel Pro wireless connecting to the WPA Wireless LAN. (No ndiswrapper required)

Machine with Netgear wg311v2 using ndiswrapper 1.9 and wpa_supplicant 0.5.7 fails to associate with access point. No errors in dmesg, syslog logs retry after retry but fails to associate. Same card was working great on Edgy.

I've tried different versions of ndiswrapper and wpasupplicant with the same result, have not been able to try different version of Network-Manager. I have tried setting up wpa_supplicant manually without network manager, but with no luck. There I get endless loops of association errors. Sadly I did not jot them down, but if it helps I can re-create that.

Reinhard Tartler (siretart) wrote :

please attach a debug log (use parameters -dd), and attach your wpa_supplicant configuration file to this bug.

Changed in wpasupplicant:
status: Unconfirmed → Needs Info
PearzooPeter (peter5-pearzoo) wrote :
Download full text (4.0 KiB)

Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'ndiswrapper' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line: 1 - start of a new network block
ssid - hexdump_ascii(len=7):
     50 45 41 52 5a 4f 4f PEARZOO
proto: 0x1
key_mgmt: 0x2
pairwise: 0x8
group: 0x8
PSK (ASCII passphrase) - hexdump_ascii(len=21): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='PEARZOO'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=21 WE(source)=18 enc_capa=0x5
  capabilities: key_mgmt 0x5 enc 0x7
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:0f:b5:04:a4:55
Driver does not support WPA.
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
Setting scan request: 0 sec 100000 usec
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 970 bytes of scan results (4 BSSes)
Scan results: 4
Selecting BSS from priority group 0
0: 00:18:4d:c7:1f:ae ssid='PEARZOO' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
   selected based on WPA IE
Trying to associate with 00:18:4d:c7:1f:ae (SSID='PEARZOO' freq=2452 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2 proto 1
WPA: set AP WPA IE - hexdump(len=26): dd 18 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02 00 00
WPA: clearing AP RSN IE
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
Association request to the driver failed
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Authentication with 00:00:00:00:00:00 timed out.
Added BSSID 00:18:4d:c7:1f:ae into blacklist
State: ASSOCIATING -> DISCONNECTED
wpa_driver_wext_set_operstate: o...

Read more...

PearzooPeter (peter5-pearzoo) wrote :

I hope this helps, is there any more info that you require?

Damien Challet (dchallet) wrote :

I confirm this bug on Feisty final. Same story (OK with Edgy, does not work with Feisty), does not associate with WPA.

Reinhard Tartler (siretart) wrote :

according to http://thread.gmane.org/gmane.linux.drivers.hostap/15839, it should help if you guys restrict usage of TKIP (wpa1 only). could you please read the linked thread retry again?

Reinhard Tartler (siretart) wrote :

08:51:16 < crimsun> siretart: I do.
08:51:21 < crimsun> Do you need something tested?
08:51:57 < siretart> crimsun: it's about bug #108013
08:52:23 < siretart> I can't really believe it, and I think I've found something relevant on the upstream mailing list
08:52:26 < crimsun> wpa_supplicant in 7.04 definitely works with ndiswrapper.
08:52:46 < crimsun> I've got an unfortunate bcm4311
08:53:07 < siretart> ok, then the upstream post ist most probably correct

tknieper (tobias-knieper) wrote :

I gave current ndiswrapper-utils-1.9 and wpasupplicant packages from gutsy a try but had no luck. Still the same issue, pairing needs endless tries till it succeeds.

See also my previous comment at the dup:
https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/108013/comments/9

Regards,
Tobias

Nanley Chery (nanoman) on 2007-09-18
Changed in wpasupplicant:
status: Incomplete → Confirmed
Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 102385 and any other logs that are relevant for this particular issue.

Changed in wpasupplicant (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for wpasupplicant (Ubuntu) because there has been no activity for 60 days.]

Changed in wpasupplicant (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers