dbus errors, frequent roaming and unstable connectivity

Bug #1879087 reported by Thomas M Steenholdt on 2020-05-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wpa (Ubuntu)
High
Unassigned
Focal
High
Unassigned

Bug Description

* Impact
extra roaming events are been generated

* Test case
check the output of `journalctl -lu wpa_supplicant`, it shouldn't have those warnings
dbus: wpa_dbus_property_changed: no property RoamComplete in object /fi/w1/wpa_supplicant1/Interfaces/3

the roaming events should not be too frequent

* Regression potential
check that wifi connection keep working correctly

--------------

When using this version of wpa_supplicant with my company WPA2-Enterprise wireless setup, I'm experiencing far too frequent roaming events (even when not moving around) accompanied by hiccups in connectivity. I also see these messages in the wpa_supplicant log:

dbus: wpa_dbus_property_changed: no property RoamComplete in object /fi/w1/wpa_supplicant1/Interfaces/3
dbus: wpa_dbus_property_changed: no property RoamTime in object /fi/w1/wpa_supplicant1/Interfaces/3
dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/3

Having done a little research, at least the dbus errors seem to be fixed by this commit upstream:

https://w1.fi/cgit/hostap/commit/wpa_supplicant/dbus/dbus_new.c?id=23d87687c2428f3b94865580b0d33e05c03e6756

So I built a version of wpa_supplicant including this particular patch and installed on my machine. Apart from solving the dbus errors completely, it seems to have had a positive impact on the frequent roaming and unstable connectivity as well (I've run for a day with no burst of roaming events at all, where they used to happen every few minutes most of the time.)

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: wpasupplicant 2:2.9-1ubuntu4
ProcVersionSignature: Ubuntu 5.4.0-31.35-generic 5.4.34
Uname: Linux 5.4.0-31-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: GNOME
Date: Sat May 16 16:47:27 2020
InstallationDate: Installed on 2020-05-12 (4 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: wpa
UpgradeStatus: No upgrade log present (probably fresh install)

Thomas M Steenholdt (tmus) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report and indicating this patch, sounds like an useful fix to cherry pick indeed

Changed in wpa (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

I've uploaded the fix and a stable update, improving the description for a better testcase would be useful though if you have an idea how to trigger the issue and test the fix

description: updated
Thomas M Steenholdt (tmus) wrote :

Thank you for taking care of this so swiftly.

I don't believe I have much to add to the test-case. From testing locally I can see that the warnings disappear from the log and the connection _seems_ more stable. I underscore _seems_ because I have not been able to figure out which other parts of the system are actually using these particular dbus messages, if any. If nobody is actually using these, the perceived improvement could be placebo.

I will keep testing though, because I've generally been struggling with a stable wifi connection on 20.04.

Thanks again.

Steve Langasek (vorlon) wrote :

> the roaming events should not be too frequent

That's not an objective test case. Please provide a clear test case that anyone should be able to follow to determine whether this bug has been fixed.

description: updated
Changed in wpa (Ubuntu Focal):
status: New → Incomplete
Mathew Hodson (mhodson) on 2020-05-23
Changed in wpa (Ubuntu Focal):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wpa - 2:2.9-1ubuntu7

---------------
wpa (2:2.9-1ubuntu7) groovy; urgency=medium

  * debian/patches/git_roaming_interface.patch:
    - backport upstream fix 'dbus: Move roam metrics to the correct
      interface', should reduces the number of events (lp: #1879087)

 -- Sebastien Bacher <email address hidden> Wed, 20 May 2020 19:03:27 +0200

Changed in wpa (Ubuntu):
status: Fix Committed → Fix Released
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

>> the roaming events should not be too frequent

> That's not an objective test case. Please provide a clear test case that anyone should be able to follow to determine whether this bug has been fixed.

I've edited the description to remove this line, the rest of the testcase should be explicit enough. I've also reuploaded including an extra fix so the item is back in the queue and should be ready to be reviewed

Changed in wpa (Ubuntu Focal):
status: Incomplete → In Progress

Hello Thomas, or anyone else affected,

Accepted wpa into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wpa/2:2.9-1ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wpa (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Sebastien Bacher (seb128) wrote :

@Thomas, any chance to give the SRU a try and tell us how it works for you?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wpa - 2:2.9-1ubuntu4.1

---------------
wpa (2:2.9-1ubuntu4.1) focal; urgency=medium

  * debian/patches/git_roaming_interface.patch:
    - backport upstream fix 'dbus: Move roam metrics to the correct
      interface', should reduces the number of events (lp: #1879087)
  * debian/NetworkManager/no-mac-addr-change.conf:
    - remove configuration options that aren't needed and were copied to
      the wrong section, fixes warnings in the log (lp: #1826639)
  * debian/patches/Check-for-FT-support-when-selecting-FT-suites.patch:
    - Backport upstream fix "Check for FT support when selecting FT suites"
      to fix drivers without FT support, thanks Kai-Heng Feng (lp: #1881549)

 -- Sebastien Bacher <email address hidden> Wed, 20 May 2020 13:01:53 +0200

Changed in wpa (Ubuntu Focal):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

Apologies for releasing this one early, I have fat-fingered the sru-release command for the wrong package. This was all by accident... That being said, I don't want to revert this if not needed. Could someone please double-check if this bug is fixed in the (now) focal-updates package, and if not, re-open this bug for future fixing?

I need coffee...

Thomas M Steenholdt (tmus) wrote :

I've been looking for the package but cannot seem to find it for testing. Please help me find it and I will test it immediately.

Thomas M Steenholdt (tmus) wrote :

Never mind - Somehow my local package simply looked newer from a versioning perspective. I found the right version and as far as I can tell the problems are gone in this version.

I have not seen any of the dbus messages and roaming works better (less erratic) here.

Thanks a lot for getting this fix in.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers