Wi-Fi connection silently disconnects, requires manual reconnection

Bug #1707543 reported by jeremy-list on 2017-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
New
Undecided
Unassigned
wpa (Ubuntu)
Undecided
Unassigned

Bug Description

To replicate:
Attempt to use a secured Wi-Fi access point continuously.

Expected results:
The network interface should remain usable as long as possible, and automatically attempt to reconnect when disconnected.

Observed results:
The network will remain connected for a while, then stop sending or receiving packets. If gnome system monitor is running at the moment when the connection stops working, it will become unresponsive for about 30 seconds. Network manager will continue to report the interface as connected, but it will not accept traffic in either direction. Using the network manager gnome applet to reconnect will make the network usable again for a while (between two seconds and three hours, somewhat random but the average time decreasing until reboot)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: wpasupplicant 2.4-0ubuntu6
ProcVersionSignature: Ubuntu 4.10.0-28.32~16.04.2-generic 4.10.17
Uname: Linux 4.10.0-28-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Jul 31 10:51:31 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-07-22 (8 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
SourcePackage: wpa
UpgradeStatus: No upgrade log present (probably fresh install)

jeremy-list (quick-dudley) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers