periodically after suspend/resume wpasupplicant fails to authenticate

Bug #1550538 reported by Jared Dominguez on 2016-02-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wpa (Ubuntu)
Undecided
Unassigned

Bug Description

After suspending and resuming, periodically wpasupplicant fails to reauthenticate. I'm prompted for a password to reconnect. I enabled debugging for wpasupplicant. Something that draws attention is seeing "wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect". This is with the Ubuntu 14.04 OEM image for the Dell Precision 5510. All updates have been installed.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: wpasupplicant 2.1-0ubuntu1.4 [modified: usr/share/dbus-1/system-services/fi.w1.wpa_supplicant1.service]
ProcVersionSignature: Ubuntu 3.19.0-33.38~14.04.1-generic 3.19.8-ckt7
Uname: Linux 3.19.0-33-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Feb 26 13:38:06 2016
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-trusty-amd64-osp1-20150721-1
InstallationDate: Installed on 2016-02-25 (1 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 20150721-23:28
SourcePackage: wpa
UpgradeStatus: No upgrade log present (probably fresh install)

The failure was seen with WPA2 Personal with an Aruba access point.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wpa (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers